IRC channel logs

2015-06-28.log

back to list of logs

***karswell` is now known as karswell
***karswell` is now known as karswell
<paron_remote>hello #guile
<_amz3_>héllo guilers :)
<_amz3_>is it possible to create a pair with an empty list as value
<_amz3_>(car my-pair) is for instance 'label
<_amz3_>and (cdr my-pair) is '() the empty list
<amz3>my used to work with this I' not sure what i've done to break it
<ft>(cons 'label '())
<amz3>this creates a list
<ft>Yes. That's what it is. :)
<ft>(cdr (list 'label))
<amz3>ok I try again my code is so messy
<amz3>woot!
<amz3>this is another topic
<amz3>It tried rnrs7 (?) msgpack that can be found on github
<amz3>they work :)
<amz3>ahha less code to write :D
<amz3> https://github.com/ktakashi/r6rs-msgpack
<amz3>the only thing is that the licensing doesn't seem to be compatible with gpl/lgpl since it requires mentions
<amz3>not sure it's compatible
<ArneBab_>amz3: do you mean the license here? http://www.nasa.gov/multimedia/nasatv/index.html
<ArneBab_>sorry, wrong link
<ArneBab_> https://github.com/ktakashi/r6rs-msgpack/blob/master/test-lib/srfi/%253a78/lightweight-testing.ypsilon.scm
<ArneBab_>(the previous link was the wrong clipboard)
<amz3>ArneBab_: https://github.com/ktakashi/r6rs-msgpack/blob/master/msgpack.sls#L7
<ArneBab_>dang, yes
<ArneBab_>L14 kills it
<amz3>ah ok
<ArneBab_>maybe you can contact the author and ask whether the license could be switched to a regular 3-clase-BSD
<amz3>sure
<amz3>thx
<ArneBab_>hm, wait
<ArneBab_> https://en.wikipedia.org/wiki/BSD_licenses#4-clause_license_.28original_.22BSD_License.22.29
<ArneBab_>no, it should be GPL compatible
<ArneBab_>it’s actually just the 2-clause BSD license: https://en.wikipedia.org/wiki/BSD_licenses#2-clause_license_.28.22Simplified_BSD_License.22_or_.22FreeBSD_License.22.29
<amz3>indeed, but other license exists in the repository
<amz3>anwyay, I might move to a ffi based in the end. But that library is helpful.
<amz3>i found the bug
<amz3>srfi-1 alist-delete takes as first argument the KEY to be deleted
<amz3>not the alist
<amz3>(alist-delete 'key (alist-cons 'key 'value '()))
<amz3>this is done :)
<amz3>has anyway tried guile-gnunet?
<amz3>looks promising
<amz3>s/anyway/anyone
*amz3 starts the serious stuff, loading conceptnet5 1G of grpa
<amz3>graph data
<amz3>if I disconnect don't be affraid, I'm prepared for worst course of failure
<amz3>worst case scenerio oom killer make an appeareance
<paron_remote>hm
<paron_remote>no https://
<paron_remote>?
<paron_remote>as in, this doesn't resolve properly: (http-get "https://google.com/")
<davexunit>http-get speaks http, not https.
<paron_remote>is there any sort of way to handle https support in guile?
<davexunit>gnutls
<davexunit>which has guile bindings
<davexunit>guix uses them
<davexunit>I'm not familiar with the api myself
<paron_remote>hm, okay thanks davexunit !
<paron_remote>having https support for (http-get) by default in guile seems like something important in this day and age probably
<davexunit>it would make guile have to depend on gnutls
<davexunit>so not sure, especially since gnutls ships with guile bindings.
<paron_remote>hm
<paron_remote>I mean, it's def true that dependency loops is not something we want :)
<davexunit>well, the bindings could be moved entirely out of gnutls and into guile core and guile could depend on it
<davexunit>but it's yet another shared library to depend on.
<paron_remote>yeah
<paron_remote>hm
*amz3 wiredtiger is roaring....
<amz3>he needs data :)
*amz3 thinks that it might be a she
<mark_weaver>paron_remote: I agree with you that it would be good for guile to support https by default. maybe it could use gnutls if it's available, but not as a hard requirement, as guix does.
<paron_remote>mark_weaver: that would be sensible
<paron_remote>I'm writing a web application in guile now and am hitting a mix of things that are wonderful by default in guile, and things sorely missing in the web space :)
<paron_remote>but it really is both!
<paron_remote>ways of decoding urlencoded and multipart form-data stuff would be helpful, too
<mark_weaver>I think ludovic wrote the TLS code in guix. I guess he'd probably be willing to donate it to guile.
<mark_weaver>I recently wrote support for following redirections for guix as well. that could also go into guile.
<paron_remote>those things would be really nice yeah :)
<mark_weaver>patches welcome :)
<paron_remote>mark_weaver: I could try patching it
<paron_remote>could be fun
<paron_remote>mark_weaver: if you and civodul signed off on getting your code into guile proper then that's fairly motivating :)
<mark_weaver>I'm definitely okay with it, and I guess civodul would be as well.
<mark_weaver>(Guix doesn't do copyright assignment, but Guile does)
<mark_weaver>actually, civodul is here, so he could answer for himself :)
<civodul>mark_weaver, paron_remote: yes it "would be nice" to have those things in Guile proper
<civodul>the TLS auto-loading hack, i'm not sure
<civodul>it could be seen as weird behavior
<civodul>maybe that part could go in GnuTLS, actually?
<mark_weaver>civodul: well, it would have to be integrated with guile's web modules such that 'http-get' would automatically handle https URLs, right?
<mark_weaver>especially since after we add support for following redirections, an http URL might redirect to an https URL.
<civodul>yeah, that's right
<civodul>hmm
<civodul>maybe Guile could have an optional dependency on GnuTLS, but without the autoload hack
<civodul>dunno
<paron_remote>civodul: davexunit's concern is a circular dependency
<paron_remote>since gnutls ships a guile module
<civodul>yes, that's a problem
<paron_remote>but maybe the code can be smart about seeing if it's there or not?
<mark_weaver>what's wrong with the autoload hack?
<paron_remote>mark_weaver: I know nothing, I guess it probably works so we can just use that :)
<paron_remote>mark_weaver: civodul: okay, I'll try porting the https code to guile proper
<paron_remote>we'll see how I do :)
<civodul>mark_weaver: the autoload hack fails gracelessly when GnuTLS is missing
<civodul>that's fine in the context of Guix, but maybe not in a more general context
<paron_remote>oh :)
<paron_remote>civodul: what approach would you suggest then?
<mark_weaver>civodul: could we make it more graceful?
<civodul>yeah maybe with some explicit module hackery
<civodul>an explicit resolve-interface + module-ref
<civodul>something like that
<mark_weaver>sounds doable