IRC channel logs

2015-06-20.log

back to list of logs

<ijp> http://shift-reset.com/pastes/mergesort_new_inliner.html
<ijp>much less nesting than before
<ijp>there are some unnecessary aliases, but I will clear that up shortly
***karswell` is now known as karswell
<amz3>héllo :)
<ijp>I don't know how many of you saw it yesterday, but http://shift-reset.com/pastes/mergesort_new_inliner.html is starting to look much less messy
<davexunit>ijp: looking good
<ijp>I can handle the realiasing (var foo = bar;), but I need to change the representation if I'm going to inline the constants
<amz3>I have a error that is kind of cryptic: Unbound variable: ((#{ g33171}#) <node> #f)
<ijp>and how did you obtain this error
<amz3>well, I defined a record with a define-record-type* <node>, it's not srfi-99 i changed to make <node> become node-identifier
<ijp>code, not prose, please
<amz3>huhu
<amz3>ok
<amz3>well sending the whole thing is fat
<amz3>what is #{ g33171}# N
<amz3>?
<ijp>it's a symbol
<amz3>I will make a minimal example code
<amz3>it's compilcated it requires guix
<amz3>I suspect there is funny symbol somewhere
<ijp>probably introduced hygienically
<amz3>paron_remote: is there somewhere I can fetch pamrel.el ?
<amz3> http://pamrel.lu/45324/
<amz3>that said
<amz3>I found something
<amz3>when I do C-c C-k and then C-x C-e on the last sexp it doesn't work
<amz3>then if if I C-x C-e the record and eval the last exp it works
<ijp>hmm, we really need to get a proper srfi-99 setup one of these days. the record system is very similar anyway
<amz3>(my define-record-type* is mainly a hack to have proper highlighting...)
<amz3>(I saw it while reading your code :p)
<amz3>I think that the srfi-99 that you use is ok at least for my usecase
<amz3>(that with set-field and set-fields makes working with record a joy)
<ijp>so, I'm not seeing any buggy behaviour
<amz3>my paste is missing something
<amz3>ijp: do you see (pk (node-identifier ...) at the end ?
<ijp>yes
<amz3>ok let it go I will sort this out
<amz3>thx
<ijp>it could be somethign that is fixed on master, but I can't think what it would be
<amz3>like I said there seems to be a way to make it work, and it has something to do with emacs/geiser
<amz3>it definitly emacs/geiser that doesn something
<remi`bd>hello! Guile’s manual says that `(sizeof TYPE)`, where TYPE is a list, will return the size of the structure that matches TYPE with “ABI conventional packing”
<remi`bd>what is this “ABI conventional packing”? Does that mean `sizeof` takes structures alignment padding into account?
<remi`bd>the reason for my question is: the size of `struct foo { char *bar; unsigned int baz; }` varies between C and Guile
<remi`bd>(sources: http://paste.lisp.org/display/150153 & http://paste.lisp.org/display/150154 — see the annotations for output)
<Feufochmar>Hello. I'm encountering a weird bug with match:substring (I think). Given the data file http://feuforeve.fr/vrac/test-guile.txt and the guile script http://feuforeve.fr/vrac/test-guile.scm , I'm getting an error (value out of range, see http://feuforeve.fr/vrac/error-guile.txt ) when I run guile non-interactively. If I copy/paste the contents of test-guile.scm inside the REPL, I don't encounter any problem.
<mark_weaver>Feufochmar: you need to call (setlocale LC_ALL "") near the beginning of your script.
<mark_weaver>when running guile interactively, that is done automatically.
<mark_weaver>but in a script, you need to do it explicitly or else the C locale is assumed, and so your text file cannot be decoded properly.
<mark_weaver>(in guile-2.2 it will be done automatically for scripts as well, but not in guile-2.0)
<Feufochmar>mark_weaver: guile does not use environment variables like LANG or LC_ALL set in the environment ?
<mark_weaver>Feufochmar: it does if you call (setlocale LC_ALL "")
<mark_weaver>I agree that we should do it automatically for scripts, and we will in guile 2.2, but for backward compatibility reasons we can't change the behavior now in guile-2.0.
<Feufochmar>ok, thanks
<mark_weaver>np
<mark_weaver>Feufochmar: there's also an environment variable you can set to tell it to always set the locale when starting up scripts: GUILE_INSTALL_LOCALE
<mark_weaver>however, it's probably better to call (setlocale LC_ALL "") so that your script will work properly regardless of the environment variable settings.
<mark_weaver>(and in case you run any scripts that depend on the locale being left alone)
<mark_weaver>anyway, you can set that variable to "1" (to install the locale) or "0" (to not install the locale)
<mark_weaver>also, we didn't add support for GUILE_INSTALL_LOCALE until guile-2.0.9
<paron_remote>amz3: yeah
<paron_remote>amz3: https://github.com/cwebber/pamrel-el
<paron_remote>also, hello *
<paron_remote>ijp: woo re: mergesort_new_inliner.html
***michel_ml is now known as michel_mno
***heroux_ is now known as heroux
***ft_ is now known as ft
***heroux_ is now known as heroux
***michel_mno_afk is now known as michel_mno
***michel_mno_afk is now known as michel_mno
***heroux_ is now known as heroux
***Fuuzetsu_ is now known as Fuuzetsu
***Fuuzetsu is now known as Guest7314
***Guest7314 is now known as Fuuzetsu
***Fuuzetsu is now known as Fuuzetsu`
***Fuuzetsu` is now known as Fuuzetsu