IRC channel logs

2015-05-31.log

back to list of logs

<davexunit>I've got some pid problems.
<davexunit>I call clone() to create a new pid namespace...
<davexunit>then I fork via primitive-fork
<davexunit>and (pk 'pid (getpid)) in the new process
<davexunit>I expect the pid to be 1
<davexunit>but it is 2
<davexunit>the parent process is *not* pid 1, as expected.
<davexunit>creating a new pid namespace within a process does not make it pid 1.
<davexunit>the first child process becomes pid 1.
<davexunit>if I inspect /proc/1/cmdline and /proc/2/cmdline I can see that they are the same
<davexunit>my expectation is that a fork + exec would give me a process with pid 1
<linas>paroneayea part of guile-dbi maintenance that would make it easier is to move it to github
<paroneayea>linas: argh
<paroneayea>I hate github
<linas>yeah, why?
<paroneayea>linas: it's proprietary, centralized, and some other things
<linas>yeah, its proprietary, and that's bad
<linas>but the user interface is the best out there.
<linas>well, but reports are ok not great, and tthe wikis suck bad
<linas>but wow, the ese of use is fantastic
<linas>I mean I wish someone at saannah cared that much
<davexunit>good morning guilers
<attichacker>Greetings
<paroneayea>davexunit: not saying we'd want to use a js based database, but you'll probably find the ideas behind https://github.com/substack/forkdb interesting
<paroneayea>"
<paroneayea>forking content-addressed append-only historical key/value blob store over leveldb
<paroneayea>"
<paroneayea>won't be nice if your database gets spammed though :)
<davexunit>paroneayea: hmm interesting
<davexunit>though I don't know what use-cases such a thing would have
<paroneayea>huh
<paroneayea>so there's two guile-gdbm implementations?
<paroneayea> https://github.com/ijp/guile-gdbm and http://www.gnuvola.org/software/guile-gdbm/ ?
<paroneayea>that may make packaging for guix confusing
<paroneayea>I think I'm going to call ijp's guile-gdbm-ffi
<paroneayea>amirouche: ping
<ajnirp>what's the standard guile way to unit test your functions?
<ajnirp>s/standard/idiomatic
<davexunit>ajnirp: guile comes with SRFI-64, which provides a testing API
<ajnirp>i'll take a look. thank you, davexunit!
<civodul>ajnirp: Guix uses SRFI-64 under tests/, if you want to see what it's like
<ajnirp>beats reading the docs :) thanks civodul.
<civodul>yw :-)