IRC channel logs

2015-05-28.log

back to list of logs

<zacts> ihttp://www.nytimes.com/2015/01/23/us/politics/senate-rejects-human-role-in-climate-change.html?_r=0
<zacts> http://www.nytimes.com/2015/01/23/us/politics/senate-rejects-human-role-in-climate-change.html?_r=0
<nalaginrut>morning guilers~
<please_help>Module 1 does generic differentiation. Module 2 builds on top of module 1 and provides matops differentiation. However, module 1 assumes dy/dx = 0 and dy/dy = 1 whereas module 2 requires dy/dx = zero-matrix-like(y) and dy/dy = ones-matrix-like(y)
<please_help>is there a clean way to provide the overriden version of the function without risk of module load order replacing it by the former version?
<please_help>If I have (define fn identity) and #:export (fn), will it work to (set! fn cons) in another module? (that is, so that the original module now knows fn is cons), and if not, what about if fn is a fluid?
<nalaginrut>please_help: you may use #:rename
<nalaginrut>while importing symbols
<please_help>but I want to do the reverse of what rename intends to do.
<nalaginrut>please_help: fluid is one of possible way, but nowadays cool guys use parameter ;-P
<please_help>are parameters basically the same thing as fluids, but with a different interface?
<mark_weaver>yes
<paroneayea>:(
<paroneayea>I'm having a problem where either goops is being unreliable or my macro is
<paroneayea>and I'm not sure which.
<nalaginrut>paroneayea: are you using master?
<paroneayea>nalaginrut: nope
<paroneayea>nalaginrut: I'm having some class-slots forgotten
<paroneayea>guile eventually forgets about them :\\
<paroneayea>I don't know what's happening
<paroneayea>some it remembers and some it doesn't, but I've inserted some debugging code that indicates that at some point it's there
<paroneayea>nalaginrut: I'm on guile 2.0.11
<nalaginrut>paroneayea: maybe related to GC? dunno, I've been a long time not to use OOP intended...
<paroneayea>nalaginrut: there could be a gc related bug I guess, I dunno
<tos-1>Hey guys, I want to print non-ascii chars. That works well if I manually start guile and then load the corresponding script. However, if I launch it as script `guile -s`, I only get question marks. How to fix this?
***wleslie_ is now known as wleslie
<nalaginrut>tos-1: could you paste your script?
<nalaginrut>tos-1: to bastebin or something
<nalaginrut>pastebin
<tos-1>nalaginrut: Just try: (display "ä")
<nalaginrut>tos-1: guile -c '(display "ä")'
<tos-1>Yes.
<tos-1>Prints out "�", here.
<nalaginrut>tos-1: or store (display "ä") to a file, say, named sc.scm, and run: guile -s sc.scm
<nalaginrut>-s is for script file
<tos-1>nalaginrut: Yes, that will also produce not the desired output. However, if you fire up guile into th repl and let it eval that sexp, it works.
<nalaginrut>tos-1: well, you need to call setlocale in the very beginning
<nalaginrut>for me, (setlocale LC_ALL "zh_CN.utf-8") works
<nalaginrut>it prints correct char
<nalaginrut>anyway, you need utf-8
<nalaginrut>tos-1: xx_XX.utf-8, pick one, en_US.utf-8 or something else
<tos-1>nalaginrut: Thanks, that works!
<nalaginrut>maybe different in different distro, I'm under opensuse
*taylanub thought it's either "UTF-8" or "utf8"
<tos-1>Even (setlocale LC_ALL "") works well, which is uses the system environment's LANG (according to the reference manual), where I've set the locale correctly.
<nalaginrut>tos-1: this way depends on your current locale config
<tos-1>nalaginrut: Correct.
<tos-1>Anyway, thanks again.
<nalaginrut>np ;-)
<mthl>ls
<mthl>oops :)
<please_help>I don't think this is the place to ask but I just can't wrap my head around this: what is d/dx mat-mul(f(x), g(x)), where x is an n by m matrix? I thought it was mat-mul(f'(x), g(x)) + mat-mul(f(x), g'(x)) but that obviously doesn't work.
<taylanub>please_help: there's a ##math channel in case that helps
<please_help>oh nice, thanks
<paroneayea>okay, I've sketched up a proof that this goops bug exists in 2.0.11 at least
<paroneayea>oh-ho
<paroneayea>it was a bug in my code, but such a subtle bug!
<dsmith-work>Morning Greetings, Guilers
<paroneayea>morning, *!
<mark_weaver>please_help: it's not clear to me what it would mean to take a derivative with respect to a non-scalar variable.
<wleslie>could be <d/dx, d/dy, d/dz>
<wleslie>a vector of partial derivatives
<mark_weaver>in this case, the variable x is a matrix
<wleslie>oh, I just saw that.
<wleslie>it means to treat it like a matrix-valued function.
<mark_weaver>well, what's the definition of the derivative in that case?
<mark_weaver>admittedly, I'm rusty on this
<wleslie>me too. product rule was a nice guess but you'd have to expand it out and check.
<mark_weaver>I suppose you could define it to be a matrix of partial derivatives
<mark_weaver>but I'm not sure if that makes sense in practice
*mark_weaver goes afk
<please_help>mark_weaver, wleslie: d/dX f(X) = sum_{i=1}^{N} sum_{j=1}^{M} d/df(X)ij f(X) d/dXij f(X)ij
<please_help>##math doesn't seem to be of much help, oh well.