IRC channel logs

2015-05-14.log

back to list of logs

<dsmith-work>adhoc: You can use geiser in regular emacs. No need for guile-emacs there.
<adhoc>paroneayea: thanks =)
<adhoc>dsmith-work: well, might as well push some boundaries =)
<adhoc>damn, same issue =/
<adhoc>configure.ac:9: require Automake 1.12, but have 1.11.6
***mario-goulart` is now known as mario-goulart
<paroneayea>adhoc: well if you install geiser
<paroneayea>I should have a guile-emacs patch to the list in a few minutes :)
<paroneayea>I just rebuilt it verifying that it works with all the changes suggested
<adhoc>paroneayea: ok, i'm off now for a bit
<adhoc>i'd like to get guix up and running
<adhoc>but maybe its time to upgrade debian from 7->8 ?
<paroneayea>ohhh yeah
<paroneayea>okay
<paroneayea>guile-emacs patch submitted to the guix list
<zacts>paroneayea: oh nice!
<paroneayea> https://lists.gnu.org/archive/html/guix-devel/2015-05/msg00190.html ya :)
***petercom1and is now known as petercommand
<paroneayea>bipt`: oh hey
<paroneayea>bipt`: https://lists.gnu.org/archive/html/guix-devel/2015-05/msg00190.html :)
<nalaginrut>morning guilers~
<adhoc>paroneayea: so is that patch accepted into guix ?
<adhoc>hmmm
<dsmith-work>Thursday Greetings, Guilers
<stis>Hej Guilers!
<davexunit>GNU Guix 0.8.2 has been released :) https://savannah.gnu.org/forum/forum.php?forum_id=8273
<davexunit>upvotes on HN are appreciated https://news.ycombinator.com/item?id=9544737
<davexunit>hoping to get it to the front page for some good exposure
<stis>\\o/
<davexunit>sweet, just landed on the front page!
<davexunit>thanks to magic upvoter #7
<zacts>hello guilers
<zacts>hey mark_weaver I wanted to share some links with you
<zacts> http://explore.sjcintellectualexplorer.com/mathematics.php
<zacts>and http://www.sjc.edu/academic-programs/undergraduate/mathematics-tutorial/
<zacts>^ I'm considering applying to this college
<zacts>I'll relate how it applies to comp sci and scheme in a bit
<zacts>I'm also currently eating lunch at a burrito shop
<zacts>but I really like many aspects of this pedagogy
<zacts>I've been kind of doing this kind of thing on my own, I really dig it. Namely, I've kind of gone to the core philosophy of mathematics and logic, and philosophy... and I'm starting there
<zacts>I'm gradually building back up to the point to where I get through SICPish things
<zacts>but I'm starting to see how these philosophical ideas can really relate to design ideas / scheme programming, I feel
<zacts>but I'm much more impressed with a pedagogy like this than many State Universities (US), comp sci curriculum
<zacts>anyway, the reason I'm sending you these links, is that I would be interested in your thoughts, and on specific comp sci topics that may be useful, that aren't covered by this philosophical and mathematical core.
<zacts>(and SICP)
<zacts>so my plan is to go more on the philosophical / math / physics side for college credit, and just teach myself comp sci / programming...
<zacts>@ least for undergrad... anyways, back to #guile (please pardon my sleightly off-topicness)
<ajnirp>i'm sorry i don't have anything to contribute to this discussion, but i'd like to say i fell off my chair laughing at "I'm also currently eating lunch at a burrito shop"
<zacts>ajnirp: hehe sorry
<zacts>yeah
<zacts>I'm home now
<zacts>and yes the burrito was good
<ajnirp>:-)
<wingo>evening, guilers
<wingo>mmburritos
<dsmith-work>wingoooo!
<wingo>hello dsmith-work :)
*wingo hacks more on cps2
<dsmith-work>Mmm.
*dsmith-work wishes he could eat a burrito
<wingo>yeah me too :)
<dsmith-work>Yeah, but I can't eat one even if I had one. : ( (gluten free)
<wingo>aw bummers
<wingo>move to france, there's no burritos here ;)
<wingo>wow i just found some horrible code
<wingo>(define (fixpoint f x)
<wingo> (let ((x* (f x)))
<wingo> (if (eq? x x*) x* (f x*))))
<wingo>it meant to recurse at the end but didn't
<wingo>hashtag fail :P
<wingo>(it's my code of course)
<dsmith-work>wingo: Is that why numbers.test is failing?
<dsmith-work>Prob not
<wingo>oh i didn't know about a test failure
<dsmith-work>I think it started with some of the cps2 changes
<wingo>ah thanks for the note, it is surely something i did in the last couple days
<wingo>usually i treat a fresh bootstrap then non-fresh re-bootstrap as a test case but clearly that's not enough :P