IRC channel logs

2015-05-04.log

back to list of logs

<paroneayea>oh hey look
<paroneayea> http://permalink.gmane.org/gmane.lisp.scheme.srfi.announce/117
<paroneayea>srfi has a future plan
***karswell` is now known as karswell
<wleslie>better than having a past plan
<davexunit>"here's a picture of me when I was younger." every picture is when you were younger.
<davexunit>"here's a picture of me when I was older." lemme see that camera.
<adhoc>a1220517
<adhoc>oops
<not_a_tiger>Are there ready to run binaries? I don't see them on gnu.org.
<davexunit>not_a_tiger: no, your distribution will provide them.
<not_a_tiger>I'm SOL then. Later #guile :)
<nalaginrut>morning guilers~
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
<not_a_tiger>I seem to have macports working :)
<not_a_tiger>For your reference it was not at all obvious how to obtain the public key to verify and authenticate the downloads. Google found it for me in a StackExchange article.
<not_a_tiger>A more trustworthy method of obtaining and the key would be appreciated.
<adhoc>does macports require xcode ?
<not_a_tiger>I have a _lot_ of reading to do now, so I'll probably fall asleep and let my compuer sleep.
<not_a_tiger>adhoc: It does.
<adhoc>ok
<not_a_tiger>adhoc: I think they want to do away with the dependency in future.
<not_a_tiger> https://guide.macports.org/#installing.xcode
<adhoc>ta
***michel_mno_afk is now known as michel_mno
***Rashack_ is now known as Rashack
***michel_mno is now known as michel_mno_afk
***michel_mno_afk is now known as michel_mno
***michel_mno is now known as michel_mno_afk
<civodul>Hello Guilers!
<paroneayea>o/
<paroneayea>(pp) is used but undefined in http://okmij.org/ftp/Scheme/monad-in-Scheme.html ... I wish I knew what its definition should be
***michel_mno_afk is now known as michel_mno
<ArneBab_>paroneayea: pretty printer?
<ArneBab_> https://www.gnu.org/software/guile/manual/html_node/Pretty-Printing.html
<paroneayea>ArneBab_: ah
<ArneBab_>in short: (define pp (@ (ice-9 pretty-print) pretty-print))
<paroneayea>ArneBab_: thanks :)
<ArneBab_>glad to ☺
***michel_mno is now known as michel_mno_afk
<ArneBab_>sneek seen wingo
<sneek>wingo was here May 05 at 06:41 am UTC, saying: i swear we are missing a tool to turn a git SHA1 to a Nix hash.
<ArneBab_>sneekh May 5th?
<ArneBab_>sneek: May 5th?
<paroneayea>on may 5? :)
<paroneayea>ArneBab_: already beat me to it ;)
<ArneBab_>
<wleslie>"let me see that camera"
<davexunit>;)
<davexunit>RIP Mitch Hedberg
***michel_mno_afk is now known as michel_mno
***dje is now known as xdje
<dsmith-work>Morning Greetings, Guilers
<dsmith-work>sneek: seen dsmith-work
<sneek>I last saw dsmith-work on May 04 at 05:00 pm UTC, saying: sneek: seen dsmith-work.
<dsmith-work>sneek: seen wingo
<sneek>wingo was here May 05 at 06:41 am UTC, saying: i swear we are missing a tool to turn a git SHA1 to a Nix hash.
<not_a_tiger>Should I learn Scheme?
<paroneayea>not_a_tiger: shouldn't you ever!
<not_a_tiger>That's an oddly worded response to an extremely simple question :P
<not_a_tiger>Should I use Scheme for general purpose programming?
<not_a_tiger>Should I use Scheme for games?
<davexunit>yes
<davexunit>yes
<not_a_tiger>Should I use Scheme for maths and science?
<davexunit>yes
<not_a_tiger>Should I use Scheme for shell one-liners in the manner of sed or awk?
<davexunit>probably not for that, but larger scripts: yes.
<not_a_tiger>I see
<not_a_tiger>So I probably don't want to use Scheme for line-by-line parsing of text files.
<not_a_tiger>Is guile + emacs the best way to learn Scheme? Some people recommend Racket or MIT Scheme.
<paroneayea>not_a_tiger: I mean, you could without too much difficulty. but sed and awk already do it, and unless you're using perl
<paroneayea>not_a_tiger: guile + emacs + geiser are well loved in here, especially with paredit/smartparens + rainbow-delimeters
<paroneayea>but
<paroneayea>rakcet and drracket are also good options.
<davexunit>not_a_tiger: line by line processing would be a good use case for scheme
<davexunit>you said "one-liners"
<davexunit>if you're writing a throwaway one line awk thing, just use your shell and awk.
<not_a_tiger>I tried using AWK for seriousl programming, and ran into serious limitations. Don't ever use AWK for binary files.
<davexunit>well... yeah. awk isn't meant for that.
<davexunit>it's a great tool for processing delimited value files, flat text databases.
<not_a_tiger>Well, Perl can do that very well. I just refuse to ever go back to Perl out of stubbornness.
<davexunit>anyway, scheme is a general purpose programming language, so naturally you can read/write files with it
<davexunit>so it's a fine choice for writing parsers and such
<not_a_tiger>Emacs Lisp has some neat methods for breaking text files into records and fields, but it is severely restricted in the kind of file I/O you can do. To be fair though, it isn't "restrictive" as much as "overly specialized".
<not_a_tiger>Plus Lisp is a bit verbose for a one-liner.
<davexunit>it's not a bash replacement, no.
<davexunit>I don't know what you're getting at here.
<paroneayea>how is elisp restricted as in terms of file i/o?
<paroneayea>though it's probably not the world's best utility language
<not_a_tiger>Emacs wants to load the entire file in memory at once.
<davexunit>that's different than Emacs Lisp, though...
<not_a_tiger>It could be different, but it isn't.
<not_a_tiger>If your file is 20 GiB, then you need more than 20GiB to load it.
<davexunit>you're confusing Emacs Lisp, the language, with Emacs, the application.
<not_a_tiger>I don't think so
<not_a_tiger>I've looked into this and asked.
<not_a_tiger>Most people just use sed or awk or perl.
<davexunit>okay, no matter. this is #guile.
<not_a_tiger>Yeah
<not_a_tiger>I watched Andy Balaam's video series
<not_a_tiger> https://www.youtube.com/playlist?list=PLgyU3jNA6VjRMB-LXXR9ZWcU3-GCzJPm0
<davexunit>guile has ports, you can read and write to/from them.
<not_a_tiger>He makes Scheme look awesome.
<davexunit>hmm, never seen these before.
<davexunit>thanks.
<davexunit>I will take a look.
<davexunit>he makes Scheme look awesome because Scheme *is* awesome.
<not_a_tiger>You probably are aware that Abelson and Sussman's SICP lectures are also on YouTube.
<not_a_tiger>They are a lot more serious and in depth of course.
<davexunit>yeah, those are awesome.
<davexunit>I've watched many of them, but not all.
<davexunit>much like the book. read a good deal, but not everything.
<paroneayea>I wonder how long it would take to go through the whole book including all exercises... some time, I'd imagine!
<davexunit>yes
<davexunit>it's a big book
<not_a_tiger>So when guile executes a script it evaluates all the forms in sequence even without PROGN?
<davexunit>in Scheme, you'd use 'begin', not 'progn'. anyway, the top-level environment doesn't need to wrapped in that.
<not_a_tiger>Scheme uses different names for its methods than Common Lisp, and I need to understand the "top-level" concept.
<davexunit>yes, scheme is much different from CL.
<not_a_tiger>Dr.s Abelson and Sussman call it "Lisp", so the differences can be surprising :)
<davexunit>it is a Lisp, but Lisp is a diverse family. :)
<ArneBab_>not_a_tiger: yes
<ArneBab_>not_a_tiger: (I decided to add a second answer ☺)
<ArneBab_>not_a_tiger: here’s my detailed answer: http://draketo.de/proj/py2guile
***michel_mno is now known as michel_mno_afk
<not_a_tiger>ArneBab_: I'm reading your py2guile, but there are interruptions :)
<ArneBab_>
<ArneBab_>not_a_tiger: if you stumble over something, please tell me. I plan to turn this into a real ebook and print book (GPL licensed)
<not_a_tiger>It's fine so far. No stumbles yet.
*ArneBab_ happy ☺
***michaniskin is now known as Guest29403