IRC channel logs

2015-03-24.log

back to list of logs

<paron_remote>I couldn't figure out what the wind blowing around had to do with this code
<paron_remote>wind-fluids
<paron_remote>oh!
<paron_remote>it's wind/unwind :)
<paron_remote>stupid english!
<wleslie>(:
<nalaginrut>morning guilers~
<ArneBab>mark_weaver: the line number is shown only for some parts of the code. If I spell a variable wrongly, I get the line number. If I call a function with the wrong number of arguments, I only get the line number for the surrounding code, but not for the function call.
<ArneBab>here’s an example: paste.lisp.org/display/146470
<ArneBab>In examples/d6.w:
<ArneBab> 10: 2 [#f]
<ArneBab>In unknown file:
<ArneBab> ?: 1 [write 1 1]
<ArneBab>vs.
<ArneBab>In examples/d6.w:
<ArneBab> 10: 1 [writhe]
***michel_mno_afk is now known as michel_mno
<civodul>Hello Guilers!
<dsmith-work>Morning Greetings, Guilers
***michel_mno is now known as michel_mno_afk
<paron_remote>is there a more scheme'y way to do something like a fold/map where you might break out early?
<paron_remote>I could recurse manually
<paron_remote>but I wonder if there's something in the tooling that comes built into guile
<davexunit>paron_remote: yeah, I think you'd want to write your own procedure for that
<paron_remote>eg, if I run into a certain result with one of the things I'm mapping over, I need to stop because it means there's no point
<paron_remote>davexunit: ok, thanks
<davexunit>paron_remote: orrrrr
<davexunit>you could do a take-while, take-until, and then map/fold over the result
*paron_remote reads up on how to do that
<davexunit>SRFI-1
*paron_remote at the point where he should start to break out his code from the scratch/tasksv2.scm into actual files ;)
<davexunit>from experience, sooner rather than later
<paron_remote>:)
<paron_remote>sometimes it's hard to get outta the hack zone tho
<paron_remote>reorganize, whaaat