IRC channel logs

2015-02-18.log

back to list of logs

*paroneayea installs drracket, out of curiosity
***sethalves is now known as sethAway
***sethAway is now known as seth
***seth is now known as sethalves
<lloda`>please_help: not as far as I know. you'd have to define your own, see srfi4-type-size here: https://gitorious.org/guile-ffi-cblas/guile-ffi-cblas/source/3462de0f0932c1af1c0d138e06eb33703b9a3c62:mod/ffi/blis.scm#L42
<nalaginrut>afternoon guilers~ happy Chinese new year
<mark_weaver>happy new year, nalaginrut!
<nalaginrut>;-)
<please_help>also, here's the code that uses (increment): http://paste.lisp.org/display/145814 (the goal is to try to remove increment if possible)
<mark_weaver>please_help: could you use 'array-contents' to create a flattened 1
<mark_weaver>1D view of the array, and then fill that one?
<mark_weaver>and then return the multi-dimensional array.
<nalaginrut>each time reply to " please_help ", it looks just like the answerer is requiring help...
<wleslie>there is this one cat with the nick 'lubyou'
<wleslie>I don't really like repyling to them (:
<nalaginrut>well, I'm just kidding ;-P
<wleslie>I've been confused before.
<lloda`>please_help: why aren't you using array-index-map! here?
<lloda`>also I have a patch up in git that will replace the whole top begin block in your code by (apply array-amend! ret result idx)
<lloda`>branch lloda-array-support
<lloda`>but first you should replace all this manual indexing by array-index-map!
<wingo>moin
<wleslie>hi
<wingo>greets
<wleslie>it's really cool when my worlds collide (you having a conversation with cfbolz on twitter)
<wingo>:-)
<zacts>mark_weaver: hey do you use org-mode literate programming to code?
<zacts>or do you just code directly?
<stis>morning guilers!
<taylanub> https://www.google-melange.com/gsoc/homepage/google/gsoc2015 have we applied yet? 2 days, 4 hours remaining
<paroneayea>would it be useful to have a topsort function in standard guile?
<paroneayea>seems to be frequently a thing people need
<paroneayea>and I found I couldn't open slib with guile in debian
<paroneayea>maybe might be nice to just include it in guile's standard library, was easy to port over
<taylanub>paroneayea: you'll probably get more attention on guile-devel, but the developers might be busy and not react unless you provide a complete patch
<paroneayea>taylanub: easy enough, I can submit one.
<taylanub>ok :)
<paroneayea>what's the conventional difference between
<paroneayea>; comment
<paroneayea>and ;; comment
<paroneayea>again?
<paroneayea>I know there's a difference
<paroneayea>but I can't remember it
<taylanub>paroneayea: ;; is when the comment is the only thing on a line, but after indentation, ; is at the right side (margin) of a line of code
<taylanub>and ;;; is when the comment starts at zero indentation
<taylanub>paroneayea: Emacs's M-; command does the right thing :)
<paroneayea>taylanub: thanks :)
<paroneayea> http://dustycloud.org/blog/topsort-for-guile/ in the off chance someone needs it in the meanwhile
<daviid>i'm am trying to produce a backtrace for a guile-gnome error using guile-2.1. here is what i do http://paste.lisp.org/+34IL I tried ,backtrace #:full? #t here is the [short] answer http://paste.lisp.org/+34IL/1 how do i get a fullbacktrace using guile-2.1[2] ?
<mark_weaver>daviid: the problem is that the bug is happening not in the code you're running, but in the REPL/compiler itself.
<mark_weaver>the error happens while trying to print the error.
<mark_weaver>typing ,backtrace at the top REPL wouldn't work anyway, because you are not in the debugger.
<mark_weaver>most likely the error happened while trying to print one of your data structures that has a custom printer.
<daviid>mark_weaver: tx, by the way, before answering the above, I got rid of all reported errors while compiling kisê against guile-2.1 [and so it is compiled and i don't think it is a kisê bug here, but a guile-gnome using guile-2.1 problem/bug, let's see]. after these changes, kisê still runs perfectly using 2.0 [and guile-gnome built against 2.0]
<mark_weaver>daviid: that's good!
<daviid>the previous paste was an attempt to get a full bactrace from an emacs session where i manually load ... but here is a terminal output http://paste.lisp.org/+34IL/2 as you can see, kisê s already compiled... how can i get a fullbacktrace of this ?
<daviid>have to afk for while, bbl
*davexunit is missing a lot of mail from guile-user
<davexunit>surely I'm still subscribed...
<zacts>hi