IRC channel logs

2015-01-31.log

back to list of logs

***Guest6784 is now known as Fuuzetsu
***mario-go` is now known as mario-goulart
<please_help>I was looking to generate random numbers, and I tried to use (random ...) but it seems to give me awful results
<please_help>Here's an example output: http://pastebin.com/AfSmgF2r
<please_help>oops, forgot to divide, actually the results aren't too ridiculous now
<mark_weaver>please_help: pastebin.com blocks tor users, so I can't view that. can you paste it somewhere that doesn't block tor? (e.g. http://paste.lisp.org/new)
<mark_weaver>please_help: you need to explicitly initialize the random number seed, or else you'll get the same sequence on every run.
<mark_weaver>(just like in C)
<please_help>I get (0.008071113752523621 0.002156507967407053) now
<mark_weaver>(set! *random-state* (random-state-from-platform))
<mark_weaver>that's one way to do it
<please_help>I don't care about the sequence, I'm looking at statistics
<mark_weaver>well, I still lack context because I can't see your paste, but if you're happy I'm happy :)
<please_help> http://paste.lisp.org/+349X
<please_help>unless I'm missing something, the distribution isn't uniform.
*mark_weaver looks
<please_help>also the numbers stay about the same when increasing the smaple size
<please_help>it could only be uniform if it was from 0 to 0.00635 rather than 0 to 0.01 if I'm not mistaken
<please_help>(assuming of course that the numbers are actually generated correctly, since I'm really only looking at the first two moments)
<mark_weaver>please_help: I'm afraid I'll have to continue investigating this later. I have to do something else for the next hour or two.
<mark_weaver>but it could be that 100 numbers is not enough. try analyzing a larger sample.
*mark_weaver goes afk
<please_help>I tried with 1000 and it gave me the same results
<mark_weaver>what platform are you on?
<please_help>linux
<mark_weaver>well, sorry, I have to go now.
<mark_weaver>while I'm away, if you could plot a histogram, that would be helpful.
<mark_weaver>please_help: ^^
<please_help>Can I use anything in guile for that?
<boxofrox>CSV?
<mark_weaver>please_help: you could use guile-charting <http://wingolog.org/projects/guile-charting/> and <https://gitorious.org/guile-charting>
<mark_weaver>but if you don't plan to use it for anything else, it might not be worth setting up the prerequisites.
<please_help>yeah, I'm in the process of doing that
<please_help>charting is generally useful to me anyway
<rekado>I'd just like to ping about this patch I sent a while ago to improve the sxpath docs: http://lists.gnu.org/archive/html/bug-guile/2014-12/msg00046.html
<rekado>if there's something you want me to change about this, please do let me know.
<mark_weaver>rekado: yes, sorry about that. I'm not very familiar with sxpath, so I haven't been able to effectively review it yet, but also, for a non-trivial contribution like that, we need copyright assignment papers from you.
<rekado>the docs are essentially copied and slightly modified from the sxpath source comments. Modified only for clarity or whenever "this file" or so was referenced.
<davexunit>... I actually had no idea that we did copyright assignment.
<rekado>re copyright assignment: where can I get the papers? I hear there's an online process for some countries (I live in Germany).
<mark_weaver>rekado: I'll email you the information. sorry about that.
<rekado>mark_weaver: thank you! I was just wondering if I did something wrong submitting a bug report with a patch attached.
<mark_weaver>I was hoping that another maintainer with more knowledge of sxpath would do it, but alas, the other maintainers are mostly focused on other things lately.
<rekado>it's not urgent for me. I was just bothered by the lack of sxpath documentation when I wrote my XMPP library, then read the sources to see that it's all documented there.
<rekado>but if we can get the paperwork out of the way I'd be glad to get this over with.