IRC channel logs

2015-01-16.log

back to list of logs

***ft_ is now known as ft
***paroneay` is now known as paroneayea
***ceverett is now known as _zxq9_
***sethalve_ is now known as sethalves
***cluck` is now known as cluck
<daviid>how do i flatten map result again ? (max (map get-width children))
<dsmith-work>mark_weaver: Thanks!
<dsmith-work>mark_weaver: Wow. I don't remember seeing that.
<mark_weaver>daviid: (reduce max #f (map get-width children)) is probably the best way, in general. using 'reduce' from (srfi srfi-1)
<daviid>mark_weaver: thanks, i did (reduce max 0 ...)
<mark_weaver>if you know the number of elements won't be too large, you could just do (apply max (map get-width children))
***karswell` is now known as karswell
<mark_weaver>this case is made a bit more complicated by the fact that there's no exact infinity to use as the 'identity'.
<daviid>ok, i like reduce, i just forgot about it for a second and ask, then remember ...
<daviid>but tx of course, have to run, there closing the place where i'm aking :) bb tomorrow
<mark_weaver>if there's an identity, i.e. an 'I' such that (max I x) = x for all x, then you can use it with 'fold', e.g. (fold + 0 xs) to sum a list, or (fold * 1 xs) to take the product.
<mark_weaver>okay, by!
<mark_weaver>bye!
<davexunit>sigh, a lot of people don't see the value in config files that use the same language as the program it configures.
<davexunit>"turing complete config? do you want sysadmins to destroy your application?"
<jgrant>davexunit: Those heathens. Next you're going to tell me people don't care about Emacs en masse. :^P
<nalaginrut>morning guilers~
<zacts>lo guilers
<civodul>Hello Guilers!
<nalaginrut>heya
***Shozan is now known as SHODAN
***mario-go` is now known as mario-goulart
*wingo contemplates proper slot definition objects
<dsmith-work>Happy Friday, Guilers!!
<OrangeShark>Happy Friday to you too dsmith-work!
<please_help>Trying to get slib to work with guile-2.1.0.164-015c3
<please_help>I can (use-modules (ice-9 slib)) fine, but if I (require 'matfile), it complains there's no slibcat file in guile's site/2.2
<please_help>indeed, there is no site/2.2 folder (though there is a site/2.0 one).
<please_help>thoughts?
<please_help>Also I can't see any slibcat file anywhere. That's with slib-3b4, by the way.
<daviid>please_help: http://people.csail.mit.edu/jaffer/slib/Installation.html
<daviid>there are general and specific things to vset-up see the above link...
<mark_weaver> http://people.csail.mit.edu/jaffer/slib/Catalog-Creation.html talks about how the slibcat file is supposed to be created.
<mark_weaver>I know that slib-3b4 works with guile-2.0.x, but I never use slib myself, so I'm not familiar with the particulars.
<daviid>please_help: also, on the news page i see wingo created a guile-2.init: " guile.init: Factor an initialization file for Guile 2.0 and later out of guile.init." probbly all you need is this file...
<please_help>daviid, I already have guile-2.init (can't (use-modules (ice-9 slib)) without it). I can't create slibcat using (require 'new-catalog) since this already requires slibcat.
<please_help>I can use the slib script to start guile with slib initialized as well
<please_help>as far as I can tell, my SCHEME_LIBRARY_PATH is correct
<mark_weaver>if no one here on channel knows, you might try asking on guile-user@gnu.org
<mark_weaver>most of us guile hackers don't use slib much
<daviid>did you create the catalog ?
<daviid> https://www.gnu.org/software/guile/manual/html_node/SLIB-installation.html
<daviid>please_help: not that i don't use it myself, just try to be nice here :)
<mark_weaver>please_help: did you follow the steps described in http://people.csail.mit.edu/jaffer/slib/Installation.html ?
<mark_weaver>actually, the link daviid gave might be more relevant.
<daviid>mark_weaver: i think he needs to create the catalog
<mark_weaver>but ignore the bit about slib-3a3 working. that's out of date. you definitely need slib-3b4 for guile-2.0 or later.
<mark_weaver>daviid: yes, clearly
<mark_weaver>but he says "I can't create slibcat using (require 'new-catalog) since this already requires slibcat."
<please_help>mark_weaver; daviid: from what I gather from the instructions, (require 'new-catalog) would create slibcat when it is not present. However, (require 'slibcat) fails because it cannot find slibcat in the same way other (require slib-part) fail.
<please_help>I respected the instructions on that page as best I could. This of course does not exclude the possibility of errors.
<daviid>please_help: don't know, i' have to try it myself but i won't be able to do that now, sorry
<please_help>I'll see if I can think of anything and otherwise head to guile-user@gnu.org then. Thanks.
<please_help>I managed to fix the problem. The 2.2 folder in site did not exist and that's why I got a file or folder does not exist when trying to generate the catalog.
<please_help>What libraries are there for guiles to read mat-files? (preferably v7).
<ijp>probably none
<please_help>rip
<please_help>unfortunately, slib is too broken with guile-2.0 so I can't use its matfile.scm
<ijp>the format doesn't look too crazy to do yourself
***Guest50187 is now known as Fuuzetsu