IRC channel logs

2015-01-04.log

back to list of logs

<zacts>hi
<daviid>mark_weaver: i was afk, but tx for the tip. the shebang is #!/bin/sh, i doiubt it is the problem
<daviid>i'm not very familiar with all this, but what i see is that the make distcheck tries to run the test-suite from within _build/...: it executes guile-gobject-test from <top dir>/guile-gnome-platform-2.16.3/glib/test-suite but, ${builddir:-.} is probably bound to <top dir>/guile-gnome-platform-2.16.3/_build/glib/test-suite which does not have 'guile-test-env'
<zacts>sup guys
<daviid>hello guilers
<daviid>wrt guile-gnome, make distcheck (a) creates a guile-gnome-platform-2.16.3 tree [as the user would get it untaring, (b) within that directory, creates a _build/ partial tree [not everything is copied but i did not get the logic yet] and (c) from that _build/ triggers tests, for example to run guile-gobject-test, it does "../../../glib/test-suite/guile-gobject-test" which leads to this error: exec: ./guile-test-env: not found
<daviid>because in the _build/ tree, there is no guile-test-env
<daviid>that said, what should be the correct guile-gobject-test top lines? currently it is: "#!/bin/sh\\nexec ${builddir:-.}/guile-test-env guile --debug -e main -s "$0" "$@"\\n!#
<daviid>i shooted "... ${srcdir:-.}/guile-test-env ...", but it fails the same way
<daviid>or is it that guile-test-env should also be part of _build/
<daviid>if that is the case, i wonder where and what to change so that happens?
<daviid>no, guile-test-env should not be part of _build/
<daviid>so, i have to find out what autotool variable is bound to <git-clone>/guile-gnome-platform-2.16.3 while running distcheck, anyone?
<daviid>$(top_builddir) maybe?
<daviid>that did not work either
<civodul>Hello Guilers!
<daviid>hello civodul!
<daviid>civodul: i can't find a solution for this make distcheck [wrt guile-gnome] failing on ../../../glib/test-suite/guile-gobject-test: 2: exec: ./guile-test-env: not found
<daviid>i must say i don't get the logic yet [why a _build partial tree for example, why not running check in the just created guile-gnome-platform-2.16.x], but here is what happens:
<daviid>make distcheck (a) creates a guile-gnome-platform-2.16.3 tree [as the user would get it untaring,(b) within that directory, creates a _build/ partial tree [not everything is copied but i did not get the logic yet] and (c) from that _build/ triggers tests, for example to run guile-gobject-test,it does "../../../glib/test-suite/guile-gobject-test" which leads to this error: exec: ./guile-test-env: not found
<civodul>daviid: sorry, i can't really help without trying it myself, i'm afraid
<daviid>here is the file: http://git.savannah.gnu.org/cgit/guile-gnome.git/tree/glib/test-suite/guile-gobject-test?h=devel
<civodul>(and i'm trying to stay focused on other things ;-))
<daviid>civodul: is it not the same logic for guile, i mean it would create a guile-2.x.x. then a partial tree _build under that and ...
<daviid>civodul: oh, ok, it's that you kindly helped me in the past [http://git.savannah.gnu.org/cgit/guile-gnome.git/commit/?h=devel&id=06ac149655c1f0aa864b948d009717ea7e75e3bc] and i tried everything i could without success: so whenever it is possible, it would be nice if you could look at it [and the above commit i changed guile-gobject-test to use ${builddir:-.} not ${srcdir:-.}, otherwise make check would not work, now make distcheck does
<daviid>not work... [maybe something is missing in Makefile.am, don't know... anyway, tx, ping me when you can
<kirill>hi all! is it a thing to run guile on ios at all?
<kirill>... if we pretend for a moment that gpl-related issues aren't an obstacle?
<davexunit>is there an easy way for conditionally evaluating code based upon the platform it is run on?
<davexunit>for example, I'd like to watch some files for changes using inotify when the kernel is linux, or a simple polling method otherwise.
<ijp>davexunit: I think cond-expand can do it based on platform
<ijp>hmm, maybe not
<civodul>davexunit: check the %host-type variable
<civodul>better yet: (dynamic-func "inotify_init" (dynamic-link))
<civodul>(works for the GNU libc)
<davexunit>civodul: but what if that isn't available? is it always?
*davexunit is throwing together some plans for a static site generator
<civodul>glibc for Linux always has inotify_init
<davexunit>okay. well I'll still need to check %host-type in case guile was running on OS X or windows or whatever, so I can fallback to polling.
<civodul>well on the other OSes 'dynamic-func' would just throw
<civodul>so you could do (if (false-if-exception (dynamic-func ...)) ;use inotify ;else don't)
<civodul>it's a feature test, which some describe as The Right Thing ;-)
<davexunit>civodul: thanks. I'll take that approach when I write the code.
***cluck` is now known as cluck