IRC channel logs

2014-11-24.log

back to list of logs

<nalaginrut>morning guilers~
<sneek>Welcome back nalaginrut, you have 3 messages.
<sneek>nalaginrut, ArneBab says: I did not test let () ... yet, but the syntax would be “let :\\n ...”
<sneek>nalaginrut, ArneBab says: I’m not sure about the efficiency: It iterates the file as string once to get the indentation levels and then (I think) twice to generate a code tree and to clean it up.
<sneek>nalaginrut, ArneBab says: Sorry for disappearing without word: I hadn’t expected that I’d be gone 2 hours.
<nalaginrut>ArneBab: I would recommend add '(let () " in the text as a special case. For common cases, users may deduct from the rules easily
<Chaos`Eternal>helo, guilers
***Sgeo is now known as Woosh2
***Woosh2 is now known as Sgeo
<ArneBab>nalaginrut: I now added that let () - thanks!
<nalaginrut>ArneBab: how about named let?
<nalaginrut>(let lp(...)
<ArneBab>let NAME …
<ArneBab>let loop
<nalaginrut>let name :\\n ?
<ArneBab> : foo 'bar
<nalaginrut>for (let lp()
<ArneBab> write foo
<ArneBab>let loop : \\n body
<nalaginrut>alright, I got the rule
<nalaginrut>;-P
<nalaginrut>I hope this \\n magic could be mentioned in the text
<nalaginrut>well, and I think I could write some chaos code: let let:lp : \\n
<ArneBab>nalaginrut: \\n is just a shorthand I use here. You have to use a real linebreak
<ArneBab>or real parentheses :)
<ArneBab>let loop () body ; is valid wisp.
<nalaginrut>ah
<nalaginrut>I thought it's \\n
<nalaginrut>ok, I thought parens can't be used in wisp
<ArneBab>nalaginrut: they can be used wherever you wish. wisp just disables indentation parsing in parens - so code in parens works just like scheme
<ArneBab>you can throw in a block of scheme and it will just work.
<nalaginrut>oh, sounds nice
<ArneBab>(that’s simply carried over from SRFI-49 and SRFI-110)
<nalaginrut>ok
<nalaginrut>oh!my! irregex main site is down
*nalaginrut wants to use irregex to eliminate double hyphen
***Shozan is now known as SHODAN
<Chaos`Eternal>helo guilers
<nalaginrut>it's pretty nice to play SRE
<nalaginrut>maybe I should write a tutorial for it
<nalaginrut>well, SRE will reduce 10x after compiled
<nalaginrut>I mean faster 10x
<civodul>Hello Guilers!
<dsmith-work>Morning Greetings, Guilers
<paroneayea>hey guilers
<paroneayea>and dsmith-work
<paroneayea>what's up
<Fuuzetsu>davexunit: Nice 3 columns in the FSF bulletin ;)
<davexunit>Fuuzetsu: heh, thanks! :)
<amz3>which bulletin are talking about?
<davexunit>amz3: the FSF fall bulletin
<paroneayea>hm
<paroneayea>I got the bulletin in the mail but can't find it
<paroneayea>it looks like the 2014 bulletins aren't on https://www.fsf.org/bulletin/
<davexunit>looks like we need to upload the last 2
<amz3>that's why I can't find it ^^
<civodul>someone™ needs to port https://github.com/arcfide/goscher to Guile
<civodul>it feels like an urgency
<davexunit>civodul: what does this do? the readme confuses me
<civodul>it's a Gopher server
<davexunit>I'll look up what that is sometime
<dsmith-work>civodul: gopher! Do people still use that? (I never have..)
<civodul>i've never used it, but somehow, i'm fascinated :-)
<civodul>it seems so underground
<paroneayea>civodul: is that a pun
<civodul>hmm, no
<BW^->guys, what's the SMP support like? :)
<civodul>BW^-: Guile has threads implemented in terms of POSIX threads
<BW^->aha
<BW^->civodul: does it also have green threads within the Posix threads?
<civodul>it doesn't have "green threads", but it has delimited continuations, which can be used to implement coroutines
<civodul>is that what you mean?
<davexunit>did someone say coroutines? https://gitorious.org/sly/sly/source/5361a105fdcb097def20caa980b1956973810b94:sly/coroutine.scm
<BW^->aha
<BW^->civodul: hmhm
<BW^->civodul: it has call/cc right?
<BW^->civodul,davexunit: no, I meant what Gambit means by |make-thead|
<davexunit>oh
<BW^->that's a green thread running within the green threads swarm in the OS thread
<BW^->however, Gambit does not support OS (=POSIX) threads currently, so that is its issue.
<civodul>davexunit: nice!