IRC channel logs

2014-10-22.log

back to list of logs

<dsmith-work>pallagun: dynamically loaded .so's are looked up in the extendion(s) dir
<dsmith-work>Man. Sorry for my misspelling.
<pallagun>dsmith-work: oh! I recall hearing of strace once or twice, I'll see what that can tell me. Thanks
<dsmith-work>pallagun: http://www.gnu.org/software/guile/manual/html_node/Foreign-Libraries.html#Foreign-Libraries
<dsmith-work>pallagun: what does pkg-config --variable=extensiondir guile-2.0 say?
<pallagun>dsmith-work: it says "/usr/lib64/guile/2.0/extensions"
<pallagun>also: wow, strace says many, many things
<dsmith-work>strace -efile
<dsmith-work>To limit to file operations.
<dsmith-work>(open,read, etc)
<dsmith-work>Ok, that's one place it's looking.
<pallagun>oh! there is the path my .so file is at
<dsmith-work>pallagun: Probably should not include the ".so" in your argument.
<pallagun>access("/home/user/.ld_library_path/libguile-scg.so", R_OK) = 0
<pallagun>open("/home/user/.ld_library_path/libguile-scg.so", O_RDONLY|O_CLOEXEC) = 9
<pallagun>dsmith-work: those two line are the only ones referencing my .so file
<dsmith-work>Ok!, It got a file handle.
<dsmith-work>( 9 )
<pallagun>there are about 8 more lines before guile comes back and tells me "file not found" and none of them mention my .so file
<dsmith-work>Hmm. reminds me of something...
<pallagun>it does appear to check /usr/lib64 and /usr/lib64/guile/2.0/extensions for my .so file as well, where it fails to find it (since I didn't put it there)
<dsmith-work>So is the name of your init function correct? ISTR something like when it can't get to that name, an error is returned, which eventually percolates up to "file not found".
<pallagun>oh really? I can check on that, one moment
<pallagun>I belive it's right. my scm looks like "(load-extension "libguile-scg" "init_scglib")" and my c/h files have "void init_scglib(void);"
<pallagun>maybe there is some cache someplace I'm not properly wiping.
<dsmith-work>Hmm.
<dsmith-work>Can you tell if your init is being called? (like with a printf)
<pallagun>oh, good point. One moment
<pallagun>no, there appears to be no print statement
<dsmith-work>Oh. Remebered something else..
<dsmith-work>If this is in a .scm file, wrap your load-extension with (eval-when (load eval compile) (load-extension .. ..))
<pallagun>oh? ok, I'll try that.
<dsmith-work>IF you are on 2.0
<pallagun>2.0.9
<dsmith-work>(or greater)
<pallagun>dsmith-work: same results sadly
<dsmith-work>pallagun: Does your init get called?
<pallagun>no, it does not. I fear there is something incredibly simple that I'm missing and I'm simply not seening it right now
<pallagun>dsmith-work: in any case, I've got to head out. Thank you for the help!
<dsmith-work>Hmm..
<dsmith-work>np
<dsmith-work>WHat does ldd on your .so say?
<dsmith-work>Can all the .so's IT needs be found?
***karswell` is now known as karswell
<nalaginrut>morning guilers~
<paroneayea>hi nalaginrut
<nalaginrut>heya
<dsmith-work>Morning Greetings, Guilers
<stis>hej guilers!