IRC channel logs

2014-10-21.log

back to list of logs

<nalaginrut>morning guilers~
<nalaginrut>I'm reading rbtree again these days, and I realized that the deletion in rbtree.ss (dwells in guildhall) is wrong
<nalaginrut>the insertion is fine
<nalaginrut>here's my version, but I still testing the deletion https://github.com/NalaGinrut/nashkel/blob/master/nashkel/rbtree.scm
<nalaginrut>there's something vague (I can hardly say wrong) in the book <<introduction to algorithm>>, so it's painful while checking and testing the implementation
<davexunit>grrr, goops generics don't work with record types
<nalaginrut>maybe wrap them in to a class?
<davexunit>that's ugly.
<davexunit>this limitation really screws up one of my plans
<davexunit>to use the generics feature without buying into the rest of the OOP stuff.
<davexunit>wellp, guess I won't be using generics... bummer.
<davexunit>I guess goops does special things to make <integer>, <string>, etc. classes
<nalaginrut>I think it's different between record-type and class, although record-type has inheritance now
<nalaginrut>davexunit: btw, it's different result of class-of between srfi-9 and rnrs record-type...
<davexunit>I guess I'll just make a little record type for what I'm doing.
<mark_weaver>sneek: later tell davexunit: it turns out that GOOPS generics will work with SRFI-9 records, but you can't simply use the first argument to 'define-record-type' as the class name. I don't know what's the best way to do it, but if you create an instance of the record type, then use (class-of <instance>) to get the class object, you can use that class object to define methods.
<sneek>Got it.
<mark_weaver>sneek: later tell davexunit: it's awkward though. we should improve this.
<sneek>Will do.
***heroux_ is now known as heroux
***byte48 is now known as Guest14756
<davexunit>hello sneek, I hear you have a message for me. :)
<sneek>Welcome back davexunit, you have 2 messages.
<sneek>davexunit, mark_weaver says: it turns out that GOOPS generics will work with SRFI-9 records, but you can't simply use the first argument to 'define-record-type' as the class name. I don't know what's the best way to do it, but if you create an instance of the record type, then use (class-of <instance>) to get the class object, you can use that class object to define methods.
<sneek>davexunit, mark_weaver says: it's awkward though. we should improve this.
<nalaginrut>mark_weaver: I think there's no any possible to specify 'src' to the procedural Tree-IL while I'm using LALR parser, no?
<nalaginrut>or did I miss something?
<nalaginrut>If the answer is negative, I'll use the sexp Tree-IL
<davexunit>mark_weaver: thanks for that! I actually discovered that myself a couple of hours ago. I will see how easy it is to make define-method support record types.
<zdavis>Hi all- I am trying to update the repl so that ,L without an argument gives a list of available languages to switch to. So far, I have a list just hard-coded. Does anybody have any suggestions for looking up the possible language choices reflectively?
<nalaginrut>zdavis: I believe there's no such feature, since I've proposed a patch to list all the available languages, but it's never applied...
<wingo>zdavis: dunno, find all locations that (language) could resolve as, then look in those dirs; see ice-9/boot-9.scm for details on module->path mapping
<nalaginrut>zdavis: and you may use 'for-humans?' to detect the proper language
<nalaginrut>language-for-humans? in (system base language)
<dsmith-w`>Morning Greetings, Guilers
***dsmith-w` is now known as dsmith-work
<nalaginrut>heya dsmith-work
<nalaginrut>sneek: later tell janneke I think your patch to lalr-scm added source-location info, which could be used in procedural Tree-IL 'src' slot. But I don't know how to use this new feature. Is there any document or tutorial? ;-)
<sneek>Okay.
***dje is now known as xdje
<pallagun>Are there any things I need to do get guile to allow me to (dynamic-link "mylib.so")? I built as described in manual section 5.16.4.3. I've placed the resulting .so in my LD_LIBRARY_PATH which I exported in my .bashrc. I swear this worked for me last week but now I keep getting a "ERROR: In procedure dynamic-link: file: "mylib.so", message: "file not found""
<pallagun>I can't seem to find what I've done to mess it up.
<dsmith-work>pallagun: A great tool to use for this is strace.
<dsmith-work>shows you exactly what files and where it's looking.