IRC channel logs

2014-09-07.log

back to list of logs

<paroneayea>arg
<paroneayea>I hope sfri stuff is fixed in debian before the freeze
<paroneayea>er
<paroneayea>not sfri
<paroneayea>bleh
<paroneayea>slib
<rlb>paroneayea: what's the issue?
<mark_weaver>rlb: I think that the version of slib in debian may be too old to work properly with guile 2.0
<mark_weaver>last I checked, the newest version of slib was the only version that supported guile 2, and it was not yet in debian
<rlb>hmm...
<mark_weaver>yep, we need 3b4, but sid has 3b1
<rlb>offhand, first step might be to file a wishlist bug against slib
<rlb>(if there's not one already) -- though arguably, this might be higher than wishlist
<rlb>i.e. slib doesn't work with guile-2.0 which *is* in sid -- so might be "normal"
<rlb>sid/testing/jessie
<mark_weaver>paroneayea: would you like to make sure that there's an appropriate bug filed in the debian BTS?
<rlb>I don't know what the current situation is wrt slib -- could be tb just doesn't know.
*rlb is trying to figure out how he might map clojure's interfaces most efficiently to guile's current facilities...
<rlb>s/interface/protocol/
<rlb>I'm sure it could be done via goops, but that's of course, the big sledgehammer...
<rlb>(clojure's protocols are designed to be efficient -- mapping fairly directly onto bits that are fast in the jvm, so that for the common cases you don't have the expense of full-blown multimethods)
<rlb>(multimethods are iirc much closer to goops)
<rlb>I think rms also helped me sort out the epl vs guile (lgpl) issue (asked here earlier) -- pointing out that my question was perhaps irrelevant b/c we really need everything in guile to be compatible with the gpl (if also compatible with the epl). So we'd either need new gpl-compatible code, or dual-licensing from the relevant epled-code contributors.
<rlb>(all wrt a currently *completely* hypothetical clojure/guile dialect)
<davexunit>I just wrote a macro that transforms (foo (bar 1)) into (foo #:bar 1), but it's super ugly.
<rlb>davexunit: for?
<davexunit>rlb: trying to create a little DSL for a library of mine
<ijp>why not just use keywords directly?
<davexunit>I don't find them pleasing, and the indenting rules are strange.
<rlb>I'm actually toying with the idea of bringing some of the (to me) interesting bits of clojure to guile directly, and then (if I were to keep going), add a clojure dialect that built on those.
<rlb>i.e. would like both guile and clojure/guile to have the sequence abstraction available.
<davexunit>I'm trying to write a DSL for describing a 2D/3D scene graph.
<ijp>it probably also doesn't matter, but such a macro is probably not hygienic
<davexunit>and I'm not happy with (scene-node #:position ... #:children (list ...))
<ijp>but it depends on how you implemented it
<rlb>(partition ... coll) for coll == list/vector/map/set, etc.
<davexunit>ijp: is it possible for me to create a non-hygienic macro with define-syntax-rule ?
<rlb>(hence my question about protocols)
<davexunit>I'm still pretty weak with the macro system.
<ijp>davexunit: it is not obvious to me that you can
<ijp>rlb: you will probably need to use goops
<rlb>ijp: thanks -- I suspected, but wanted to make sure something else hadn't been added recently.
<ijp>well I'd propose something else for guile if I could come up with something better
<rlb>(protocols are much more limited -- but are fast on the jvm -- mapping very closely to java dispatch)
<ijp>but frankly, I don't like any of the ad-hoc polymorphism solutions in dynamic languages
<rlb>(one of clojure's principles being pragmatism wrt the platform in any given dialect)
<ijp>in practice, I've often done "interface passing"
<ijp>basically typeclasses but with manual plumbing
<ijp>there are some cute tricks you can do with open recursion that feel schemey, but most people wouldn't like it in practice
<rlb>may also try to produce an edn module for guile... time permitting
***JudgeDreadlock is now known as Johann
***Johann is now known as Johann\\
<paroneayea>hm
<paroneayea>for the script I'm writing, some data is being sent across the wire
<paroneayea>my default feeling is "use json!" but maybe I should just dump some sexps and read them on the other end... I guess I need to read into the safety of that in guile
<ijp>take care not to WRITE values you can't READ back
<davexunit>paroneayea: yeah, read sexps.
<davexunit>reading isn't the same as evaluating.
<davexunit>you'll be fine.
<ngz>This is slightly off-topic but I'm trying to get guile-wm running in Xephyr. I copied default .guile-wm and fixed it a bit (I have neither F20 key nor proggyfont installed). But all I get is a black screen. There's no error in /tmp/guile-wm.log either.
<ngz>Does anyone have some clue about what to do next?
<davexunit>ngz: is the guile-wm process actually running?
<ngz>If I close the Xephyr window, I get some backtrace with pointers to xcb/xml/struct.scm and /usr/bin/guile-wm. So I guess it was running.
<ngz>Moreover, /tmp/guile-wm.log is modified.
***Johann\\ is now known as imaaminpoika