IRC channel logs

2014-08-11.log

back to list of logs

***linas_ is now known as linas
<nalaginrut>morning guilers~
<nalaginrut>I found a very strange bug in master, it's fine in stable-2.0, but I don't know how to reproduce it
<nalaginrut>anyway, I can reproduce it everytime here
<nalaginrut>I mean how to tell other guys to reproduce it, without giving my code...
<janneke>nalaginrut: hard to isolate a small snippet that exposes the bug?
<nalaginrut>janneke: a little hard, it's so strange because it's ok under stable-2.0,
<nalaginrut>well, it's about syntax-rules
<nalaginrut>but I can't say it's the bug of syntax-rules
<nalaginrut>it appears that one of the rule of macro can't be found, although it works when you run the line code directly
<nalaginrut>my problem has no problem, when I tested in stable-2.0
<nalaginrut>s/problem/program
*nalaginrut is trying to isolate a snippet
<nalaginrut>I think it's hard to isolate, because it only appears when you call it in certain module
<nalaginrut>hmm...it's ok when I removed srfi-1 from import list...
<nalaginrut>well, I think I found something, I imported srfi-1, but after some modifications, the program happens not to use any srfi-1 symbols, then there's the problem
<nalaginrut>It works when I removed useless srfi-1 from import list
<nalaginrut>I don't think it's normal ...
<lloda>iirc srfi-1 redefines some functions that are in (guile), or it used to
<nalaginrut>but I didn't create symbols same with srfi-1 symbols IIRC
<nalaginrut>BTW, I've reported it to bug-guiel
<nalaginrut>bug-guile
<plotr>anyone used guile-scheme-mode for emacs?
<plotr>or, more general, which mode do you prefer for editing guile?
<taylanub>plotr: wasn't aware of a guile-scheme-mode .. scheme-mode with Geiser enabled is pretty fine
<taylanub>and Paredit of course!
<taylanub>that's the most important part, in fact; I'd probably be totally fine without syntax highlighting in Lisp
<plotr>thanks - didn't know about geiser
<plotr>Ok, let is just a syntactic sugar for lambdas - what if I got to use let, than some value produced in let body got to further binded to some var - use nested let, and again and again
<plotr>is there some sugar for those nested (let .. (let.. ?
<plotr>or more like - what's the most acceptible style for such things in guile?
<davexunit>plotr: let*
<davexunit>(let* ((x 1) (y (1+ x))) ...)
<plotr>doh! I've even saw it in the tutorial
<plotr>thanks
<dsmith-w`>plotr: Yeah, it's lambdas all the way down..
***dsmith-w` is now known as dsmith-work
<davexunit>plotr: yw
<taylanub>it's lambdas all the way except for letrec/letrec*/define, which lambdas can't model
<plotr>rec in letrec is from 'recursive'?
<lloda>yes
***optimus_swine is now known as CuneytArkin
<paroneayea>so
<paroneayea>I'm planning on picking up two scheme books then, which I figure should be The Little Schemer and The Reasoned Schemer, especially because I'd love to undersand logic programming
<paroneayea>those two seem probably more important than picking up The Seasoned Schemer
<paroneayea>I think :)
<paroneayea>(but I haven't read them, that's looking from the outset)
<davexunit>SICP is also great, and available in HTML form under CC-BY-NC
<davexunit>granted it's more about teaching how to do computer science, something you know how to do already, but it's got a lot of interesting problems and examples
<paroneayea>yeah, I might refer to that if I need some particular specifics
<ota>Even very experienced CS folks can hardly go wrong working through SICP.
<ota>I did it with my son, and found it very interesting.
<plotr>recently I've seen plenty "but in modern days we tend to use X instead of Y in guile" - is there some style guide or best-practices paper which covers such things?
<taylanub>plotr: hmm, none that I know of, though the manual might have a couple
<taylanub>those things probably come from more general trends in the Scheme world, or do you have something Guile-specific in mind?
<davexunit>plotr: the only instances I can think of are:
<plotr>not really - I'm just learning it so it would be nice to learn "the right way" of doing things from the start :)
<davexunit>1) use pattern matching via (ice-9 match) instead of car/cdr/cadr/cadadr/etc.
<davexunit>2) use record types instead of lists for describing new data types
<dsmith-work>3) Use Scheme instead of C
<plotr>which records do you mean - I've stumbled upon at least 3 different implementations so far
<taylanub>plotr: SRFI-9
<taylanub>they've been standardized in R7RS too
<plotr>which RxRS is supported by current guile btw?
<taylanub>if you want something more fancy you can use R6RS records I suppose; if you want full OOP there's GOOPS
<taylanub>plotr: full R7RS support is almost-complete in a branch; otherwise R5RS, and select parts of R6RS
<plotr>cool, thanks
<taylanub>(R6RS is quite big and some parts of it didn't catch much adoption...)
<taylanub>(big in comparison to 5 or 7)
<plotr>is there some article comparing SRFI-9 records with R6RS records?
<taylanub>hm, SRFI-9 ones are really really simple. R6RS ones are somewhat fancy but I think one can also grok them in full, so I'd say just look at both and you'll have the comparison in your mind :)
<davexunit>I've only used srfi-9 records
<taylanub>on retrospect, grokking R6RS records is nontrivial. the intent of "sealed" records is not immediately obvious, and the "protocol" stuff is quite complicated (but rightfully so once one groks it)
<zacts>hi guile hackers
<dsmith-work>Hey hey
<dsmith-work>Aww. sneek is gone again
<civodul>Hello Guilers!
<davexunit>welcome back civodul!
<davexunit>can anyone compile guile master successfully?
<mark_weaver>I did recently.
<davexunit>I need to try again when I get home and post the error if it fails again.
<mark_weaver>make sure to set GC_MARKERS=1 to work around the libgc bug
<mark_weaver>the libgc 7.4.0 bug, that is.
<davexunit>okay.
<davexunit>I'll try it.
<davexunit>time to head home and see how it goes.
<xdje>I thought GC_MARKERS=1 had been added to the source tree.
<xdje>[e.g. no need to set it externally]
<mark_weaver>ah, indeed you are right
<xdje>I remember checking as I added the same workaround to gdb. :-)
<dsmith-work>I've been building master ok.. Two make check errors in coverage.test
<mark_weaver>same here
<dsmith-work>I know 64bit machine complies ok. Pretty sure 32bit does too.
<CuneytArkin>dsmith-work
<CuneytArkin>Have you ever noticed that a lot of people recnetly have started to use possessive determiners seemingly indefifinitely
<CuneytArkin>As in "I'm talking to my friend right now" where "I'm talking to a friend of mine right now" would be more conventional.
<CuneytArkin>As in, when you have no idea what friend is referred to.
<mark_weaver>I built it on a 32-bit machine, and it does work.
<dsmith-work>CuneytArkin: My command of english is not that great.
<CuneytArkin>dsmith-work, pardon, I had no idea.
<CuneytArkin>I'm just wondering if I'm going insane.
<CuneytArkin>I'm fairly certain that conventionally, one would not say "I'm talking to my friend right now" when you have no idea what friend that is, only if the friend has been already established in some way.
<dsmith-work>CuneytArkin: You could even say it's not my (written) native language. (C is)
<CuneytArkin>I pity the fool.
<CuneytArkin>If the Sapir Whorf hypothesis is true, I'm fairly certain that having C as a native language leads you run very very quickly alongside walkways with no safety rails.
<dsmith-work>It is what we used in '84
<CuneytArkin>That was before airbags, mind you.
*dsmith-work fwaps CuneytArkin with an e-lisp manual for reminding him of 64k segments and dos.
<CuneytArkin>Even so.
<ijp>conventions change
*taylanub started with Bourne shell yet transitioned to Lisp just fine
<taylanub>CuneytArkin: funny nick by the way
<CuneytArkin>Say I said to you "I'm going to eat with my freind, be back soon"
<CuneytArkin>Surely that would read a bit weirdly?
<ijp>not really
<CuneytArkin>Surely "I'm going to eat with a friend of mine, be back soon" would read better.
<CuneytArkin>taylanub, ah yes
<CuneytArkin>Cüneyt Arkin, the greatest Turkish action star to have ever lived.
<CuneytArkin>Also sporting a fine mullet.
<ijp>but why bring this up on #guile, and not some linguistics channel?
<mark_weaver>ijp++
<dsmith-work>ijp: tack
<mark_weaver>fwiw, as a native english speaker, I don't find "I'm going to eat with my friend" particularly unusual or grating to the ears.
<CuneytArkin>Hmm.
<CuneytArkin>Interesting.
<taylanub>CuneytArkin: (actually Arkın, FWIW. but let's not get more off topic)
<CuneytArkin>Yes, I cannot make the dotless I.
<mark_weaver>I agree that "with a friend of mine" is a bit nicer, but hardly worth starting a long discussion over on #guile.
<CuneytArkin>Damn shame.
<CuneytArkin>Should probably look up how.
<CuneytArkin>That is true.
<CuneytArkin>Truth be told, I didn't look at the name of the channel when I asked.
<dsmith-work>Enlish is quite flexible, and can be bent into all kinds of twisted shapes.
<CuneytArkin>I'm not saying it's wrong, it just seems new to me.
<CuneytArkin>I do a double take when reading it, still.
<dsmith-work>I've found that quite a few non-native speakers have a *much* better command of the language than some random American.
<dsmith-work>mvo and civodul come to mind
<CuneytArkin>Well, more literary.
<CuneytArkin>Often not more fluent, but a higher literary style.
<CuneytArkin>Seldom does an American these days still properly use the word 'whom' or even 'I'
<ijp>whom is basically deprecated
<CuneytArkin>When they say 'Jane might have done that, but not me.', my heart wallows in pain.
<CuneytArkin>ijp, see, this is what I mean.
<CuneytArkin>What part of the world are you from m'lady.
<ijp>NE Scotland
<CuneytArkin>Ah yes, do you speak like Paul McGilllion?
<ijp>I have no idea who that is
<CuneytArkin>"Ere's me bloody accent mate'
<CuneytArkin>A Canadian actor with a fine Scottish accent.
<ijp>I find it hard to talk like that without laughing
<mark_weaver>adverbs are being deprecated as well.
<CuneytArkin>But are you a true scottsman?
<ijp> http://shift-reset.com/tmp/see_you_sonny_jim.ogg
<CuneytArkin>Is the only thing between the elements and your manhood a kilt and nnothing more?
<ijp> http://shift-reset.com/tmp/lambda_calculus.ogg is closer to how I talk normally
<CuneytArkin>mark_weaver, well, only in certain positions.
<CuneytArkin>"I'm going quick" occurs, but "quick I go" not really, then they still say quickly.
<CuneytArkin>Or "That is undeniably brilliant"
<ijp>"why yes, I do have voice samples on my website. doesn't everyone?"
<CuneytArkin>Not 'that is undeniable brilliant"
<CuneytArkin>Hmm
<mark_weaver>*nod*
<CuneytArkin>That does not sound quite as scottish as I hoped.
<mark_weaver>but this is all very off topic here
<dsmith-work>TRue
<ijp>CuneytArkin: my sisters would be more to your liking, but I don't have samples of them
<CuneytArkin>mark_weaver, can't you rotyally decree the topic to be both guile and scottish accents?
<CuneytArkin>Like how the Sultan at the end of Alladin solved the problem from the start of the film "I now decree that princesses can marry anyone they like"
<davexunit>error when building master:
<davexunit>guile: uncaught throw to misc-error: (load-thunk-from-memory not an ELF file () #f)
<davexunit>for ice-9/psyntax-pp.go