IRC channel logs

2014-07-21.log

back to list of logs

***ad___latebras is now known as the_essential_le
***the_essential_le is now known as essential_lemur
<joolean>Howdy, #guile!
<joolean>What are the Cool Kids (i.e., people on master) doing to inspect SCMs in GDB these days? It looks like gdb_print was removed.
<joolean>Specifically, it looks like wingo removed it with a5d0c1
<nalaginrut>morning guilers~
<nalaginrut>I think Content-Length:0 bug was fixed in master, right? I know it's fixed in stable-2.0
<nalaginrut>if-none-match can't accept a normal string as etag?
<nalaginrut>maybe it's a bug
<dsmith-work>Hey hey
<dsmith-work>stis__: Hej!
<wingo>heya dsmith-work
<stis__>tja dsmith-work
<ijp>./stdio.h:1034:1: error: 'gets' undeclared here (not in a function) _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead"); ^
<ijp>never seen that one before
<ijp>maybe I'll clear my config cache and try again
*stis__ is feeling the power of mother nature (thunder and lightning)
<ijp>yeah, seems it was just a stale cache
<ArneBab>stis__: here it’s great, too!
<ArneBab>I wrote a script which uses binomial expansion, and when my numbers get too big, it returns +nan.0
<ArneBab> http://paste.lisp.org/display/143195
<ArneBab>do you know how I can make it cope with huge numbers?
<ArneBab>to test:
<ArneBab>wget http://paste.lisp.org/display/143195/raw; guile -L .
<ArneBab>then
<ArneBab>(use-modules (spielfaehig))
<ArneBab>(spielfähig 0.02 4000 70)
<ArneBab>easier: wget http://paste.lisp.org/display/143195,1/raw -O spielfaehig.scm; guile spielfaehig.scm
<lloda>.02 is inexact, so it'll be done in floating point. Try 1/50 or #e.02 (?)
<ArneBab>I’ll try that, thanks!
<ijp>sounds slow
<ArneBab>it is, yes
<ArneBab>it was originally intended for n up to 20 and min_players up to 9
<ArneBab>and p around 0.9
<ArneBab>but it proved to be extremely useful for quick probability checking…
<lloda>if the big numbers only appear in the intermediate steps, there should be a better way to compute that, but I don't know
<ArneBab>I’m now using exact math
<ArneBab>first observation: the memory usage rises
<ArneBab>with floats: 14MiB, with (/ 1 50) it’s already at 30MiB.
<ArneBab>(which still is very little memory)
<ArneBab>something weird happened there… I got a huge number in return
<ArneBab>seems that it was just the exact representation
<ArneBab>which I could not parse by eye
<ArneBab>(exact->inexact (...)) helped
<ArneBab>thanks a lot!
<ArneBab>working version: http://paste.lisp.org/display/143195#2
<ArneBab>here’s the conclusion from that: http://draketo.de/english/exact-math-to-the-rescue
***essential_lemur is now known as EvilTheCat
*wingo found a nice bug in soft ports
<civodul>howdy wingo!
<civodul>wingo: what kind? :-)
<wingo>civodul: not a crasher :)
<wingo>source locations at the repl are almost always wrong
<wingo>i have a patch i'm testing
<wingo>greets btw!
<dsmith-work>wingo: That last update fixed the last error I saw. But added a new one. coverage.test now fails.
<civodul>oh, location info that gets lost
<wingo>dsmith-work: yep, working on that
<dsmith-work>wingo: Cool
<wingo>in a local branch i patched the reader to add source info to the spine of lists, not just the head
<wingo>maybe that will give us source info for lone symbols and immediates
<wingo>tough to plumb it through psyntax though
<civodul>heh
***EvilTheCat is now known as Turkish_pizza
<dsmith-work>wingo: Gonna give a talk at http://lists.gnu.org/archive/html/guile-user/2014-07/msg00018.html about guile 2.{1,2}, elf, and the rest? ;-)
*dsmith-work ducks before wingo can swing
<civodul>and at http://lists.gnu.org/archive/html/guile-user/2014-06/msg00005.html !
<civodul>argh
<civodul>dsmith-work: you'll have to ping him again :-)