IRC channel logs

2014-07-12.log

back to list of logs

***jao` is now known as jao
***haroldwu_ is now known as haroldwu
<davexunit>does guile have an equivalent to this python function? https://docs.python.org/2/library/socket.html#socket.htons
<davexunit>"Convert 16-bit positive integers from host to network byte order."
<ijp>,a hto would give you htonl and htons
<davexunit>figured it out.
<davexunit>(dynamic-func "htons" (dynamic-link))
<ijp>right, but it is unnecessary
<davexunit>yeah?
<davexunit>you're right
<davexunit>sorry, for some reason I didn't your first message right
***ActivateKruger is now known as DeKolonel
***DeKolonel is now known as Tsvekno
<mark_weaver>davexunit: how are you using htons? it's been deprecated in 2.0.11. I think you should be using the bitvector integer operations instead for that.
<sneek>mark_weaver, you have 1 message.
<sneek>mark_weaver, civodul says: re adding a MIPS build machine, we can discuss that, but basically it boils down to allowing hydra.gnu.org to access the machine over SSH, and that machine must have Guix installed
<davexunit>mark_weaver: like (htons 33445)
<mark_weaver>davexunit: well, I was looking for a slightly larger picture than that.
<mark_weaver>presumably you are constructing network packets, or maybe writing something to disk?
<mark_weaver>what are you doing with the result of 'htons', I mean.
<davexunit>oh I'm sorry.
<mark_weaver>no worries :)
<davexunit>I'm working with an API, and one of the functions takes a port in network byte order.
<davexunit>it's a C API that I'm writing bindings for, and the docs recommended using htons to do the conversion.
<mark_weaver>oh, interesting. it takes it as an int or long?
<mark_weaver>what API is this?
<davexunit>takes it as a uint16
<davexunit>mark_weaver: libtoxcore
<mark_weaver>ugh, that seems like a bad API decision to me.
<davexunit>could very well be.
<davexunit>I don't know anything about it, just trying to comply.
<mark_weaver>well, I'd consider doing the conversion within your binding.
<davexunit>okay. I'll do that.
<davexunit>thanks.
<davexunit>be back in a bit.
<mark_weaver>okay!
<dje42>Are there docs on sneek anywhere? The ability to send messages to someone even when they're not currently present is pretty cool.
<mark_weaver>sneek: help
<mark_weaver>dje42: do what I just did, and sneek will send you help in private messages.
<dje42>sneek: help
<dje42>thx!
<mark_weaver>yw!
<dje42>Hmm, #gdb could use sneek.
<dje42>Who could guide me in setting one up there?
<mark_weaver>dsmith is the person who wrote and runs sneek.
<sneek>Understood.
<mark_weaver>arg
<mark_weaver>sneek: forget dsmith
<sneek>Okay.
<mark_weaver>sneek: botsnack
<sneek>:)
<mark_weaver>dje42: I think that freenode has similar functionality accessible in some other way.
<dsmith>Ya
<dsmith>messageserv I think
<dsmith>noteserv ?
<dje42>Huh.
<mark_weaver>right, someone sent me a delayed message that way once, but I've forgotten the details.
<dsmith>memoserv!
<dje42>We often get questions whose answer can be found in apropos. How often does sneek apropos and sneek guile help get used?
<dsmith> https://freenode.net/services.shtml
<dsmith>dje42, Probably by no one but me.
<mark_weaver>dsmith: you added the apropos command very recently, didn't you?
<mark_weaver>I never remember seeing them before, anyway
<dsmith>sneek, guile help cons
<sneek>`cons' is a procedure in the (guile) module.
<sneek>- Scheme Procedure: cons x y
<sneek> Return a newly allocated pair whose car is X and whose cdr is Y.
<sneek> The pair is guaranteed to be different (in the sense of `eq?') from
<sneek> every previously existing object.
<dsmith>sneek, guile apropos file
<dsmith>And then seeks sends me the apropos output as /msg
<mark_weaver>nice!
<dsmith>The limit is 10 lines I think. sneek uses /msg if the output > 10
<janneke>b
***Tsvekno is now known as HalfALobster