IRC channel logs

2014-07-05.log

back to list of logs

<daviid>sneek: later tell civodul, there must be a way do avoid these warnings though and I'd like to get rid of them
<sneek>Got it.
<civodul>Hello Guilers!
<wingo>heya civodul :)
<civodul>howdy wingo :-)
<dsmith>Hey hey!
<dsmith>civodul, I did eventually get an image built.
<dsmith>Hmm. Just a minimal buildroot image with guile as the only additional target eats up 5.1G of disk to build.
<civodul>heh
<civodul>dsmith: you should really use Guix for that ;-)
<dsmith>Is there guix for beaglebone black?
<civodul>not particularly
<civodul>but i mean it can be used to cross-compile userland software at least
<civodul>though actually it may lack tweaks for ARM targets
<civodul>ok, so no ;-)
<dsmith>heh
<civodul>i'm not selling it well, am i? ;-)
<ijp>but wait, there's more....
<civodul>in theory it can even make your life brighter
<civodul>but that part isn't implemented yet
<ijp><ijp> ,best-salespitch <fsbot> BILLY MAYS HERE, AND I'M HERE TO TELL YOU ABOUT THE MOST IMPORTANT PRODUCT I'VE EVER ENDORSED: EMACS. BUT WAIT, THERE'S MORE, ORDER NOW, AND YOU'LL GET NOT ONE, NOT TWO, NOT THREE, BUT FOUR VIM EMULATION MODES FOR FREE!
<ijp>there really are four, but not all come with emacs
<civodul>heheh :-)
***janneke` is now known as janneke
<dsmith>ijp, Very good
<ijp>the code will need a rewrite, but I think I solved my last problem with my hamts module
<dsmith>sneek, botsnack
<sneek>:)
<dsmith>sneek, help cons
<daviid>hello guilers!
<dsmith>Heya daviid
<dsmith>sneek, guile help cons
<sneek>`cons' is a procedure in the (guile) module.
<sneek>- Scheme Procedure: cons x y
<sneek> Return a newly allocated pair whose car is X and whose cdr is Y.
<sneek> The pair is guaranteed to be different (in the sense of `eq?') from
<sneek> every previously existing object.
<dsmith>sneek, help
<dsmith>sneek, apropos port
<daviid>heya dsmith!
<dsmith>sneek, guile help foo
<sneek>Did not find any object named `foo'
<dsmith>sneek, apropos foo
<dsmith>sneek, guile help
<daviid>what happended to http://git.savannah.gnu.org/cgit/guile-gnome.git/, all subdirs permissions are now: d--------- ?
<daviid>i've just noticed because I wanted to send a link -> guile-gnome-corba-types.c and a paste about a [very small] patch that I beleive is ok _but_ crashes the [corba] test suite. the patch is merely to call scm_make_vtable instead of scm_make_vtable_vtable. let me organize a paste anyway, i'd like some help if possible...
<daviid> http://paste.lisp.org/display/143106
<davexunit>Hi guilers. I have the following expression: (display-backtrace (make-stack #t) (current-error-port))
<davexunit>and it prints the backtrace I want... mostly. however, the top stack frame isthe call to (make-stack #t) and I would like it not to be there.
<davexunit>I haven't quite figured out how to fix it.
<ijp>if you put a number after #t it will cut away that many frames
<ijp>the whole make-stack api seems a little weird to me, but whatever
<davexunit>ijp: oh, thanks. the documentation for make-stack confused me.
<davexunit>solved my problem. yay!
<davexunit>thanks
<daviid>the NEWS file says: ... This may affect user code if you were defining a procedure using scm_c_make_subr rather scm_c_make_gsubr. The solution is to switch to use scm_c_make_gsubr...
<daviid>can someone kindly explain what i should do :) ?
<civodul>daviid: you should use scm_c_make_gsubr to define procedures
<civodul>see scm_make_gsubr in libguile/deprecated.c
<daviid>you mean i should use scm_c_define_gsubr right?
<daviid>civodul: hey, hello!
<civodul>scm_c_define_gsubr is directly equivalent to the old scm_make_gsubr AFAICS
<ijp>I'm writing an accessor function, which optionally takes a default to return if there is no such value. Which is more perspicuous:
<ijp>1. pass in a (cons #f #f), check the return value with eqv?, and throw an error if we get back that cons
<ijp>2. pass in a thunk as the default that calls error, and always call the result
<daviid>civodul: yes, i've just seen the definition in deprecated.c, but new code should use scm_c_define_gsubr i guess so i'm going to change that too [in guile-gnome-corba-types.c]
<ijp>in the past I've done both e.g. (pfds bbtrees) does the latter
<daviid>civodul: could you kindly have a quick look at this: http://paste.lisp.org/+32F6/1
<ijp>hmm, (pfds psqs) does it the former way. hooray for consistency
*ijp makes a note
<daviid>can't find the definition for get-keyword
<ijp>it's a goops function
<daviid>i know
<ijp>in libguile/goops.c
<daviid>can't find the source code
<daviid>ah thanks
<ijp>git grep bro
<ijp>or tags, or something
<civodul>daviid: slight bug in the patch: should be scm_make_vtable (..., gsubr)
<civodul>and use scm_from_latin1_string rather than scm_from_locale_string (more efficient)
<daviid>ah, many thanks!
<civodul>ijp: i'm for option #1
<ijp>so, I was trying to think of a way to test something that only happens when two hashes collide, and my first though was "how on earth am I going to find two values that collide?"
<ijp>then it hit me: use f'ing const as the hash function
<ijp>simples!
***george2 is now known as george2_
***george2_ is now known as george2
<civodul>indeed :-)
<daviid>i'm further debugging corba, primitives.scm has a bug, here is a proposed patch: http://paste.lisp.org/display/143106#2 i'm asking because of a couple of quizz with this definition
<daviid>(1) it did not need the (or (get-keyword ... #f)) I think. (2) I could rename type as class, but i choosed the oposite because of the error message, wdyt and (3) why the (let* (object servant ior), they are not used are they?
<daviid>ot maybe gnome-corba-error is a 'non blocking' error, I guess so
<daviid>s/ot/or
<daviid>civodul: it still fails corba test-suite: ../../build-aux/test-driver: line 107: 1306 Segmentation fault "$@" > $log_file 2>&1
<daviid>
<daviid>here is the updated patch: http://paste.lisp.org/display/143106#3
<daviid>i would cope with 'wrapset.api failed with this test...' but segmentation fault is rather weird
<daviid>ok, if I manually run the test-suite it's fine, something is wrong with exit-with-summary, maybe
<daviid>the problem is I can not find any usefull info, test-suite.log just says 'FAIL', wrapset.log remains empty due to the segfault
<daviid>civodul: i was wrong [my manual prep for launching the corba tests was not proper, now it is] and it segfault executing (run-all-defined-test-cases), what could i do to get more info?
<daviid> http://paste.lisp.org/display/143106#4
<daviid>here is an strace [the beginning and the end of it [too big..]]: http://paste.lisp.org/display/143106#5
<ijp>does load hide exceptions?
<ijp>also, is there an easy way to break on a locally defined procedure?
<ijp>(note to self: it would be nice of ,foo gave help output when you don't add the right number of arguments)
<civodul>ijp: load doesn't hide exceptions
<ijp>well, then something funny is going on here
<daviid>civodul: I did comment all lines related to *-vtable and it does not segfault anymore. are we sure that scm_make_vtable returns the same type [of what it makes] then scm_make_vtable_vtable ?
<ijp>I think it has to do with top level values in compiled files, hmmmm
<daviid>i think i badly expressed myself here: somehow, (1) one of the corba tests fails probably because vtable is not a struct-vtable anymore, and (2) that causes a segfault, which is another problem i guess