IRC channel logs

2014-06-29.log

back to list of logs

<jcca>ft: Hi Can I do (define serial (open-output-file "/dev/ttyACM0"))
<jcca>ft: (configure-termios...)
<jcca>ft: (display "message" serial)
<jcca>ft: (close-port serial)
<davexunit>guile-2d has officially been renamed to "Sly"
<ft>jcca: You might need to be able to read from the file as well to be able to use ‘tc-get-attr!’ - I don't know because I didn't try with output-only files yet.
<jcca>ft: ok, thanks.
<davexunit>blam https://gitorious.org/sly/sly/
<jcca>ft: Why?
<ft>jcca: Can you elaborate? :)
<ArneBab>davexunit: are you sure about that name?
<ArneBab>Sly does not really sound positive…
<davexunit>I think it's pretty good.
<davexunit>it's similar to guile in meaning
<davexunit>so if sly is negative, so is guile. ;)
<ijp>guile has the advantage of not being in your typical persons vocabulary
<davexunit>true
<ijp>as an aside, if I ever wrote a scheme compiler, my plan was to call it baldrick
<ijp>(an *actual* compiler, not the toy ones I do anyway)
<ijp> http://www.toyota-4runner.org/attachments/5th-gen-t4rs/63794d1336528966-snorkel-update-baldrick.jpg
<ArneBab>davexunit: guile actually is in many peoples vocabulary: Guile Theme goes with Everything
<ijp>Guile there is a proper noun
<ArneBab>yes
<ArneBab>but the meaning is a very different one - and one nown internationally ☺
<ArneBab>known
<ArneBab>ijp: alternatives with a similar but positive meaning are wily and astute
<ijp>wily has unfortunate coyote connotations
<ArneBab>how about astute?
<ijp>anyway, naming this thing isn't my decision
*ijp sticks on SF2 theme songs
<ArneBab>jepp
<davexunit>didn't realize my choice of name would spark a conversation like this.
<davexunit>I think sly is okay. Some like it, others don't. Can't please everyone but it's good enough for me.
<ijp>guile 3d would have worked until you added 4d support
<davexunit>then I could name it tessarect
<davexunit>but when I introduced 5d...
<taylanub>guile-dimensions!!
<davexunit>too long of a name.
<ijp>guile superhappyfuntime
<ijp>shortened to shft
<davexunit>:P
<ijp>hmm, now I can't get https://www.youtube.com/watch?v=-VILgSsesD0 out of my head
***siel_ is now known as siel
***karswell` is now known as karswell
***_zxq9_ is now known as zxq9
<nalaginrut>what is amts & hamts?
<janneke>morning!
<janneke>do we have a procedure/module that resembles /usr/bin/diff ? (esp diff -uw)
***endou__ is now known as endou_
<alexei___>Hi, the return value of scm_c_export() is void contrary to what docs say https://www.gnu.org/software/guile/manual/html_node/Accessing-Modules-from-C.html#Accessing-Modules-from-C Consider applying this http://pastebin.com/qMX0jdsM
<wingo>alexei___: tx; can you drop a brief mail to bug-guile@gnu.org? my tree is borked atm, and that will make sure we don't forget
<wingo>no subscription needed; a mail to bug-guile makes a bug report
***_zxq9_ is now known as zxq9
<ArneBab>guile-XD ☺
<ArneBab>guile sh[i]ft also sounds fun ☺
<ArneBab>davexunit: But in the end it’s your tool - and there’s a limit to the effect of names (if sly works really well for many people, the name won’t really hurt that much).
<alezost>if it wasn't too late, I would suggest "gruile" ("gr" for "graphics"), besides it sounds a bit like "Grail"
*janneke just hacked a (define* (diff a b :optional (options "-u") (virtual-name-a "a") (virtual-name-b "b"))
<janneke>and wonders if and why he duplicated some efforts, or else where he could dump it
***nalaginrut_ is now known as nalaginrut
<wingo>persistent bit sets: http://git.savannah.gnu.org/gitweb/?p=guile.git;a=blob;f=module/language/cps/intset.scm;h=8bda290c171011a1231e37c51cbffa197fc3b3a0;hb=b1103eb9804e18654c885d3336ee3b63dec08eb9
<wingo>clojure-style vectors: http://git.savannah.gnu.org/gitweb/?p=guile.git;a=blob;f=module/language/cps/intmap.scm;h=19d04c02079aadc18fced4c4d9b38dd0e9f81d9a;hb=b352309301a0d7fe41196b08e34186edda210d86
<wingo>(except they are sparse, unlike clojure's vectors)
<alexei___>((< max-fixnum val) max-fixnum) in (define-syntax-rule (clamp-range val) is probably a typo
<alexei___>nevermind
<davexunit>hey guilers.
<wingo>heya davexunit
*davexunit is trying to port chicken's lru-cache
<davexunit>want to cache game assets loaded from disk and regular memoization will just keep eating memory.
<wingo>nice
<wingo>you don't want to use mmap or something similar?
<wingo>with MADV_DONTNEED to free and MADV_WILLNEED to page back in
*wingo very pleased with recent flow analysis stuff; needs a writeup to
<wingo>*tho
<wingo>happy to have landed most of it today
<davexunit>wingo: hmm, I haven't even considered that.
<davexunit>I will have to look into it.
<davexunit>I just want a cache with some upper bound because the cache will exist for the entire duration of the game.
<davexunit>I'm not sure how to use mmap in guile...
<davexunit>might be too low level.
<davexunit>brunch time, bbl
<janneke>is there a neat way to avoid writing this lambda; i.e., discard : (lamba (x) (some-fixed-procedure))
*janneke looks for some kind of compose that junks a parameter, or something
<add^_>(some-fixed-procedure) ?
<janneke>i have a list of `((key . ,proc) (key-2 . ,proc2)) pairs
<janneke>the procedures are invoked with one parameter
<add^_>sounds like (case x ...)
<janneke>sometimes, the "proc" does not need the parameter
<janneke>i now changed the library code to test for procedure?
<janneke>and otherwise use the fixed value directly
<davexunit>I think this has come up before: there is no hash-table-size procedure for guile's hash tables.
<ijp>I forget the reason why, but you can compute it fairly simply
<ijp>e.g. (hash-count (const #t) h)
<daviid>davexunit: hello! just reading the log and searched for sly, found a s/w already named sly [didn't check if it's alive but thought you would like to know]: "Introduction. Sly is a JavaScript library for advanced one-directional scrolling..." http://darsa.in/sly/
<davexunit>daviid: I stumbled on this too.
<davexunit>I think it's okay.
<davexunit>it's not a major clash. different library, different language.
<daviid>davexunit: i think install.org file is outdated, it still refer to figl in dependencies
<davexunit>daviid: thanks for noticing. will fix.
<daviid>the "Freeimage is to used to load..." is incorrect, I think
<davexunit>thanks for that, too!
<davexunit>glad to have someone reading what I've written
<daviid>I would remove debian subtitles and add a sentence in the beginning saying that the install command propose are based on a debian ... it really is redondant i think
<daviid>s/command propose/commands proposed
<davexunit>daviid: are you looking at the latest code in master? my INSTALL.org has guile-opengl now.
<davexunit>no mention of figl.
<daviid>github?
<davexunit>daviid: I also removed that.
<davexunit>gitorious.
<davexunit> https://gitorious.org/sly/sly
<daviid>i picked up the first guile-2d link googleing
<davexunit>I modified the README on github so that there's bold text that directs you to gitorious.
<daviid>you should update [maybe] the github page to point to the new one...
<davexunit>I only use github to work with upstream projects that use github now.
<davexunit>my own projects are on gitorious because it's free software.
<daviid>mine too :)
<davexunit>:)
<daviid>so, i can not install sly [for the same reason we talked about..], just reminding
<davexunit>ijp: thanks for the hash-table-size suggestion
<davexunit>daviid: one sec, I can attempt to help again
<davexunit>daviid: could you send me the build log?
<davexunit>in a paste or something
<daviid>willdo
<daviid>give me a sec ...
<daviid>davexunit: i'm curious why users hit this problem [often] and also would to use the autotool 'schema' you're using for kisê :)
<daviid>davexunit: http://paste.lisp.org/display/143038
*davexunit looks
<davexunit>so what's the actual error, again?
<daviid>./configure: line 2384: GUILE_PROGS: command not found
<daviid>anyone can help with this? [guile-sdl install]: ./autogen.sh --prefix=/opt -> ./autogen.sh: 25: ./autogen.sh: snuggle: not found
<davexunit>ahhh I forgot how to deal with that...
<daviid>i'll find out, np
<davexunit>daviid: what is the output of: find /usr -name guile.m4
<daviid>dave it's in /opt, not /usr
<davexunit>ahhh well that explains why I've never encountered this before.
<daviid>remember that we've been through this with civodul already, guile,m4 is installed
<daviid>in my case it's here /opt/share/aclocal/guile.m4
<daviid>
<davexunit>yeah I know, but I don't remember all of the details
<daviid>my ACLOCAL_FLAGS is properly set as well: cho $ACLOCAL_FLAGS -> -I /opt/share/aclocal
<daviid>see this guy is terrible [the sdl guy] because he pretends you can use autoconf, but makes it [hiddenly] depending on a s/w he wrote
<add^_>ttn?
<davexunit>yup
<davexunit>I tried packaging guile-sdl for guix and gave up
<daviid>SNUGGLE: Neutralize Uncharacteristically Grotesque GUILE Library Entropy!
<davexunit>too much crazy custom software
<davexunit>daviid: man, I don't know what's up with this guile.m4 thing.
<davexunit>the mailing list might be helpful, mark weaver could see it and might know what the issue is.
<daviid>davexunit: i'll find out, for all of us, i'm far from being the first, remember foeniks... https://www.gnunet.org/bot/log/guile/2013-09-29
<daviid>snuggle snuggles me, i don't even want to install that crap
<davexunit>oh wow, that was back during the GNU30 hackathon
<davexunit>interesting reading this log.
<daviid>yeah [wanted to have lunch with you and mark, but then i live about 10.000km :)]
<davexunit>the (system repl coop) module was conceived that day.
<daviid>nice work indeed!
<daviid>by the way did you look at the clutter api?
<davexunit>I haven't yet.
<daviid>i wish mark would write me: david anything i can do to help you with guile-clutter? :) [oh maybe 1 day he will :)]
<davexunit>mark has been very busy relocating.
<daviid>but guile-clutter needs help since ... 2012 :)
<daviid>gdk_pixbuf_get_pixels returns a guchar *, clutter_image_set_data wants a const guint8 *
<daviid>so, I (wrap-opaque-pointer! ws "guchar*") and commented the ignore gdk_pixbuf_get_pixels so that function is now wrapped as well, and calling returns [for example]: (get-pixels pb) -> #<gw:wcp <guchar*> 0x3ccf930>, which fine
*daviid is speaking loudly, explaining to someone else, sometimes, unexpectidely triggers other route(s) for a solution...
<davexunit>stop-irc
<daviid>now, we don't wrap cogl [yet :)], and clutter_image_set_data wants a CoglPixelFormat, I wonder what would be best here
<daviid>should I add a colg types entry in Makefile.am ? or create a nasty hack just for that cogl type?
<daviid>or add a cogl directory to the clutter branch [which would trigger a lot more work]
*janneke is happy: found const
***ijp` is now known as ijp
<ArneBab>Now only the conclusions are missing from py2guile: http://draketo.de/proj/py2guile/