IRC channel logs

2014-05-26.log

back to list of logs

<nalaginrut>morning guilers~
<nalaginrut>oh, the speed problem of http-get has been solved by ludo, nice~
<civodul>Hello Guilers!
***Shozan is now known as SHODAN
<nalaginrut>civodul: thanks for fixing http-get
<civodul>yeah, it took me a while to figure it out
<bhattigurjot>i have guile 2.0.11 compiled and installed on my system
<bhattigurjot>and yet the result of the following query
<bhattigurjot>dpkg-query -W -f='${package}\\n' "guile-2.0"
<bhattigurjot>is
<bhattigurjot>dpkg-query: no packages found matching guile-2.0
<bhattigurjot>how do I check from my terminal whether it is installed or not?
<taylanub>bhattigurjot: how did you compile&install Guile?
<bhattigurjot>taylanub: ftp://ftp.gnu.org/gnu/guile/guile-2.0.11.tar.gz
<bhattigurjot>from here
<taylanub>bhattigurjot: I mean, did you just do "./configure && make && make install"?
<taylanub>or did you actually use dpkg to build and install it?
<bhattigurjot>the former
<taylanub>then dpkg knows nothing about that. in fact no central database on your system does; that's what package managers were made for
<bhattigurjot>so how could I check if this library has been installed or not?
<bhattigurjot>I'm creating a bash script
<taylanub>check if the files are in place, like /usr/share/lib/libguile...
<taylanub>oh, for a script, hrm..
<taylanub>what exactly does the script do?
<bhattigurjot>it installs another software but first checks to see if the dependency/library has already been installed
<bhattigurjot>or not
<bhattigurjot>rest all I can check with dpkg-query -W -f='${package}\\n' "$1"
<bhattigurjot>where $1 can be replaced by the package name
<taylanub>wouldn't that be better as a package-manager recipe? especially since you already seem to assume that the system has dpkg...
<taylanub>so just make a .deb with Guile >=2.0 as a dependency or so?
<bhattigurjot>I'm sorry I didn't get you :-/
<bhattigurjot>actually I need it to be guile 2.0.11
<amgarching>Maybe "guile --version"
<taylanub>honestly I would just put it in some README that the user needs Guile 2.0.11 then
<taylanub>(I'm assuming that Debian doesn't have a Guile package for 2.0.11 yet)
<bhattigurjot>amgarching: yeah
<bhattigurjot>taylanub: I don't think so
<bhattigurjot>the deb package is not there I think
<taylanub>could of course also make an unofficial Guile 2.0.11 .deb package
<bhattigurjot>what about this? http://pkgs.org/debian-sid/debian-main-amd64/guile-2.0_2.0.11+1-1_amd64.deb.html
<bhattigurjot>or this https://packages.debian.org/unstable/lisp/guile-2.0
<taylanub>the latter, yes
<taylanub>the ads on the former page make me want to run away from my monitor
<bhattigurjot>will that work on other distros? Ubuntu or Mint alike?
<taylanub>bhattigurjot: it should work for Debian-derivatives I guess.
<taylanub>which includes Ubuntu and Mint
<bhattigurjot>ok.. thanks :-)
<taylanub>np
<daviid>2.0.11+1-1 is in debian testing
<bhattigurjot>daviid: will that cause any trouble?
<daviid>sorry, I just wanted to mention to taylanub that guile 2.0.11 is in debian testing, I did not read the all conversation and don't know what trouble you're refering to
<bhattigurjot>it's ok.. I was just asking in general
<bhattigurjot>about any bugs or crashes or anything
<taylanub>From what I know Debian Testing is quite OK.
<ksefchik>Hello! I'm trying to build a program that needs guile and I'm getting this error from the configure file: checking for scm_boot_guile in -lguile... no
<ksefchik>configure: error: ERROR! Guile 1.6 or above required.
<ksefchik>Could anyone help me fix this?
<saul>ksefchik, perhaps the library to be linked should be -lguile-2.0 ?
<ksefchik>Here's my config.log https://gist.github.com/9e2f8bd7d3621831f9c4
<ksefchik>Possibly. TBH, I don't know much about autoconf generated configure scripts or how they work. How would I reference that?
<ksefchik>ah! It looks like configure is finding it here -> https://gist.github.com/13b24a913fe2252a48af
<didi>ksefchik: What's the program? I would be surprised if a program coded to use Guile 1.6 run on Guile 2.0.11 without any modifications.
<ksefchik>it's freetalk-3.2
<ksefchik>Okay, installing 1.8 now
<ksefchik>because it's on homebrew :3
<ksefchik>oh boy. Guile takes a long time to make. :D
<saul>ksefchik, you might try changing the corresponding line in 'configure.ac' to:
<saul>AC_CHECK_LIB([guile-2.0],[scm_boot_guile],,AC_MSG_ERROR([ERROR! Guile 2.0 or above required.]))
<saul>(That will at least get you past ./autogen.sh && ./configure
<ksefchik>I'll give it a try!
<ksefchik>Right now I'm installing 1.8 to see if that works better
<ksefchik>(out of the box)
<ksefchik>You are all beautiful people by the way!
<ksefchik>Thanks for the help!
<ksefchik>This actually looks like a really cool little library
<ksefchik>#notlittle
<saul>How does one write a Guile script so that the auto-compilation messages are not produced?
<saul>I have tried including --no-auto-compile to the example given on http://www.gnu.org/software/guile/manual/html_node/Scripting-Examples.html#Scripting-Examples
<saul>... but that results in an error.
<saul>(and I don't really want to disable auto-compiling, just the messages)
<saul>Correction, --no-auto-compile appears to work fine.
<saul>OK, if a .go file is in the cache already, adding the --no-auto-compile switch appears to be ignored.
***george2|chakra is now known as george2
<saul>FYI, found a bug report for this already exists: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=16364
<invergo>Does anyone have the patience to help out a Scheme/Guile neophyte?
<invergo>My basic question is: what's the best way to serialize a Scheme object to disk?
<invergo>But it might be the wrong question.
<invergo>In short: I'd like to build up a Skribilo document across multiple calls to the program. I'm trying to find the best way to store the document-in-progress in between calls.
<invergo>Each call will append a new chapter/section to the document, and those sections will be built up programattically themselves
<invergo>I've tried playing with compiling to objcode, writing to disk, and then later loading from disk and compiling to value, but I'm having problem with the environment I guess (unbound variable errors and such)
<civodul>howdy invergo!
<invergo>Hi civodul :)
<civodul>invergo: there's basically no simple automatic way to serialize arbitrary objects
<civodul>and i've come to think that it's a feature
<invergo>Probably. I'm also worried about future versions of Guile always being able to read objcode written by old versions.
<civodul>yeah
<civodul>so, it could be that the intermediate parts of the document could be saved as sexps
<civodul>or code
<invergo>That was an original desire. I'm trying to remember why I abandoned that route.
<civodul>what i typically do when i need to serialize stuff is to hand-code conversion to/from a versioned sexp format
<invergo>And then just eval it?
<civodul>no
<invergo>Hm ok
<civodul>then 'read' it, and build the corresponding object
<invergo>Ah, ok. I need to read up on readers then.
<civodul>so you can check the version number and do any appropriate adjustments
<invergo>Wise
<civodul>(that was general advice, not Skribilo-specific ;-))
<invergo>Understood
<invergo>btw, I'm really liking Skribilo!
<civodul>instead of storing the document itself in between calls, perhaps you could store some higher-level representation of its input?
<civodul>ah cool :-)
<invergo>I thought of that, but since it would be a structured document, I figured that the nested sexp format was already the most natural
<civodul>ok
<invergo>(This is my first attempt at writing anything substantial in Scheme, so I might not be making any sense)
<civodul>:-)
<invergo>OK, well, I'll have another go at this then. Thanks for your help!
<civodul>you're welcome!
<civodul>good luck with that
<invergo>cheers
<civodul>ttyl!
<saul>civodul, why not just 'write' the objects?
<civodul>saul: it only works for simple objects, not for structs or GOOPS objects
<saul>Aha, thanks. (I haven't used GOOPS for anything.)
<civodul>that's a reasonable choice :-)