IRC channel logs

2014-04-09.log

back to list of logs

***didi`` is now known as didi
***Fuuzetsu` is now known as Fuuzetsu
<pallagun>beginner question: I made a smob (just a pointer to double) that I allocated with malloc instead of the scm_gc_malloc. I have a bunch of existing code that uses malloc, so I wanted to test/figure it out. The example in the guile doc uses scm_gc_malloc. Is there an example somewhere that uses normal malloc?
<pallagun>also, if I made a smob and set up a scm_set_smob_free function, should that get called when I run ",gc" ?
<nalaginrut>morning guilers~
<pallagun>greetings
*nalaginrut just fixed heartbleed for his server
<b4283>nalaginrut: heartbeatd ?
<nalaginrut> http://filippo.io/Heartbleed/
<b4283>nalaginrut: wow, cool
<didi>It doesn't look like a good idea.
<zacts>lo
<b4283>nalaginrut: my old debian is vulnerable :(
<nalaginrut>sudo apt-get upgrade
<zacts>b4283: I thought that debian squeeze was not vulnerable to heartbleed
<zacts>(correct me if I'm wrong)
<nalaginrut>yes I think the older one should be fine
<b4283>yeah, doing that right now
<nalaginrut>but it depends on modversion of openssl
<b4283>dist-upgrade shows libssl is required for update
<zacts>I wonder how difficult it would be to implement the SSL/TLS protocol in guile scheme?
<nalaginrut>b4283: if yours is lower than 1.0.x, and it's fine
<nalaginrut>zacts: I think the problem is efficient
<zacts>efficiency?
<nalaginrut>IMO, a binding is enough
<zacts>I guess gnutls + guile works
<nalaginrut>zacts: yes, that's what I mean
<zacts>but it's just a curiosity, I do feel that more code should be implemented in languages other than C..
<zacts>C is starting to show its cruft with bugs like these, it seems.. but I'm still a newbie
<nalaginrut>I think it's possible, but not so fast
<nalaginrut>I mean the performance
<zacts>hm.. I don't mean for a library for servers and browsers, but for guile scheme applications
<zacts>like a guile server
<nalaginrut>I think the better solution is to use guile-gnutls
<zacts>but I guess we should probably stick with gnutls as it is more tested
<nalaginrut>if you need a secure guile server, you'd better based on guile-gnutls
*nalaginrut Artanis will do this someday...
<zacts>nalaginrut: what can I use now to serve a static blog such as, http://zacts-blog.herokuapp.com/ ?
<zacts>I want to use (scheme) instead of perl.
<nalaginrut>zacts: cool, is it static page?
<zacts>nalaginrut: yeah
<nalaginrut>you want to generate static page with Scheme?
<zacts>yeah
<nalaginrut>or a dynamic page
<zacts>nalaginrut: static
<nalaginrut>zacts: alright, you should try hyde of Chicken
<zacts>ok, cool
<nalaginrut>Artanis' main site is generated by hyde of Chicken
<nalaginrut> http://www.web-artanis.com/
<nalaginrut>the only problem is lacking of tutorial, only a manual
<nalaginrut>I learn it by myself
*nalaginrut is considering to post a tutorial on his blog
<nalaginrut>zacts: but you can read my code for it, it's easy to understand https://github.com/NalaGinrut/artanis/tree/gh-pages
<nalaginrut>zacts: BTW, you need Chicken-Scheme rather than Guile on this case
<zacts>ok
<nalaginrut>Anyway, it's better to have a porting for Guile
<didi>There is also <https://github.com/greghendershott/frog>.
<nalaginrut>ah~cool
<b4283>oh yeah, heartbleed fixed
<didi>b4283: Change your keys.
<didi>Revoke the certificates.
<b4283>didi: it's self-signed
<didi>b4283: Still.
<b4283>i guess i'll just have to change it
<nalaginrut>how to revoke the certificates?
<b4283>nalaginrut: you need to put it in the new certificate's revoke list
<nalaginrut>oh, my new server hasn't published the certificate
<nalaginrut>well, I think it's fine
<b4283>nalaginrut: how do you publish a cert ?
<nalaginrut>I mean this is my own server, so I didn't share the pub key to others
<nalaginrut>I wonder if it's the same thing we're talking about
*wingo checks out gdb from git so he can write a guile extension for it, whee
<nalaginrut>ooh
<stis>\\o/
<wingo>heya civodul
<civodul>Hello Guilers!
<taylanub>Hidy ho
<nalaginrut>what's the difference between pmatch and match?
<nalaginrut>pmatch/source
<nalaginrut>My actual question is, can I replace pmatch with match?
<taylanub>nalaginrut: Where/what is pmatch ?..
<nalaginrut>I mean in my own compile-tree-il
<nalaginrut>taylanub: I found it in (system base pmatch), and used in (language ecmascript compile-tree-il)
<nalaginrut>well, I guess pmatch is a simpler implementation of 'match'
<nalaginrut>but it's better to be confirmed
<wingo>is doug evans around?
*wingo can't remember his nick
<civodul>wingo: dje42
<wingo>ah cool
*wingo poking at gdb extensions
<civodul>neat, no? :-)
<wingo>very :) a couple of rough edges tho, like exposing the name "gsmob"
<wingo>was this already discussed, do you know?
<civodul>yes, during the review process
<civodul>i didn't really like insisting on SMOBs in the doc
<civodul>i thought most of it was gone, maybe no
<wingo>still some in there
<wingo>i also wonder why `object-property' is insufficient
<mario-goulart>wingo? https://github.com/BurntSushi/wingo
<wingo>yeah, i guess it's an obvious name for what it is :P
<mario-goulart>:-)
<taylanub>haha
<taylanub>That reminds me to try out the Guile-WM
<wingo>civodul: were you able to get gdb's test suite to run? fails for me for some reason
<wingo>civodul: speaking of which, hydra needs a kick to flush queued jobs or something
***Fuuzetsu is now known as Guest21808
***Guest21808 is now known as Fuuzetsu`
***Fuuzetsu` is now known as Fuuzetsu
<davexunit>taylanub: guile-wm is very neat. I go through phases of using it instead of gnome 3.
*wingo forgets how to send a patchset over email
<wingo>seems i was missing git-send-email
<Fulax>for file in *.patch; do mail <address>; done ? :)
<taylanub>I use ratpoison since a long time, and actually only ever use full-screen windows, the only actual functionality I make use of being a couple Xorg-global keybindings, and the little echo area it can show on the top right. Perhaps those things shouldn't be done by the WM anyway ...
<wingo>not exactly :)
<Fulax>I missed mail <address> <$file
<dsmith-w`>Howdy Guileers
***dsmith-w` is now known as dsmith-work
<dsmith-work>wingo: Got another master test case not happy. cse.test is looking for the (language tree-il cse) module.
<civodul>wingo: i was able to run the Guile part of GDB's test suite
<civodul>but when i switched to libgc 7.4, weird things started happening
<wingo>dsmith-work: ah, drat
<wingo>will fix
<dsmith-work>Cool
<taylanub>Hrm, with GNU MP 6.0.0, or something else related to my 2.0.11 build on OS X, #i1@-0 evals to 1.0+0.0i instead of 1.0-0.0i.
<taylanub>Makes numbers.test fail at the string->number test.
<taylanub>Wrote it in my e-mail about building 2.0.11 on OS X 10.9 / Xcode 5.1, I guess I should make a separate topic for it, don't think it's OS X-related.
<taylanub>Hehehe, GMP 6.0.0 release notes: "This release will not work reliably on FreeBSD 10.0 for i386 or amd64 using the 32-bit ABI. The reason is bugs in the compiler 'clang'." Not related to my issue since I built with GCC, but it's interesting to see more clang-related issues ...
<didi>civodul: Congratulations on the release.
<civodul>thanks!