IRC channel logs

2014-03-21.log

back to list of logs

<zacts>mark_weaver: yep, same coredump on those same two architectures
<zacts>mark_weaver: clang 3.3 for FreeBSD-10 and
<zacts>clang 3.4 for FreeBSD-11
<zacts>although keep in mind that freebsd-clang is a heavily(?) patched version of clang made specifically for FreeBSD
<zacts>mark_weaver: well, also it was only FreeBSD >= 10 that completely replaced gcc with clang by default
<zacts>so earlier versions use a gplv2 version of gcc.
<zacts>so sounds like a clang issue. mark_weaver with your knowledge how can I test for guile specific clang issues? I'll ask #freebsd-clang about clang specific issues also.
<zacts>mark_weaver: the freebsd-clang guys think it's an odd bug. will post back after I do a gdb backtrace, and look at a couple of patches.
<zacts>mark_weaver: guile patches you may be interested in - http://ftp.netbsd.org/pub/pkgsrc/current/pkgsrc.tar.gz
<zacts>oops wrong link.. ftp://ftp.netbsd.org/pub/pkgsrc/current/pkgsrc/lang/guile/patches/
<zacts>mark_weaver: I may /msg you to prevent my channel flooding.
<mark_weaver>hi zacts! was afk. looking now
<mark_weaver>I doubt that the guile-snarf patch is still needed. I recently rewrote that for clang.
<zacts>mark_weaver: what do you think about the patch-ao patch?
<mark_weaver>yeah, that one is interesting. still researching.
<zacts>note: these patches apply to 1.8 not 2.0, but still the freebsd-clang devs told me to check them out
<mark_weaver>zacts: the thing is, that entire section of code is only used if you're using an old version of libgc.
<mark_weaver>our first choice is to rely on GC_stack_base to tell us the base of the stack.
<mark_weaver>the other thing is that even if you're using an old libgc, we have a case in 2.0.11 for HAVE_PTHREAD_ATTR_GET_NP that's labelled "This one is for FreeBSD 9".
<mark_weaver>so it looks like we have this covered already.
<zacts>mark_weaver: FreeBSD-9 uses gcc, while FreeBSD >= 10 uses clang only
<mark_weaver>yeah, so it seems likely to be a clang issue.
<zacts>ok, well I'll do a backtrace, and let you know how it goes with the fbsd-clang devs
<mark_weaver>I think the next two steps are: (1) run "make check" for libgc-7.2e, and make sure it passes.
<mark_weaver>if that passes, then (2) get a backtrace from guile.
<zacts>hm.. ok. I'll try that
<mark_weaver>thanks!
<zacts>no, thank you for taking the time to help me understand all of this! :-)
<mark_weaver>np :)
<zacts>mark_weaver: http://nopaste.info/2c558a12c5_nl.html
<nalaginrut>morning guilers~
<mark_weaver>zacts: presumably that's because libgc is not getting linked in.
<mark_weaver>and indeed, "cc test.o -o test" doesn't include libgc in the link.
<zacts>mark_weaver: oh, let me try something
<zacts>hm.. didn't work. I tried installing devel/boehm-gc first, before devel/boehm-gc-pthreads
<zacts>mark_weaver: what would one do on gnu/linux to fix this kind of error?
<mark_weaver>did you use the configure script in libgc?
<mark_weaver>or just one of the bare makefiles?
<zacts>let me check. btw perhaps you should /msg me so we don't flood the channel.
<nalaginrut>Leslie Lamport Receives 2013 ACM Turing Award For Advances In Reliability And Consistency Of Computing Systems
<nalaginrut>;-)
<ijp>and not for LaTex
<nalaginrut>well, this is for last year?
<nalaginrut>hmm..this year
<zacts>hm.. I think I'll pick up my scheme book again
<nalaginrut>Facebook released their new Hack language, but I'm not a big fan of PHP dialect... ;-/
<civodul>Hello Guilers!
<nalaginrut>ijp: I just realized that he is the original author of Latex ;-D
<ijp>5 hours later...
<nalaginrut>hi ludo
<nalaginrut>I have a meeting last several hours
<nalaginrut>s/have/had
<artyom-poptsov>Hi civodul
<wingo>moin
<nalaginrut>(apply + `(,((lambda (#{2+3}#) #(1)2+3) #e2e3) ,(* 120 .((*(/(+(/(* #e144#) 84)))))) ,(*(/(+ #e5/7)) 5)))
<nalaginrut>;-P
<nalaginrut>Maybe we should hold a chaos Scheme competition?
<nalaginrut>;-D
<civodul>indeed :-)
<civodul>and it actually works, woow
<nalaginrut>I took some time to find a proper mystery numbers to make it looks horrible
<nalaginrut>hmm...maybe chaos English sentence competition is better for me...
<civodul>funny, rms usually replies to release announcements with "congratulations on the new release"
<civodul>for 2.0.11, he wrote: "My condolences on the new release." :-)
<ft>:)
<ft>Shows, that he actually reads the annoucements. :)
<civodul>indeed!
<davexunit>hahaha
<DerGuteMoritz>haha, why condolences?
<davexunit>DerGuteMoritz: 2.0.10 was released with an "embarrassing regression", prompting the 2.0.11 release.
<civodul>before 2.0.11, we were at an average of 1 release per year
<civodul>now that has doubled
<civodul>:-)
<DerGuteMoritz>hah
<DerGuteMoritz>nice
<mark_weaver>That's just like RMS :)
<saul>DerGuteMoritz, because there were only two days between releases and 2.0.11 was required to fix a silly (though important) coding error.
<saul>Sorry about that. I'd typed my response hours ago and didn't send it. Then later accidentally did.
<wgl>Installing guile 2.0.11 on freebsd 10.0: all works up to the point of "make install". Fails on step ' ../build-aux/install-sh -c -d '/usr/local/include/guile/2.0/libguile''
<wgl>Any hints on where to look?
<mark_weaver>you caught me at a bad time, and I have to go afk now, but is there an error message? what do you mean "fails" ?
<wgl>Simply install: : No such file or directory
<wgl>This is after make install-data-hook
<mark_weaver>wgl: can you show me the output of "grep -i install config.log" ?
<mark_weaver>One guess is that FreeBSD 10 has /usr/bin/install, and configure thinks it's okay to use, but it doesn't support the options we expect.
<mark_weaver>wgl: if you have a GNU version of the install program (ginstall?), you might try setting the INSTALL environment variable to point to that.
<mark_weaver>wgl: fwiw, zacts here on channel is working on a recipe for freebsd ports for guile 2.0.11. it works on 64-bit systems.
<wgl>mark_weaver: It is about 10 lines. Pastebin?
<mark_weaver>sure
<wgl>mark_weaver: http://pastebin.com/BCwnX12u
<mark_weaver>*grump* pastebin.com blocks tor
<mark_weaver>can you use paste.lisp.org?
<mark_weaver> http://paste.lisp.org/new
<wgl>mark_weaver: http://paste.lisp.org/+31D9
<mark_weaver>wgl: so I guess you have a /usr/bin/install, but maybe it doesn't support the -m option, is that right?
<wgl>no, help for command says '-m mode' valid
<wgl>I annotated paste with lines around make result at http://paste.lisp.org/+31D9/1
<mark_weaver>oh, nevermind. I see that the source filename that we're asking to install is the empty string. hmm.
<wgl>Ah, looks to be so.
<mark_weaver>I wonder why zacts didn't run into this. he's been testing guile-2.0.11 on FreeBSD on redports.
*mark_weaver looks deeper
<mark_weaver>wgl: did you use GNU make or BSD make ?
<wgl>regular make. Trying gmake now.
<wgl>Presto!
<mark_weaver>cool :)
<wgl>Perhaps I overlooked an instruction.
<mark_weaver>no, I think it's supposed to work, but we have some new code in the Makefile that is not as portable as it should be, I guess.
<wgl>Havent' been doing freebsd long; mostly ubuntu. Switching over all my boxes starting with my dev box.
<mark_weaver>wgl: can you send a bug report about this to bug-guile@gnu.org ?
<wgl>Thanks much.
<wgl>Will do.
<mark_weaver>thanks! happy hacking :)
<wgl>So guile will soon be the elisp replacement?
<mark_weaver>elisp is not going away, but we hope to replace the emacs implementation of elisp anyway.
<wgl>Replace it with re-implemented elisp? or something else?
<mark_weaver>right
<mark_weaver>elisp code running on guile, that is.
<mark_weaver>but you'll also be able to write code in scheme on guilemacs.
<davexunit>a lot of people seem worried about being able to emacs extensions in scheme, or rather any language that isn't elisp.
<davexunit>because of fragmentation and such.
<davexunit>but using the guile vm to run elisp would be so awesome. FFI, continuations, threads, etc.
<stis>davexunit: I gues that my prolog implementatino will be the ultimate horror for them :-)
<stis>I think that the worry is theoretical, the head count writing extensions would incerase.
<davexunit>I also think that people would continue to just use elisp, but that's just a hunch.
<stis>well, the maintainers of emacs can just restrict to accept elisp packages for emacs
<stis>that alone would limit the fragmentation
<davexunit>stis: yeah that could do it.
<zacts>lo
<zacts>mark_weaver: I'm going to try to build guile against clang on gnu/linux
<mark_weaver>zacts: on a 32-bit system, you mean? if so, that would be helpful.
<zacts>indeed
<mark_weaver>thanks!
<zacts>mark_weaver: actually it will have to wait until later. My cafe connection is too slow..
<mark_weaver>heh, okay.
<stis>I have problems setting up a module environment for ,L prolog, any ideas?
<stis>#:make-default-environment doesn't do the trick for me
<zacts>mark_weaver: looking @ the backlog, but did wgl figure out the problem?
<zacts>'wgl: Presto!'
<wgl>zacts: used gmake rather than make; worked. Filed bug email.
<zacts>what was the bug email?
<wgl>zacts: sent to 'bug-guile@gnu.org'. It says that the error message about 'No such file or directory' referrs to an empty file name and that gmake fixes the problem.
<wgl>Prior attempt had been using just 'make'
<zacts>wgl: I don't see it on the bug-guile archives..
<mark_weaver>I don't know how bug-guile handles spam filtering, but maybe there's some latency.
<wgl>zacts: just now received an email 'bug#17060: Acknowledgement()'
<mark_weaver> http://bugs.gnu.org/17060
<mark_weaver>wgl: thanks
<mark_weaver>I'll add some more details in a followup message.
<wgl>mark_weaver: YW, and thank you for help.
<zacts>yeah, I think that most gnu packages require gmake on freebsd
<mark_weaver>np!
<wgl>Now, if i can just build a threaded sbcl on freebsd 10.0, my week will be complete.
<cluck>davexunit: the new release was pushed and emacs trunk is now open, if you're going to propose some work and do major changes now's the time
<stis>A prolog interpreter is hacked together, rough but nice! see guile-devel mail
<stis>note this is iso-prolog + a few small quirks
<stis>next step is to implement continuations that unify correctly
<davexunit>cluck: I haven't the faintest idea of where to start with guilemacs, honestly.
<stis>we should try to make a team that finalizes guile into emacs.
<davexunit>the guilemacs task force
<davexunit>well there is that guy on emacs-devel offering money to new contributors
<saul>stis, what does it mean it mean, unify a continuation?
<davexunit>who knows if he approves of guilemacs, though
<stis>sual: I meant closures, for that one need to unify the internal state, sorry!
<stis>saul: function code identity would kill tablating for example (memoization)
<stis>as well as closure identity
<saul>stis, I will have to study that. Thanks.
<sjoerd`>is the function scm_is_eq in C proper for comparing keywords?
<mark_weaver>sjoerd`: yes