IRC channel logs

2014-01-12.log

back to list of logs

<ArneBab>(luckily the development teams of most programs I need use Mercurial)
<mark_weaver>well, the thing is, someone has to create a proper commit for the VCS. if you don't do it, it means that someone else has to do it.
<ArneBab>need→need to contribute to
<ArneBab>I can create a proper commit and push it somewhere.
<ArneBab>hg-git works transparently
<mark_weaver>so there's no solution for creating something suitable for input to "git am" ?
<ArneBab>I do not know what git am requires
<ArneBab>…let me google
<mark_weaver>I guess I should be able to pull it from a git repo that you have hosted somewhere.
<mark_weaver>I haven't yet used git in that way, so I'd need to learn about it.
<ArneBab>no probs
<ArneBab>mark_weaver: here’s the commit you need: https://gitorious.org/guile/arnebabs-guile/commit/287c5514bfdb193a78c598d9382e5c0ed3ce3a49
<ArneBab>I need to go make some late-night housework now… (I promised my wife to carry some stuff up into the attic)
<mark_weaver>ah good, https://gitorious.org/guile/arnebabs-guile/commit/287c5514bfdb193a78c598d9382e5c0ed3ce3a49.patch is in the right format
<mark_weaver>okay, good night!
<ArneBab>you can also simply pull from git://gitorious.org/guile/arnebabs-guile.git
<mark_weaver>indeed
<dje42>Is there a builtin primitive to apply a procedure to each element of a list and stop when the result is true, returning that value (or #f if all invocations return #f) ?
<dje42>Easy enough with a named let, just wondering if there's something simpler.
<dje42>and-map?
<dje42>Errrr, or-map
<taylanub>dje42: I think that should be `any' from SRFI-1.
<taylanub>(Not a "builtin primitive" but I hope that wasn't really a requirement.)
<dje42>Ah. [no, I wasn't lookup for a primitive per se, just a utility]
<dje42>boot-9.scm has or-map, but any will do too
<stis>Morning guilers!
<wingo>greets!
<sneek>Welcome back wingo, you have 3 messages.
<sneek>wingo, nalaginrut says: Is this warning harmful? "fatal: Not a valid object name"
<sneek>wingo, nalaginrut says: I'm using tekuti for the blog
<sneek>wingo, ijp says: if by some chance you haven't already, check out "secrets of the glasgow haskell compiler inliner"
<wingo>happy new year &c!
<stis>happy new year& c to you too! Welcome!
<wingo>how goes?
*wingo was mostly away from the machine, but managed to fix some things in master in the end
<stis>cool! Wel familywize this has been a really nice christmas!
<wingo>excellent :)
<stis>And I'm soon to completa a reasanble iso-prolog implementation!
<stis>for guile!
<stis>And you?
<wingo>excellent!
<wingo>good, saw all the families back in the us
<wingo>back in geneva since tuesday
<wingo>slowly paging all the things back in :)
<stis>Warmer? or did you bring the cold weather with you ;.-)
<wingo>it's been warmer here than in the us -- there it was slushy and cold :)
<stis>paging in... I find it a very good exercise to do something else and the come back, you tend to improve the quality that way
<stis>e.g. seeing things that was on the black spot when one is 'in' the area
<wingo>landed a dead code elimination pass, and some generic beta/eta reductions
<wingo>effects analysis too, and some reachability things (what expressions are reachable from cont N that are not also reachable from cont M, etc)
<wingo>also $ktrunc (which is now $kreceive) appears everywhere that guile truncates multiple values, though it can be optimized out
<wingo>should help avoiding all kinds of values-related bugs that we have currently
<stis>cool!
<wingo>in the pre-cps side of things
<wingo>currently trying to finish the docs on cps
<stis>Cool, I would really like to enjoy some doc's and thoughts about 2.2
<wingo>there are some things in git already
<civodul>Hello Guilers!
<civodul>our custom-binary-input-port implementation cannot be used to implement a port wrapper that computes a hash over what's actually been read
<civodul>because it has built-in buffering
<civodul>that sucks
<civodul>soft ports don't have this problem, but they have other problems
<civodul>any suggestions?
<civodul>hey, howdy wingo!
<wingo>heya civodul :-)
***Guest3074 is now known as `micro
<jemarch>hi
<civodul>hello jemarch
<dje42>Setting aside various kinds of critical sections, is it bad to longjmp out of scm_with_guile? E.g. suppose a user-provided scheme function does the longjmp.
<dje42>[I don't know if this can happen for me today, and I'm going to avoid it where I can. At this point I'm just wondering.]
***add^_` is now known as add^_
<wingo>updated the "master" docs on the site
<wingo> http://www.gnu.org/software/guile/docs/master/guile.html/CPS-in-Guile.html#CPS-in-Guile
<stis>wingo yey!
<dje42>civodul: saw your message re: gdb 7.8
<civodul>ah yes
<dje42>Way back when I didn't expect 7.7 to be as delayed as it was.
<dje42>But no matter, 7.8 needn't be similarly slipped.
<dje42>It was problematic for various reasons to get guile into 7.7 so I never pushed for it.
<civodul>ok
<dje42>Now that 7.7 has branched, I'm hoping to get the patches in soon.
<civodul>cool!
<dje42>Last real TODO is SIGINT handling.
<civodul>right, and i didn't really have any solution :-/
<civodul>BTW, i noticed tromey will talk about gdb at FOSDEM
<dje42>Ah.
<tromey>civodul: if you're going to be at FOSDEM I'd love to meet up. I was hoping Dodji would give me an introduction to you & wingo but it turns out he isn't going to make it :(
<wingo>bummer about dodji! but I will try to go; depends on some things at home
<civodul>tromey: yes, that'd be great
<civodul>hopefully there'll be a GNU dinner on Friday
<tromey>I'll have to check my schedule :)
<tromey>but I'm sure we can find some time
<civodul>heh
<civodul>most likely i'll attend your talk, so at least we could meet there :-)
<tromey>was the dinner mentioned on gnu-prog-discuss?
<civodul>mostly ghm-discuss
<tromey>ah
<tromey>not sure I"m on that
<civodul>that's the helper list to meet gnus in real life ;-)
<tromey>I wonder if mark wielaard is on it. I often just rely on him for social organization at fosdem :)
<dje42>I suppose it's not earth-shattering if a SIGINT gets dropped.
<dje42>It's better than one magically appearing later.
<dje42>civodul, tromey: ^^^ thoughts?
<civodul>dje42: probably, though dropping it is not ideal either
<civodul>fortunately, usually little time is going to be spent in Scheme code, i guess
<civodul>so even if SIGINT occurred, you'll soon notice
<dje42>No, not ideal. It'd only happen if an interrupt happens during a transition from, e.g. python -> scheme
<civodul>yes
*civodul -> zZz
<civodul>good night/day!
<dje42>'nite