IRC channel logs

2013-12-21.log

back to list of logs

<brendyn>so what's everyone getting me for christmas?
<zacts>hey
<zacts>anyone able to answer my question on #scheme?
<zacts>:-)
<mark_weaver>I'm not on #scheme now, but if you ask your question again I'll try.
<mark_weaver>(ask it here, that is)
<zacts>sure
<zacts> http://paste.lisp.org/display/140627
<zacts> http://paste.lisp.org/display/140628
<zacts> I'm currently reading 'Scheme and the Art of Programming' and it requires a non-standard definition.
<zacts><zacts> they only say: "The procedure of no arguments /reset/ in Program 7.6
<zacts>
<zacts>how can I define a procedure like reset for the second paste?
<zacts>I can't continue through the book without it..
<zacts>and thanks!
*zacts is searching the web right now.. I'm finding procedures named reset and shift and abort-to-prompt, but they seem to require arguments..
<adhoc>that reminds me, i should dig out SICP again and start reading =)
<zacts>I still have yet to read SICP, it is next after SAOP, but I know someone who is interested in translating it into portuguese
<mark_weaver>well, you can throw an exception, although that will also print another error message. do you need 'reset' in many places, or do you just need a redefined 'error' ?
<zacts>only a redefined error
<mark_weaver>(define (error . args) ((@ (guile) error) (string-join (map (lambda (x) (object->string x display)) args))))
<mark_weaver>(@ (guile) error) refers to the core guile binding for 'error'.
<mark_weaver>the lambda expression converts one arg to a string using 'display'.
<mark_weaver>the map converts all the args to strings using display.
<mark_weaver>string-join takes a list of strings and joins them together with spaces in between.
<zacts>let me try it
<zacts>cool thanks!
<zacts>now I can continue through the book
<mark_weaver>you're welcome. happy hacking!
<zacts>=)
<matkuki>Hi guys, anyone have any experience building Guile with MinGW on windows?
<matkuki>"make" gives me a couple of warnings, but "make install" gives an error that it cannot find a file named guild.exe
<mark_weaver>yeah, that's a known bug, fixed in git (stable-2.0 branch). The fix is here: http://git.savannah.gnu.org/gitweb/?p=guile.git;a=commitdiff;h=dac5e6491b215f8d70bc8328639b4c72cb7cd565
<mark_weaver>tarballs of more recent stable-2.0 git checkouts are available here: http://hydra.nixos.org/job/gnu/guile-2-0/tarball/latest
<matkuki>thanks, i will try it out.
*mark_weaver --> zzz
<matkuki>mark_weaver: woohoo, it worked! thanks mark!
<amirouche>anyone use guile on gentoo ?
<amirouche>(héllo)
*dsmith notes that there are 58 in #guile, 173 in #scheme, and 1187 in #haskell
<dsmith>mark_weaver, Woah! I see you are adding r7rs support.
<mark_weaver>yeah, I'm on a bit of a tear with that.
<mark_weaver>note that very little of it is tested yet, so no doubt there are some glaring bugs in there.
<mark_weaver>but it was enough to run one of the library examples in the r7rs document.
<mark_weaver>(conway's game of life)
<dsmith>I haven't been paying much attention to it. What are your thoughts?
<mark_weaver>well, on the whole I prefer R6RS.
<dsmith>Ok
<mark_weaver>but R7RS is also reasonably good, and has some nice API improvements over anything that came before, although it's much less comprehensive than R6RS.
<dsmith>Are you talking about Small or Large? (or both?)
<mark_weaver>small
<dsmith>ok Thanks.