IRC channel logs

2013-12-02.log

back to list of logs

<nalaginrut>morning guilers~
<davexunit>hey nalaginrut
<nalaginrut>heya
<davexunit>made some more progress on FRP in guile-2d :)
<davexunit> http://i.imgur.com/OyVmzwb.png
<davexunit>and code: http://paste.lisp.org/display/140333
<nalaginrut>oh~
<nalaginrut>I have to finish my current work then play guile-2d
<davexunit>this example would require so much more code if it was to be done without FRP.
<nalaginrut>I'm glad to see that you do it without GOOPS, although I like GOOPS, I always want to try to do things without OO
<nalaginrut>anyway, just an experiment of me
<davexunit>yeah, I *really* want to avoid OOP and use more functional programming concepts instead.
<davexunit>when I finally get a functional solution, I'm much happier than I would have been with an OOP solution.
<nalaginrut>yeah, that's my aim too
***Sgeo_ is now known as AntiVariousPro
***AntiVariousPro is now known as AntiVariousProte
<wingo>moo
*nalaginrut bought linode for himself, and for Artanis
<wingo>nice :)
*nalaginrut is glad to see there's debian7 to choose ;-D
<nalaginrut>sneek: later tell tupi Have you solved the issue of "AM_DEFAULT_VERBOSITY: non-POSIX recursive variable expansion"?
<sneek>Okay.
<nalaginrut>sneek: later tell tupi well, I fixed it by fallback automake from 1.14 to 1.12, hmm...
<sneek>Will do.
***goto is now known as anderson
<wingo>we should make docker images of guile things
<wingo>like a hello-world image...
<davexunit>wingo: I don't quite understand docker. there's *a lot* of hype around it that makes it hard to see clearly.
<wingo>i have the same feeling :)
<davexunit>all I know is that they have an adorable logo.
<wingo>:)
<davexunit>that whale with crates on it is just too cute.
<wingo> http://www.docker.io/learn_more/ has a nice presentation at the bottom
<davexunit>thanks
<davexunit>wingo: been working on functional reactive programming for guile-2d http://paste.lisp.org/display/140337
<wingo>neat
<wingo>frp breaks my brain :)
<davexunit>mine is very simple, but effective. :)
<davexunit>lines 18-23 are all that are needed to make something move around the screen when the arrow keys are pressed.
<davexunit>that's pretty awesome, I think. that typically requires much more effort from the developer.
<wingo>:)
<davexunit>okay so docker seems to be a way to deploy servers on a multitude of hardware.
<davexunit>using lxc
<davexunit>so you could run the container on a machine without virtualization.
<wingo>apparently it's pretty cheap to run as well
<davexunit>I don't understand where lxc ends and docker begins.
<davexunit>what does docker do on top of lxc? scripts to automate deployment?
<wingo>i guess
<wingo>also a "registry" of apps
<wingo>so i guess there is also the format for a container image
<wingo>also some sort of unionfs thing for allowing differential snapshots
<davexunit>oh that's neat.
<davexunit>so how would this be used in the FOSS community? it clearly seems useful for deploying proprietary web applications.
<davexunit>which I imagine is the most common use case.
<wingo>well i think "get started with a guile blog thing" would be one case
<davexunit>so you'd have a docker container set up to automagically get a dev/production environment running?
<wingo>sure
<atheia>Hello Guilers!
<wingo>atheia: greets :)
<atheia>Wingo (and other contributors): Congrats on landing the new Guile VM — it sounds very exciting!
<wingo>thanks!
<davexunit>the new VM will be awesome.
<wingo>it'll be ok :)
<wingo>hopefully we'll wire up some thread-local inline allocation while we're at it
<wingo>i wonder what that will do for the heap number case
<davexunit>heap number case?
<davexunit>like floating point stuff?
<wingo>yes
<wingo>numbers.c is such a mess :P
*davexunit looks
<davexunit>oh god
<wingo>:)
<davexunit>time for a long drive to my parents house so they can sign my car over to me.
<davexunit>happy hacking, guilers.
<guest`>why this doesn't work if I replace 'value' with 'scheme' '(use-modules(system base compile))(call-with-input-string"++++++++++[>+++++++<-]>++."(lambda(port)(read-and-compile port #:from 'brainfuck #:to 'value)))(newline)'?
<wingo_>guest`: because the compilers graph is directed
<wingo_>you would have to compile to tree-il, then decompile to scheme
***wingo_ is now known as wingo
<guest`>wingo: what /usr/share/guile/2.0/language/brainfuck/compile-scheme.scm do then?
<wingo>good question...
<wingo>i guess it compiles to scheme!
*wingo did not know
<wingo>it must be some bitrotten version of a compiler
<wingo>guest`: tx for the note, fixed in git
***_zxq9_ is now known as zxq9
<stis>evening guilers!
<wingo>heyz
<jemarch>hi
<civodul>hello jemarch
<wingo>ohai
<civodul>hey wingo
<jemarch>civodul: hey
<TaylanUB>Are there any documentation guidelines for Guile akin to Emacs/Elisp ? Is there a reason not to adopt the Emacs style of documentation ?
<civodul>TaylanUB: guidelines about Guile's own documentation?
<TaylanUB>Yeah, and it would be a convention for everyone's Guile modules, akin to Elisp conventions.
<civodul>dmd 0.1 is out!
<civodul>Guile as PID 1!
<davexunit>what an honor!
<davexunit>release notes?
<TaylanUB>woot!
***_zxq9_ is now known as zxq9
<civodul>even release notes!
<davexunit>civodul: where?
<civodul>NEWS, and in the announcement
<civodul>ah, dunno if it reached the lists yet
<civodul> http://lists.gnu.org/archive/html/guile-user/2013-12/msg00008.html
<davexunit>oh cool.
<davexunit>yeah I haven't received the email from the list yet.
<davexunit>I was checking info-gnu archive, not guile-user
<civodul>it's a bit early for info-gnu ;-)