IRC channel logs

2013-10-29.log

back to list of logs

***fangism is now known as fangism-hongru
***fangism-hongru is now known as fangism-hongry
<nalaginrut>morning guilers~
<civodul>oh, Hello Guilers!
<TaylanUB>Hidy ho!
<civodul>aaah
<civodul>it was too silent here :-)
<civodul>"Compute the maximum fixed point of the data-flow constraint problem."
<civodul>that is impressive :-)
<wingo>hehe ;)
*wingo learned quite a bit while playing with that stuff
<wingo> http://www.cs.umb.edu/~offner/files/flow_graph.pdf‎ is great
<civodul>"quite a bit", 100 pages!
<civodul>:-)
<civodul>cky: cky-hygienic-macros seems like a good idea
<wingo>hehe, there are many things i still don't get :)
<cky>civodul: Glad you like! :-)
<cky>civodul: Oh, BTW, I saw something lately (that has your name attached to git blame) that I'd query you about.
<cky>In the current documentation, in the Block Comments section, it says that (+ #| this is a #| nested |# block comment |# 2) evaluates to 3.
<cky>Either there's a missing 1 before the block comment, or the result should be 2.
<dsmith-work>cky: It's a very heavy 2
<cky>dsmith-work: Oh, I see. ;-)
<cky>Like a 2.99999999999999999999999999999999999999 kind of heavy 2, I guess. ;-)
<mark_weaver>cky: feel free to push a fix for that.
<mark_weaver>I think it's safe to say that the 1 is missing.
<civodul>cky: then the documentation may be broken :-)
<civodul>FSVO 2
<mark_weaver>What does "FSVO 2" mean?
<ijp>no, mathematics is broken
<ijp>actually, I believe I mentioned this before, but I do recall using one scheme implementation that allowed you to define numbers
<mark_weaver>wow
<civodul>mark_weaver: "for some value of 2"
<mark_weaver>ah, thanks :)
<civodul>i get used to these things ;-)
<ijp>I want to say it was stklos, but if it was stklos it doesn't do it anymore
<civodul>stklos' not dead!
<cky>mark_weaver: Will do.
<cky>civodul: ;-)
<cky>mark_weaver: Also did you see my message on the mailing list about the broken (help "foo")? I'll be happy to push my change if it looks reasonable.
<dsmith-work>cky: Exactly!
<dsmith-work>cky: As in (+ 2 2) -> 5 for certain large values of 2
<cky>;-)
<wingo>mew
<ijp>ruff!
<fangism>hi all, really old problem on x86_64-darwin11 (seg fault): env GUILE_INSTALL_LOCALE=1 GUILE_AUTO_COMPILE=0 ../meta/uninstalled-env guild snarf-check-and-output-texi < objprop.doc
<fangism>anyone else get this on guile-2.0.9? [guile-procedures.texi] Error 1
<fangism> http://paste.lisp.org/display/139704 -- shows partial output before crash
<fangism>2.0.7 did not have this problem, not sure about 2.0.8
<wingo>fangism: i can't reproduce that here with stable-2.0 git
<wingo>but i am on debian
<fangism> http://paste.lisp.org/display/139704#1 -- cat objprop.doc -- does that look similar to yours?
<fangism>objprop.doc is the smallest .doc that triggers seg fault
<fangism>what's a good way to run the uninstalled executable in gdb?
<wingo>meta/gdb-uninstalled-guile
<wingo> http://paste.lisp.org/display/139704#2
<wingo>i think my objprop.doc is the same
<fangism>apart from relative paths to .c file, yeah
<fangism>is there a gdb-uninstalled-guild?
<fangism>i'll just make one :)
<wingo>fangism: :) you can also meta/uninstalled-env env GUILE=meta/gdb-uninstalled-guile guild ...
<wingo>terribly verbose but it does work
<wingo>meta/guild should just work, that would be nice
<fangism>hmm, still struggling to get gdb to find the executable...
<fangism>gdb doesn't like guild (is a script)
<fangism>is there an equivalent way to load guild from within guile?
<wingo>you can load (scripts TOOL)
<wingo>for various values of TOOL
<wingo>then apply that module's main to the args that you choose
<fangism>I did this so far: env GUILE_INSTALL_LOCALE=1 GUILE_AUTO_COMPILE=0 ../meta/gdb-uninstalled-guile
<fangism>which booted into gdb, run then gave me the standard guile prompt
<fangism>or from gdb prompt, can I run with arguments like -s ../meta/guild ... ?
<wingo>you can run guile
<wingo>then (use-modules (script compile))
<wingo>for example
<wingo>then ((@@ (script compile) main) "arg1" "arg2" ...)
<fangism>arg1="guild", arg2="snarf-check-and-output-texi"? (sorry if these are stupid questions)
<wingo>i think it starts already with snarf-check-and-output-texi
<wingo>it would be (scripts snarf-check-and-output-texi) in that case of course
<wingo>instead of (script compile)
<wingo>and it's scripts not script
<fangism>ah
<wingo>you can see these files in module/scripts/snarf-check-and-output-texi.scm for example
<fangism>after (scripts snarf-check-and-output-texi), how do I redirect in (<) an input file?
<fangism>from the guile prompt, that is
<wingo>good question :)
<wingo>perhaps (with-input-from-file "objcode.doc" (lambda () ...call main ...)0
<wingo>otoh it's such a short file that you could copy-paste into the terminal of course
<fangism>duh, i'll just paste
<wingo>though maybe that's not the thing to do, given that it's maybe a locale issue...
<fangism>it didn't like the first 'snarf_cookie' unbound variable
<fangism>how can you tell it's a local issue?
<wingo>locale
<fangism>*locale
<wingo>i don't mean to say it's only your issue :)
<wingo>just thinking it could be locale related
<fangism>what should the procedure argument to with-input-from-file be?
<fangism>snarf_cookie is not exported from snarf-check-and-output-texi, so i'm thinking of trying with-input-from-file
<fangism>i've done: (use-modules (scripts snarf-check-and-output-texi)) (with-input-from-file "objprop.doc") (snarf-check-and-output-texi) -- then it hangs (waiting for input? not using CPU)
<wingo>fangism: the argument to with-input-from-file should be a thunk
<wingo>so snarf-check-and-output-texi without the parens
<fangism>gotcha
<fangism> http://paste.lisp.org/display/139704#3 -- gdb stacktrace
<wingo>wow, that could be a good one
<wingo>what C compiler did you use to compile guile?
<wingo>the new clang or the old apple gcc fork?
<fangism>apple's clang with Xcode 4.6.2
<fangism>looks like it finished "object-property" and then died somewhere in "scm_set_object_property_x" ?
<wingo>looked to me like the tortoise and hare thing didn't work
<wingo>can you mail bug-guile with that backtrace?
<wingo>i suspect if you compile guile with a lower optimization level it will work
<wingo>or a different compiler
<fangism>Apple LLVM version 4.2 (clang-425.0.28) (based on LLVM 3.2svn)
<fangism>will email bug-guile
<civodul>blech
<wingo>wow, i have guile building now with rtl...
<civodul>all of it?>
<wingo>it has done eval, boot-9, psyntax, vlist ...
<wingo>waiting on it to finish
<wingo>but that's farther than it's ever gotten before
<civodul>woow
<wingo>currently compiling peval
<wingo>iterative contification is neat, i have it printing how many things it contifies at each round
<wingo>usually takes 3-4 rounds to finish, but for peval it is taking longer
<wingo>sometimes it drops down to 1 contification but then that contification opens up 3 more possibilities...
<fangism>wingo: emailed bug-guile AT gnu
<wingo>tx
<civodul>wingo: is it something that needs to be tweaked, to avoid infinite recursions and such?
<wingo>dunno
<civodul>or is it known to terminate?
<wingo>it will terminate
<civodul>... eventually
<civodul>:-)
<wingo>but the question is, is it an n^2 thing or what
<civodul>yeah
<wingo>for peval it took like 30 rounds, over a couple minutes
<wingo>i'm sure it could be optimized a lot
<wingo>dominator computation and loop detection are being run there when it's not necessary
<wingo>but still i think it's probably worth it
<wingo>each contification is an important optimization
<wingo>and peval is really important, so i'm willing to pay for it
<wingo>the compile is proceeding
<dsmith-work>....
*fangism is curious what the tortoise and hare business is about
<fangism>wingo: rebuilding with clang -g -O1, we'll see what happens
<dsmith-work>fangism: circular list detection
<fangism>ah, i get it
<fangism>wingo: -O1 still crashes :( bootstrapping clang-release-3.3 now, will try that later
*TaylanUB built Guile 2.0.9.x fine on OS X a couple months back.
<fangism>TaylanUB: with what compiler/options?
<TaylanUB>Nothing fancy IIRC. It's on my work machine and I'm at home so can't check right now.
<dsmith-work>Hmm. I wonder how wingos build went..