IRC channel logs

2013-10-10.log

back to list of logs

***nalaginrut_ is now known as nalaginrut
<nalaginrut>morning guilers~
<nalaginrut>GNU Make 4.0 released, integrated Guile ;-)
<nalaginrut>sneek: later tell civodul I tried the latest stable-2.0, then 'interrupt system call' bug is gone, but I found the handler called delayed
<sneek>Okay.
<dje42>Is there a way to list the doc strings for all objects in a module?
*youlysses wonders how hard it'd be to implement din in guile on-top of guile-sdl. http://dinisnoise.org/about
<youlysses>Right now, they seem to be pimping tcl as ideal over "lisp". :^U
<nalaginrut>dje42: (hash-for-each (lambda (k v) (let ((p (module-ref (current-module) k))) (and (procedure? p) (format #t "~a~%" (procedure-documentation p))))) (module-import-obarray m) )
<nalaginrut>sorry, change (module-import-obarray m) to (module-import-obarray (current-module))
<dje42>thx. trying it with gdb+guile I see it only prints doc strings for functions I've called
<dje42>[maybe just need to switch into the gdb module first?]
<nalaginrut>dje42: what's the mean of gdb+guile? guile as debug script? or debug guile?
<nalaginrut>my approach is weak to fetch all the bindings of current module
<dje42>gdb, with guile scripting added on
<nalaginrut>nice
<dje42>[almost ready to submit to gdb-patches@]
<nalaginrut>dje42: sounds cool, it's really good job if you really done that, I planed to work on guile-gdb, but lack of time
<nalaginrut>any repo I can see?
<dje42>nothing yet, except on my home machine
<dje42>soon [i hope]
<dje42>time for sleep .... 'nite
<nalaginrut>night
<nalaginrut>sneek: later dje42 this is a more completed version https://gist.github.com/NalaGinrut/6914993
<sneek>So noted.
<nalaginrut>sneek: later tell dje42 this is a more completed version https://gist.github.com/NalaGinrut/6914993
<sneek>Okay.
<nalaginrut>#vu8(121 101 115 121 101 115 0 0 0 0), how can I parse this bytevector as struct{ char* str1; char* str2;}?
<nalaginrut>emm..no, struct { char str1[3]; char str2[3];}
<nalaginrut>alright, I got it
<nalaginrut>seems there's bug for SA_RESTART in the latest stable-2.0
<nalaginrut>the registered SIGALRM handler doesn't run unless I type Enter
<nalaginrut>but in the older version, though there's 'interrupt system call' bug, the handler will run automatically
*nalaginrut sending the mail
<nalaginrut>oops, it's reported http://debbugs.gnu.org/cgi/bugreport.cgi?bug=14640#5
***ijp is now known as c967d108-66a1-4d
***c967d108-66a1-4d is now known as ijp