IRC channel logs

2013-09-29.log

back to list of logs

***linas_ is now known as linas
<aidalgol>ijp: OK, so what should we do with the bot next?
<sneek>aidalgol, you have 1 message.
<sneek>aidalgol, dsmith says: sarahbot used to inhabit #scheme and was written in a java based scheme. Sneek is a port of part of that code to guile and bobot++.
<ijp>aidalgol: dunno, I've been peeking through rudybot's code today
<aidalgol>Is it ugly?
<ijp>the organisation is confusing
<nalaginrut>afternoon guilers~
<aidalgol>evenin'
<nalaginrut>heya
<nalaginrut>guile-2d has 40 stars now! I have to do more effort ;-)
<nalaginrut>for Artanis
<civodul>Hello Guilers!
<foeniks>I have created homebrew formulae for installing guile-2d on my macbook
<foeniks>i.e. creating a package for each of the dependencies
<foeniks>yet I get an error when homebrew does configure guile-sdl
<foeniks> http://pastebin.com/n4MA7yAQ
<foeniks>configure: error: guile required but not found
<foeniks>however, guile is installed via homebrew
<foeniks>do you have any ideas?
<dsmith>foeniks, look at the place in the configure script to see how it checks for guile. Try to run that by hand. See where that takes you.
<dsmith>foeniks, There is a log file
<davexunit>foeniks: guile-sdl has some issues on os x, afaik
<davexunit>I have another user that had trouble installing it.
<davexunit>which sucks.
<foeniks>davexunit, yeah, but what I found about osx incompatibility is at compile time and not configure time
<foeniks>will have a look at the configure script
<davexunit>foeniks: please keep me informed. if you can help with this problem, it would be great to write to the guile-sdl bugs list.
<davexunit>I am the author of guile-2d, btw.
<foeniks>davexunit, will do ;)
<davexunit>thank you for trying to get guile-2d working.
<davexunit>it's not as easy as it should be, but someday...
<cky>davexunit: Ohai! Hope you're enjoying GNU30. :-)
*cky is at RacketCon today.
<foeniks>hmm, running ./configure directly works
<foeniks>so homebrew seems to set up things differently
<davexunit>cky: hello
<davexunit>I am helping someone setup GNU FM right now.
<davexunit>cky: hope you are enjoying racketcon
<davexunit>nice to see some guilers irl yesterday
<cky>Yes, awesome to see Guilers. Have fun with GNU FM!
<foeniks>ok this was my bad
<foeniks>it seems that including a guile dependency in the guile-sdl.rb Formula fixed things
<foeniks>don't know much about homebrew but it seems to sandbox the build process or whatever
*foeniks is randomly speculating
<foeniks>davexunit, homebrew has an sdl and sdl2 package
<davexunit>okay.
<davexunit>you want sdl
<davexunit>no support for sdl2 yet
<foeniks>thx
<davexunit>(I might write my own minimal sdl2 wrapper for guile-2d)
<davexunit>(sometime...)
<foeniks>next issue is that during compile time, it does not find SDL.h and libguile.h
<foeniks>configuring was successful
<foeniks>I think this is something that can be traced
<foeniks>might have to leave in the next few minutes
<davexunit>okay
<davexunit>thanks for your work so far
<foeniks>from what I can see there is an SDL.h that comes with mac-os which is in /Library/Frameworks/SDL.framework/Versions/A/Headers/
<foeniks>next step will be to find out whether to build against these or the homebrew packages
<foeniks>pygame seems to be built against the homebrew SDL, a bit dated but http://jalada.co.uk/2011/06/17/installing-pygame-on-os-x-with-a-homebrew-python-2-7-install.html
<foeniks>In file included from sdl.c:23:
<foeniks>guile-sdl.h:40: error: SDL.h: No such file or directory
<foeniks>okay, #include "SDL.h" fails in guile-sdl.h at line 40
<foeniks>with #include "SDL/SDL.h" it should work
<foeniks>hmm, from the command line parameters, the directory SDL should be in the include path
<foeniks>this will need some more investigation
<foeniks>will be off for a while
<foeniks>bye
<davexunit>bye
<davexunit>hey mark_weaver
<mark_weaver>hi davexunit! sorry, I'm late getting out today. up all night with thoughts running through my mind :-/
<mark_weaver>davexunit: what have you been up to today so far?
<davexunit>helping with gnu FM. getting lunch now.
<davexunit>I'm down for guile related things when you make it out today.
<mark_weaver>sounds good! I'm still trying to figure out what's the best thing guile-related thing to work on that would be collaborative in nature.
<mark_weaver>davexunit: do you have ideas of something I could work on in Guile that would help Guile-2D?
<davexunit>a compatible repl?
<mark_weaver>ah, that's a good idea!
<mark_weaver>I think that would be widely useful.
<mark_weaver>have you figured out where you're going to lunch?
<davexunit>Mary Chung
<davexunit>I'm there with a bunch other people from the hackathon.
<mark_weaver>cool!
<mark_weaver>you're there right now?
<davexunit>yeah waiting now
<mark_weaver>okay, I'll see you at the hackathon after lunch. should be there in an hour or so.
<davexunit>sounds good.
<davexunit>hopefully I'll be back around that time.
<cluck>:)
<dje42>Does Guile have any conventions for the style of error messages? [even if not always followed]
<dje42>E.g.; Begin with capitalized word? End with period?
<civodul>dje42: should be the GNU conventions, though it's probably not always followed
<civodul>at the API level, though, you should not pass actual messages
<civodul>ideally, use SRFI-35-style error condition objects
<dje42>Even GDB doesn't follow the exact GNU conventions (sigh).
<civodul>heh
<dje42>I ask because what I see in Guile is sufficiently dissimilar from GDB that I can imagine there being a discussion.
<dje42>For errors -> Scheme, I want to follow Guile.
<civodul>yeah, historically Guile has been doing weird stuff ;-)
<dje42>But I can imagine code review in GDB pushing back.
<civodul>so, the historical exception mechanism in Guile is used to pass actual error messages
<civodul>but that's obviously a bad idea
<civodul>that's why i advocate for SRFI-35-style exception objects
<dje42>thx
<civodul>i think wingo and mark_weaver would agree with that recommendation
<dje42>I've been following Guile's own exception, umm, style.
<dje42>(key, args) with args having its own convention of func_name, arg_pos, message, object (e.g. for type errors)
<dje42>What does & as a symbol prefix mean? [I gather % means "private" or "internal". But haven't come across & before. At least I can't remember having seen it.]
<ijp>it depends
<ijp>if you saw it in the conditions code, it's just there to signify a condition
<dje42>Ah.
<dje42>I don't see a call to set-exception-printer! in srfi-35.scm.
<dje42>I gather from srfi-34.scm that all conditions are mapped to Guile exception key 'srfi-34.
<foeniks>I am trying to build guile-sdl from the repository snapshot
<foeniks>so when executing the autogen.sh script, it wants to execute 'snuggle'
<foeniks>so after some googling it seems that snuggle is a tool which has been superceded by guile-baux
<ijp>ttn is a pain in the ass like that
<civodul>that's not politically correct, ijp :-)
*davexunit wants to write his own sdl2 binding :P
<dsmith>ttn is "interesting"
<dsmith>sneek, seen ttn?
<sneek>ttn was here Jun 15 at 10:36 pm UTC, saying: good night everyone..
<civodul>ttn has developed Guile helpers that are not quite in line with the philosophy of the rest of Guile, i'd say
<foeniks>so, "autogen.sh: line 25: snuggle: command not found" <- how to get "snuggle"
<dsmith>Ah, but WHICH June 15?
<ijp> http://gnuvola.org/software/snuggle/
<civodul>foeniks: http://gnuvola.org/software/snuggle/
<ijp>incidentally, when did he start maintaining RCS?
<civodul>a few months ago
<foeniks>ttn?
<civodul>yes
<ijp>that's a really weird thing to volunteer for
<dsmith>ijp, Sometimes you send in a patch. And all of a sudden they make you the maintainer
<ijp>sometimes not even that
<civodul>dsmith: there is no "they"
<dsmith>heh
<civodul>one has to volunteer
<dsmith>ok
<ijp>wingo gave me commit access to guile-sqlite3 just because I kept moaning him to apply someone else's patch
<civodul>dsmith: that said, you're right about the general approach; it's just slightly more subtle in practice ;-)
<foeniks>ok, so guile-baux is no drop-in replacement of snuggle
<dsmith>Sending in the patch is obviously volunteering, right? No one forced you. ;^)
<foeniks>and now `autogen.sh: line 30: guile-baux-tool: command not found`
<foeniks>yet I thought guile-baux was something to be incorporated into the repository of the main project
<foeniks>?
<ijp>I thought that was silly myself
<ijp>kinda schizo
<civodul>well, he's trying to solve the problem of supporting several major Guile versions
<civodul>and surely, there's room for factorization
<ijp>I really need to learn how to use a theorem prover
<civodul>Coq + ProofGeneral is great
<foeniks>I need to learn to understand gnu build tools...
<dje42>Does Guile or SRFI have some kind of iterator support (not necessarily equivalent to Python, just something similar) ?
<ijp>the collections srfi may have covered it, but I don't know if anyone actually supports that
<ijp>and streams are kind of iterators
<ijp>if you just want generic iteration, and not a generator object, try srfi 42
<ijp>I have some issues with the design of that, but mark_weaver seems to like it
<dje42>thx
<ijp>if you scour the mailing list, you can find generator implementations, because I invariably rewrite one when someone asks for an example of delimited continuations
<mark_weaver>ijp: fwiw, I've warmed up to foof-loop as well.
<mark_weaver>ijp: where's your little tutorial about how to get guildhall set up with your repo?
<mark_weaver>sneek: guildhall?
<sneek>Its been said that guildhall is git clone git://gitorious.org/~wingo/dorodango/guildhall.git
<ijp> https://github.com/ijp/guildhall/wiki/Getting-Started
<mark_weaver>sneek: forget guildhall
<sneek>Consider it forgotten.
<mark_weaver>sneek: guildhall is https://github.com/ijp/guildhall/wiki/Getting-Started
<sneek>Okay.
<mark_weaver>ijp: thanks!
<mark_weaver>what's the syntax for setting repl options again?
<civodul>mark_weaver: ,option
<mark_weaver>thanks!