IRC channel logs

2013-09-28.log

back to list of logs

<tupi>io film festival
<tupi>sorry, wrong window :)
<ijp>davexunit: you might be interested in http://users.softlab.ntua.gr/~ttsiod/gravityRK4.html
<ijp>could make a nice demo idea for your guile 2d
<davexunit>thank you, ijp
<aidalgol>ijp: New issue: memos
<ijp>I started coding it up, but I got distracted
<aidalgol>I almost feel I should be paying you...
<ijp>the ijp is a simple creature, you just need to find problems of the right size
<aidalgol>What else does sneek do that cbot can't do?
<aidalgol>sneek: source
<sneek>Last time I checked source is at http://git.savannah.gnu.org/gitweb/?p=guile.git
<aidalgol>No, not the *guile* source.
<ijp>doc lookup, but I have code for that
<aidalgol>What's sneek an instance of, again?
<ijp>bobot
<aidalgol>ty. I couldn't remember the name.
<aidalgol>Do we want a sandboxed REPL, too?
<ijp>well, the way mark_weaver suggested to me was to spawn a separate guile process with os resource limits
<davexunit>ooh I'm interested in sandboxed guile
<davexunit>for an idea of mine :)
<ijp>a simpler way is to create reduced import modules, but then you don't get protection for ((lambda (x) (x x))(lambda (x) (x x)))
<ijp>in particular, these modules should not be able to introspect on the module
<ijp>you'd also need to hack a variant whitelisted version of use-modules
<aidalgol>Sandboxing is tricky, and since sneek doesn't already have one, I think it can come after the sneek coup.
<ijp>and of course, there is my favourite solution (and the only real one): write a whole new guile vm
<aidalgol>Uh, I think a separate process is the way to go.
<ijp>which is not as bad as it sounds, but not a good idea while we are still figuring out the rtl one
<aidalgol>RTL?
<ijp>the new one
<aidalgol>Presumably not Right-To-Left.
<ijp>it's supposed to stand for register-transfer-language, but IIRC that's not an accurate representation
<aidalgol>OK, now this is just getting really ridiculous, but I want to make erc-shoot more portable.
<aidalgol>So we can use it from ERC *and* cbot.
<aidalgol>Is the current implementation within the subset of elisp that the GVM can run?
<ijp>tias
*aidalgol checks the manual.
<aidalgol>How?
<ijp>,L elisp
<ijp>erc-firearms.el works fine
<ijp>-shoot.el probably won't due to library functions
<aidalgol>Yeah...
<aidalgol>It's also written for a human user, what with the pronoun variable.
<aidalgol>Might make more sense to make erc-firearms a file with the vector as the only s-exp in it.
<aidalgol>And then `read' that in from emacs *or* guile.
<ijp>I do that quite often. I like making it delimited because then it's only one read
<aidalgol>delimited how?
<ijp>( entries ..... ) EOF
*ijp unlocks achievement: understands free monads
<aidalgol>ijp: Just beefed up plugins/shoot.scm
<mark_weaver>ijp: a more serious problem with reduced import modules is this: http://lists.gnu.org/archive/html/guile-devel/2012-05/msg00041.html
<ijp>ah, I'd forgotten about that
<ijp>that one is a tremendous pain in the arse
<mark_weaver>It's on my TODO :)
<ijp>when's the hackathon? today, or tomorrow?
<aidalgol>Why can the hole not be plugged until 2.2?
<ijp>aidalgol: because some people *glares at stis* actually use that syntax for syntax objects
<ijp>I'm not sure why that was allowed in the first place, bootstrapping?
<ijp>at the very least, it could (in contrived circumstances) break a perfectly normal scheme program
<mark_weaver>the hackathon is the next two days (Saturday 10am EDT until sometime late on Sunday)
<mark_weaver>ijp: not sure why what was allowed?
<ijp>vector literals for syntax objects
<mark_weaver>well, it's not so much "allowed". it's just that vectors are used as the representation of syntax objects.
<ijp>bootstrapping is the obvious reason, but surely it would have been a preprocess
<mark_weaver>but bootstrapping is a problem, yes. psyntax-pp.scm contains those syntax objects in the expanded macros.
<mark_weaver>so if we change the representation to something that can't normally be read, we need a solution for psyntax-pp.scm at least.
<mark_weaver>it's possible that there are other issues as well, dunno.
<mark_weaver>I guess the first solution that comes to mind is to change the representation to a record, and then add an optional read syntax that is normally disabled.
<mark_weaver>and see if anything else breaks :)
<ijp>I watched david wheeler's dissertation defense video
<ijp>a bloody gig it is, I'm surprised he hosts it
<mark_weaver>ijp: interesting. it seems like a very good technique to me. did someone point out a serious flaw?
<ijp>dunno, but I haven't came up with anything he hasn't covered
<ijp>he gives a formal proof, and the assumptions seem reasonable to me
<dsmith>ijp, look to sarahbot
<aidalgol>What's sarahbot?
<cky>aidalgol: A bot of all trades that hung around the Common Lisp channels.
<wingo>greets
<civodul>howdy!
<aidalgol>Evenin'
<wingo>emitting dwarf, woo
<mark_weaver>woohoo!
<civodul>wingo: excellent!
<wingo>:)
*mark_weaver heads over to the gnu30 hackathon in Cambridge (right next door to MIT's radio station, where I work :)
*foeniks wonders if he is the only one thinking of Camebridge, Camebridgeshire first, when reading that name
<dsmith>sneek, later tell aidalgol sarahbot used to inhabit #scheme and was written in a java based scheme. Sneek is a port of part of that code to guile and bobot++.
<sneek>Will do.
<wingo>dsmith: where is sneek's source code?
<cky>dsmith: Oops, I stand corrected.
<cky>(Re sarahbot.)
<mark_weaver>cky: fyi, I'm currently at a friend's house, getting a wireless mic to ensure better sound quality for RMS's talk later.. will be back within the hour.
<mark_weaver>davexunit: ^^
<dsmith>wingo, It's not in a public repo anywhere. I did send a tarball to a few people..
<dsmith>wingo, jao, nalaginrut, and someone else I think
<davexunit>where's that mark_weaver at?
<davexunit>we need a guile meetup here at MIT
<civodul>Guilers, unite!
<davexunit>he's been off hunting for audio equipment all day
<davexunit>so the rms stream has good audio quality
<davexunit>perhaps tomorrow will be the day of the guile!
<mattl-mobile>davexunit: never.
<ijp>davexunit: what about cky?
<davexunit>ijp: he's here.
<davexunit>he was at the cryptoparty
<davexunit>and also didn't know where mark_weaver was.