IRC channel logs

2013-08-24.log

back to list of logs

***sethalve_ is now known as sethalves
<aidalgol>How can I connect to a REPL server listening on a UNIX domain socket (as opposed to a TCP socket)? The only tools I can think of (e.g. netcat) only speak TCP/IP.
<weinholt>aidalgol, try socat
<aidalgol>weinholt: Invoked how?
<aidalgol>Ah ha! socat UNIX-CONNECT:/tmp/guile-socket STDIO
<weinholt>yep
<aidalgol>ty
<civodul>Hello from GHM!
<djcb>GHM?
<djcb>ah, GHM!
<civodul>yes, GHM!
<amk9>what c means in assoc ?
<sneek>Welcome back amk9, you have 1 message.
<sneek>amk9, nalaginrut says: I think it's cool to have a try, could you raise an issue as feature-request on github? in case I forget it later
<weinholt>amk9, the name of the assoc procedure just comes from "association list"
<amk9>I got it actually
<amk9>ass*q* is for eq?
<amk9>ass*v* is for eqv?
<amk9>and assoc seems like the default so it's just assoc
<weinholt>yeah, and similary for member/memq/memv
<amz3>thx
<stis>Morning guilers!
<add^_>Good afternoon :-)
<sneek>Welcome back add^_, you have 2 messages.
<sneek>add^_, mark_weaver says: (fib 4000000) has 835951 decimal digits. To compute such large fibonacci numbers, you need to use a matrix exponentiation method. I have Scheme code that can efficiently compute it in less than 0.4 seconds in Guile: https://lists.gnu.org/archive/html/guile-devel/2011-01/txtGaSbapq3P2.txt
<sneek>add^_, mark_weaver says: computing it is fast, but printing out the number takes a *lot* longer.
<add^_>mark_weaver: I was thinking wrong about that, I wasn't supposed to write out the 4000000th fib or anything, it was something else, I solved it though. Thanks!
*add^_ is going to look at the linked code anyway
<add^_>Aah nice
<wingo>heya civodul
<civodul>hey wingo!
<civodul>we miss you!
<civodul>are you at Froscon?
<wingo>civodul: no, my gf's family is in town this weekend
<wingo>in the end i go to neither :)
<wingo>say hey to all the folks there!
<civodul>hey, will do :-)
<wingo>do you know, is savannah down for pushing?
<civodul>i don't think so
<civodul>anything wrong?
<civodul>you wanna push the rest of the compiler? ;-)
<wingo>i am working on making the compiler understandable ;)
<wingo>wanted to push some unrelated stuff
<DerGuteMoritz>hello from quasiconf!
<wingo>heya DerGuteMoritz :-))
<DerGuteMoritz>hey wingo!
<wingo>sorry i couldn't be there either :)
<DerGuteMoritz>yeah too bad!!
<wingo>all parenthetically lovely over there?
<DerGuteMoritz>but you don't miss *that* much, many people couldn't make it
<wingo>bummer
<DerGuteMoritz>yes, having a clojure workshop right now, everyone's busy!
<DerGuteMoritz>around 30 folks
<wingo>that's good though :)
<wingo>yay clojure :)
<DerGuteMoritz>felix will do a talk on scheme implementation techniques in about 45 minutes
<DerGuteMoritz>which I think will be this year's highlight!
<DerGuteMoritz>if you are interested you can follow the live stream here: http://streaming.sigint.ccc.de/c116/
<DerGuteMoritz>or http://streaming.media.ccc.de/c116/ I guess is the canonical URI
<wingo>cool, i will tune in!
<DerGuteMoritz>nice!
<civodul>hello DerGuteMoritz & quasiconf :-)
<DerGuteMoritz>hi civodul!
<DerGuteMoritz>you in paris?
<civodul>yep, GHM!
<DerGuteMoritz>neat!
<civodul>no streaming though
<DerGuteMoritz>hope it's going well
<DerGuteMoritz>wingo isn't there either?
<civodul>nope
<civodul>he betrayed both of us!
<DerGuteMoritz>oh right just read the backlog
<civodul>:-)
<DerGuteMoritz>ha!
<DerGuteMoritz>SCHEMER
<civodul>heheh
<wingo>;)
<DerGuteMoritz>sorry, internet connection was down for a moment
*wingo has to step out actually, biab -- enjoy felix's talk, and i think i'll catch the video later
<DerGuteMoritz>cool!
<wingo>hopefully they have better luck this year :)
<DerGuteMoritz>have a nice day!
<add^_>arrays are confusing
<add^_>Making them isn't really hard (especially because of the list->array procedure), but understanding how the array-ref works is...
<add^_>Ugh
*add^_ is trying to use the arrays for OpenGL stuff in figl
<add^_>Oh
*add^_ just understood than he had misunderstood something
<add^_>xD
<add^_>The bounds of (list->array ...) wasn't what I thought it was.
<add^_>Rather, the dimspec
*add^_ shuts up now
<civodul>shanecelis: listening to/viewing your talk at the GHM currently :-)
<shanecelis>civodul: heh, cool.
<sneek>Welcome back shanecelis, you have 1 message.
<sneek>shanecelis, mark_weaver says: here's an implementation of 'make-trampoline' that uses vastly less memory per trampoline, and avoids loading the compiler: (define (make-trampoline module name) (let ((var (module-variable module name))) (lambda () ((variable-ref var)))))
<shanecelis>mark_weaver is so cool.
<shanecelis>sneek: tell mark_weaver thanks and that he got a special mention in my talk for being extremely helpful.
<sneek>mark_weaver, shanecelis says: thanks and that he got a special mention in my talk for being extremely helpful.
<shanecelis>oh, oops!
<shanecelis>hi mark_weaver!
<mark_weaver>aww, thanks! :) where is the video of your talk, btw?
<shanecelis>I'll post it soon. Right now they're showing it live in Paris.
<civodul>yep
<civodul>i guess it'll eventually end up on audio-video.gnu.org and irill.org
<civodul>(if that's fine with you)
<shanecelis>yeah, totally fine. :)
<civodul>that was my assumption :-)
<civodul>hello mark_weaver, BTW :-)
<mark_weaver>hi civodul! sorry I couldn't be there. I look forward to seeing your talk on Guix as well :)
<mark_weaver>So much hacking to do, not enough time to do it all :-/
<civodul>heh :-)
<civodul>ooh, the Webkit demo now
<shanecelis>:)
<civodul>very nice
<civodul>i'd rather use this than Conkeror ;-)
<shanecelis>Thanks. :)
<civodul>making what M-x shows contextual sounds like a good idea
<shanecelis>civodul: Glad to hear you like it. I don't want to make gratuitous changes, so hearing affirmation (or rejection) is good for what's worth working on.
<shanecelis>Q&A finished. *whew*
<djcb>are there streams available?
<ijp>streams as in lazy lists?
<add^_>srfi-41 streams?
<ijp>srfi 41 is to be preferred if you are using a recent enough guile
<ijp>(ice-9 streams) is kinda ...
<mark_weaver>yes, definitely use SRFI-41
<djcb>ijp: streams as in viewable content from ghm :)
<mark_weaver>haha
<mark_weaver>apparently not :-(
<djcb>well, i guess that i'll have to amuse myself with srfi-41 then :)
<amz3>how is GHM going ?
***ijp` is now known as ijp
<mark_weaver>sneek: later tell Chaos`Eternal sorry I missed your messages earlier. Ping me next time you're on?
<sneek>Got it.