IRC channel logs

2013-07-11.log

back to list of logs

<Giomancer>wELL, KICKASS.
<Giomancer>..aaand capslock. :P
*Giomancer waves hello and runs off to lurk
<nalaginrut>morning guilers~
***cky944 is now known as cky
<wingo>moo
<dsmith>oom
<taylanub>omo
<taylanub>Oh, when I (compile '(let ((v (vector 0 1 2))) (vector-ref v 0))) I actually get back 0, even though using ,optimize on the same form fails to do that (unless the vector is a literal). Is there a somewhat better indicator than using ,optimize to see what my code actually ends up being optimized to ?..
<nalaginrut>fixed 2 bugs of artanis, now redirect under firefox is fine
<taylanub>Oh, `compile' actually runs the code, it seems. :P
<taylanub>Yeah, apparently the default target "language" is "value". Interesting.
<taylanub>(Well, nothing says "language", it's just the #:to parameter.)
<civodul>Hello Guilers!
<taylanub>Hrm, coverage-reporting has some annoying bugs; merely changing whitespace can change the reported coverage-percentage.
<civodul>taylanub: (system vm coverage)?
<taylanub>civodul: Yup, I'm using it to generate pretty LCOV reports viewable in the browser, as advertised in the manual, which is very very neat, except for a couple false negatives (and possibly false positives, but I guess code-coverage testing has many intrinsic limitations anyway).
<civodul>taylanub: i'm confident it has bugs ;-)
<civodul>when running ./check-guile --coverage (which is veeeeery slow), it does have issues
<civodul>but i've never managed to come up with a reduced test case :-/
<civodul>so if you do, please report it
<civodul>i'd be happy to finally fix that
<taylanub>OK. By the way the graphical reports I get only seem to show which source lines were visited at all, disregarding the different code-pathes through which they can be reached; I wonder if this is a limitation of the graphical front-end, or the underlying GCC utility it uses.
*taylanub goes to RTFM on gcov.
<add^_>:-)
<civodul>taylanub: you use LCOV, not gcov, and LCOV is not part of GCC
<taylanub>Oh, I thought LCOV just turns gcov output into web documents.
<civodul>yes, but in our case, "gcov output" is produced by (system vm coverage), not by gcov :-)
<taylanub>Aha, interesting.
*wingo finished a cps-conversion pass this morning, on stolen time
*taylanub steals time all too often. :|
<shanecelis>wingo: What's the status on ethreads?
<shanecelis>wingo: I was considering using them or something like them in Emacsy.
<add^_>shanecelis: Oh, you were the one working on emacsy? Nice!
*add^_ should have known
<wingo>shanecelis: still wip, no eta
<wingo>the branch works fine, but the right solution is to make ports usable from scheme without recursing through c
<wingo>so it doesn't make sense to merg them now
<wingo>and i have other priorities
***sneek_ is now known as sneek
<shanecelis>wingo: Cool. Good to know.
<shanecelis>Is there a good way to tell guile to drop into the REPL when there's an error in a script?
<shanecelis>add^_: Yep. There's a hello world app for it, but lots left to do.
<shanecelis>I had some time-consuming state that just got obliterated because of a little error that I'd like to prevent in the future.
<wingo>call-with-error-handling i think
***linas__ is now known as linas
*civodul discovers geiser+company by chance
<add^_>geiser+company?
<add^_>civodul: ^
<add^_>shanecelis: I should take a closer look at it really, it seems very promising. :-)
<taylanub>There is `company-mode' which seems to do auto-completion with an in-buffer popup. The `auto-complete' package does much the same and is much more popular, but perhaps it hasn't been integrated with Geiser yet. (I'm also not sure if its higher popularity is for any "real" reason.)
<add^_>taylanub: aha
***sneek_ is now known as sneek
<civodul>add^_, taylanub: yeah, there's a Geiser back-end for Company
<civodul>and it does the nifty completion things as seen on TV
<civodul>well, my guess, because i don't have a TV
<taylanub>After some time I found auto-complete annoying while typing Elisp. If it were faster it could be quite neat I guess.
<taylanub>Can't wait for implementing that in Guile Scheme for Emacs! :P
<civodul>:-)
<civodul>i've found it surprisingly fast for Geiser
<civodul>less than half a second, i'd say
<taylanub>Maybe company-mode is faster than auto-complete, and/or maybe I misconfigured my auto-complete.
<civodul>ah, dunno
<civodul>i think i don't use it
<civodul>i use Geiser's completion + hippie-expand
<civodul>and now company-thing
<taylanub>Oh, is it not automatic as you type ?
<civodul>no!
<civodul>well, Company is
<civodul>but Geiser is M-TAB
<civodul>so i gather tha auto-complete is automatic?
<taylanub>Yeah. :P