IRC channel logs

2013-05-30.log

back to list of logs

<davexunit>is there a reason that '%' isn't modulo like in most languages?
<civodul>mostly naming conventions
<civodul>but you can (define % modulo) if you want
<civodul>(but note that (ice-9 prompts) uses % for something else)
<davexunit>I'll stick with the standard name. Just curious. thanks.
*davexunit got guile-sdl working
<davexunit>apparently cloning the git repo was the wrong way to go.
<civodul>yeah starting from a tarball is usually easier
<shanecelis>I realized I was going to need to clean up before a thing was garbage collected.
<shanecelis>Guardians are a really clean solution. Love it!
<Nafai>shanecelis: congrats on the GSOC for Emacsy!
<shanecelis>Nafai: Hey, thanks!
<shanecelis>Nafai: I'm excited about it. Unfortunately, I'm on a deadline right now, so I'm forcing myself to not think about it.
<davexunit>I'm also very excited about emacsy
<shanecelis>davexunit: good to hear. Yeah, some of the issues you were bringing up like customization are definitely things I'm interested in tackling with Emacsy.
<davexunit>looking forward to seeing what you come up with.
<davexunit>I wonder how easy it will be to fit Emacsy into a game loop.
<shanecelis>Ok, one thing I'm really excited about that stretches a little bit beyond Emacs is job control. I mean, imagine if when you were using Emacs and something stalled, you could hit C-z like you do in the shell and suspend it or put it in the background.
<davexunit>that would be wonderful.
<shanecelis>davexunit: Easy, I hope. And I'm trying to keep it as a library not a framework so people can do as they like with their event loop.
<davexunit>what is the easiest way to take a floating point number and turn it into an integer? (round (inexact->exact n)) ?
<davexunit>shanecelis: :)
<shanecelis>night, guilers!
<davexunit>good night
<davexunit>longshot: anyone know offhand how to get the raw pixel data of an SDL surface using guile-sdl?
***fangism is now known as fangism-hongry
<nalaginrut>morning guilers~
<nalaginrut>davexunit: maybe get the pointer then pointer->bytevector
<civodul>Hello Guilers!
<nalaginrut>civodul: heya
<nalaginrut>is there any way to apply a monkey-patch in Guile?
<civodul>what do you mean?
<nalaginrut>civodul: when my Guile program is running, is that any way to update the running code without restarting the program?
<civodul>nalaginrut: ah yes, that's what Geiser does, for instance
<civodul>basically you can set! existing procedures and variables
<civodul>and you can compile stuff at run time
<janneke>how do i get the type of something, ie what is (class-of ..) called without goops?
*janneke wants x->string
<janneke>outside of goops
<fbs>How many possible types can it have?
<janneke>number, string
<fbs>just use a simple if?
<fbs>(if (number? x) (number->string x) x)
<janneke>fbs: i'm stupid! *thanks*
<fbs>lol
<janneke>too much hacking, too little sleep -- not good
<janneke>:-)
<fbs>what are you making?
<janneke>a gui for lilypond
<janneke>oh, i'm using goops, but need to extend lily right now and don't want to introduce goops there
<janneke>...just yet
<fbs>ah
<davexunit>I don't know of a way to ask "what type is this?"
<add^_>davexunit: is it too general?
<davexunit>it's a thing that is slightly weird getting used to. in python, ruby, etc. I can ask an object what it's type is.
<davexunit>afaik you do not do this in scheme. you can ask if something is a particular type, but not what type an object is.
<add^_>Hm
<shanecelis>davexunit: huh, I didn't know that. Interesting.
<davexunit>but is this actually true? I just haven't discovered a way to do it. (outside of GOOPS classes)
<fbs>I think it is
<shanecelis>Are there any guile web servers?
*shanecelis googles
<shanecelis>nevermind. found it.
<fbs>its in the manual
<fbs> https://github.com/NalaGinrut/artanis
<fbs>might also be an option
<davexunit>artanis is a cool project.
<shanecelis>very cool.
<shanecelis>Sometimes I think of Guile as not being a batteries-included language, but it's just chock full of good stuff.
<fbs>well it doesnt have the python/ruby user base
<davexunit>yeah, it doesn't have all the goodies that python/ruby enjoy
<davexunit>I hope guile can gain some more users :)
<add^_>fbs: How's Guile-IRC doing?
<fbs>add^_: i redid the networking, moved it into a seperate network file, new tls stuff in a seperate file
<davexunit>guile irc? now that sounds cool!
<fbs>now i should be able to use #:autoload to make the whole tls crap optional so people dont need to install tls
<add^_>Yeah
<add^_>Good
<add^_>:-)
<fbs>but it still needs a lot of love
<davexunit>I got guile-sdl installed last night and it's been pretty fun to use so far.
<fbs>need stuff like nick tables, rate limiting etc etc
<add^_>fbs: I'm actually not very familiar with most of the IRC stuff, I didn't really feel like reading through the specs etc..
<fbs>well most of the IRC stuff already works
<add^_>I just made that ugly TLS hack with some help from civodul :-/
<fbs>but its networking, so there are network problems that need to be handled
<fbs>and ofc the joining of protected channels, or getting kicked out, banned whatever
<add^_>ah, yeah..
<fbs>so I need to make channel and nick tables, parse messages from the server to see if i get kicked out and when users leave.
<add^_>ok :-)
<add^_>Hm, I deleted every config-file for my bot when I was uploading it to github. :-/
<fbs>its a lot of boring work
<fbs>:p
<add^_>Yeah
<add^_>The fun part is what's already done ;-)
<fbs>always
<add^_>hah
<fbs>hmm, looks like something broke :/
<add^_>?
<fbs>lol nm, wrong directory
<add^_>ah
<fbs>hmm
<fbs>this should
<fbs>botbotbot: ,hi
<fbs>,hi
<fbs>,hello
<botbotbot>hello master!
<fbs>so thats its current state :)
<add^_>hm
<add^_>Is that the basic bot stuff from the guile-irc project?
<fbs>no its the test/test-connect in the dev branch
<add^_>I remember adding some stuff for the bot, but that's in it's own project.
<add^_>ah
<fbs> https://github.com/fbs/guile-irc/blob/dev/test/test-connect.scm
<fbs>./env test/test-connect.scm irc.freenode.net 6697 #guile 1
<fbs>if i ever get far enough I can code a small server. That way it can test itself
<add^_>:-)
<add^_>aaah, I found another banana commit!
<fbs>:p
<fbs>must be the first commit
<add^_>Yup
<fbs>anyway, time to go shopping
<fbs>o/
<add^_>cya later
***Gues_____ is now known as Guest10180
***g3ntleman_ is now known as g3ntleman
***fangism-hongry is now known as fangism
<BufferUnderpants>Hi, I'm trying to build guile-gnome
<BufferUnderpants>But, ./configure throws this error: configure: error: Failed to find Guile. Is it installed?
<BufferUnderpants>Despite guile being very much installed. Like, a lot
<BufferUnderpants>Version 2.0.7
<BufferUnderpants>Any ideas of what could be wrong?
<janneke>BufferUnderpants: it's prolly looking for guile-config
<janneke>try: apt-get install guile-2.0-dev
<BufferUnderpants>janneke: Hmmm... well, guile-config is installed as well
<BufferUnderpants>Or at least, I can run the command
<janneke>guile.pc then?
<janneke>how did you install guile?
<BufferUnderpants>Also, I had to build from source, because for some reason Fedora has refused to package Guile 2 despite it being out for years now
<janneke>have you checked if pkg-config can find guile-2.0.pc?
<BufferUnderpants>Hmmm... so I would have to do something with pkg-config?
<ijp>BufferUnderpants: guile 2 will be in the next release
<ijp>and the reason has been compatibility with existing guile-requiring packages
<ijp>(this is for fedora)
<janneke>BufferUnderpants: it all depends
<janneke>where and how did you install guile?
<janneke>if you use a non-standard, or non-pkg-config supported location
<janneke>you need to set PKG_CONFIG_PATH
<BufferUnderpants>ijp: great! good to know. Sorry if I was crass, but I sort of awaited it after seeing its progress
<janneke>BufferUnderpants: what are you building with guile-gnome?
<ijp>no problem. It's not like I did it :P
<BufferUnderpants>janneke: I was just fooling around, seeing what worked and what not, maybe build an RSS reader thang with it
*janneke goes off to bed -- have fun
<BufferUnderpants>Good night, then
<janneke>good luck
<BufferUnderpants>I'll try to have it