IRC channel logs

2013-05-10.log

back to list of logs

<fangism>anyone have a pointer to a patch/commit that fixes the texinfo-5 issues with guile-2.0.x?
<ijp>it is fixed in master and stable now I believe
<ijp>183d2ace576
<ijp>there have been texinfo patches since then, but that's the one that mentions fixing the build
<civodul>2.0.9 doesn't have the problem
<ijp>fangism: is there anything preventing you from running a more recent guile?
<fangism>ijp: 2.0.9 unfortunately crashed for me (abort trap) during documentation extraction, so I wanted to fix 2.0.7 first for users before tackling 2.0.9
<fangism>ijp: what's the appx date of that commit?
<fangism>2013-04-01 (Mark Weaver)?
<ijp>beginning of march or so, I thought
<ijp>Date: Fri Mar 1 17:49:24 2013 +0100
<fangism>found it
<ijp>if you had the repo, you could have just did git show $sha-fragment
<fangism>was using the gitweb interface, since I don't have a clone checked out
<aoi->k
<aoi->so if you builde guile, guile-dbi to install into /usr/local it just works
<aoi->you try to install it into another prefix, then the include paths fails to be updated =/
<aoi->at least guile-dbi builds now =)
<aoi->dsmith i got guile and guile-dbi to build now
<aoi->nalaginrut-left: now to get artanis built and installed =)
<aoi->nalaginrut-left:close to getting a running server now ...
<aoi->so close;
<aoi-> http://0.0.0.0:1234/
<aoi->artanis/artanis.scm:213:17: In procedure new-route-context:
<aoi->artanis/artanis.scm:213:17: In procedure module-lookup: Unbound variable: request-cookie
***nalaginrut-left is now known as nalaginrut
<nalaginrut>aoi-: oops, I've updated cookie module yesterday, and I didn't test it
<aoi->heh
<nalaginrut>well, should be request-cookies now
<nalaginrut>wait a minute
<nalaginrut>aoi-: there're some commits in my machine haven't pushed to github, so maybe some problems there. But it works fine in my machine ;-P
<nalaginrut>aoi-: please pull it
<aoi->ok
<aoi->\\o/
<aoi->no index.html but it works!
<nalaginrut>yes, that's default index.html
<nalaginrut>you may try blog2.scm
<nalaginrut>it's templated
<nalaginrut>oh, but build the database first
<aoi->nalaginrut: i guilt guile-dbi and guile-dbd-mysql etc, installed ok when put into default PREFIX
<aoi->s/guilt/built/
<nalaginrut>;-)
<aoi->now that its all built and running on my laptop, i can hack on it a bit over the next week
*aoi- will be on holiday, off to see my mother =)
<aoi->also lots of time spent on planes and busses
<aoi->laters
<nalaginrut>wingo: seems our parser don't like Etag (parse-entity-tag-list "2-518c9735-1000")
<nalaginrut>scheme@(web http)> (parse-qstring $20)
<nalaginrut>ERROR: Bad qstring header component: 2-518c9735-1000
<wingo>is it a valid etag?
<wingo>i think it needs to be enclosed in quotes
<nalaginrut>but it passed in from browser
<wingo>which browser?
<nalaginrut>I can't control that
<nalaginrut>chrome
<wingo>browsers should only give you the precise etag that you give them
<nalaginrut>yes, it's what I generated
<wingo>so usually the issue is that you gave them a bad etag to begin with
<nalaginrut>(define (generate-ETag filename)
<nalaginrut> (cond
<nalaginrut> ((file-exists? filename)
<nalaginrut> (let ((st (stat filename)))
<nalaginrut> `((Etag . ,(format #f "~X-~X-~X"
<nalaginrut> (stat:ino st) (stat:mtime st) (stat:size st))))))
<wingo>yep :)
<nalaginrut>that's my Etag generator, is it wrong?
<wingo>it is wrong, yes
<nalaginrut>oops
<wingo>i think anyway
<wingo>depends on how you write your headers
<wingo>if you use the guile http writers it should write the string with quotes
<nalaginrut>no I use build-response
<nalaginrut>`((content-type . (text/html) ,@(generate-Etag "file"))
<nalaginrut>for #:headers
<nalaginrut>wingo: so you mean my generator is incorrect? or my usage of web module is wrong?
<wingo>unmatched parens there
<nalaginrut>yup, but it's not the case ;-P
<wingo>nalaginrut: how do you write the response over the wire? do you use the http server?
<wingo>or do you use some other server
<nalaginrut>yes I use (web server)
<wingo>and so you use write-response
<wingo>or the server uses is
<wingo>*uses it
<wingo>humm
<nalaginrut>how can I improve my generator?
<wingo>telnet to your server and see if it is giving you an etag with quotes around it or not
<nalaginrut>well, that generator was borrowed from stackoverflow
<wingo>the algorithm is fine and it sounds like it should work
<wingo>ah
<wingo>nalaginrut: use `((etag . ...)
<wingo>instead of Etag
<nalaginrut>no ("Bad value for header ~a: ~s" (etag "56e300-516bb5c7-12fd"))
<wingo>early errors are better than late errors :)
<wingo> -- HTTP Header: ETag etag
<wingo> The entity-tag of the resource.
<wingo> (parse-header 'etag "\\"foo\\"")
<wingo> => ("foo" . #t)
<wingo>from the manual
<nalaginrut>I think the point is parse-qstring doesn't accept any string
<wingo>see the etag header type
<wingo>no that is not the point
<wingo>please read the parts of "HTTP Headers" in the manual that talk about etags
<nalaginrut>OK
<wingo>i use etags in tekuti fwiw
<wingo>and have no problems with any browsers that i know of
<wingo>though there is apache in front
<nalaginrut>OK thanks it's solved
<nalaginrut>`((Etag . ,(format #f "\\"~X-~X-~X\\""
<nalaginrut>that is the point
<nalaginrut>I think the point is that we have to keep the value of etag be quoted
<nalaginrut>hmm...I confess I didn't read the latest manual recently
<wingo>:)
<wingo>pretty sure all is working as intended
<wingo>use lower-case etag as the symbol.
*dsmith looks up etags ...
***dev- is now known as developernotes
<dsmith>sneek, macros?
<dsmith>sneek, macros is http://hipster.home.xs4all.nl/lib/scheme/gauche/define-syntax-primer.txt
<sneek>I'll keep that in mind.
<dsmith>sneek, macros?
<sneek>Someone once said macros is http://hipster.home.xs4all.nl/lib/scheme/gauche/define-syntax-primer.txt
<dsmith>sneek, macro-primer is http://hipster.home.xs4all.nl/lib/scheme/gauche/define-syntax-primer.txt
<sneek>So noted.
<dsmith>sneek, botsnack
<sneek>:)
***dev- is now known as developernotes
***sneek_ is now known as sneek
***MB is now known as Guest21872
<spacebat>I'm trying to build guile 2.0.9 but configure dies after a while a few errors starting with gl_FUNC_PIPE: command not found
<spacebat>that's not the error I got the first time I tried to build, so I tried make distclean but that seems to run configure and land at the same error
<spacebat>but git reckons the state of the working copy is clean
<wingo>if you made distclean then you will need to autoreconf -vif
<wingo>iiuc
<spacebat>thanks it does indeed seem to be getting me further
<spacebat>trying to build on debian wheezy - finally got around to installing gc-7.2
<dsmith>wingo, Just saw your mail on elf debugging & docstring stuff.
<dsmith>wingo, Nice
<dsmith>wingo, Is it going to be possible to link together .go files? Combining the various sections and maybe stripping out unreferenced bits?
<aoi->spacebat: install libgc1c2 and the -dev package
<dsmith>aoi-, That's the older version, isn't it?
<dsmith>sneek, libgc?
<spacebat>aoi-: I have and I understand it works for the most part, but I wanted to use the one called for by the build system, so I'm giving that a try
<sneek>libgc is http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-7.2d.tar.gz
<aoi->libgc1c2
<aoi->thats the debian wheezy package
<dsmith>Which is 7.1
<dsmith>7.2d fixes some things.
<wingo>dsmith: i think it will be possible, yes
<wingo>well
<wingo>so there are a few things to do there
<wingo>stripping out unreferenced bits won't happen -- that's really a function of the inliner and the optimizer
<wingo>but you might be able to package a number of compiled modules into one .go
<wingo>together with an entry script
<dsmith>Awesome
<wingo>and eventually possibly even compiling an executable that dynamically links to guile
<wingo>from scheme
<wingo>that would be the emacs use case
<dsmith>Very very cool
<spacebat>you mean loading guile as a shared lib, or
<spacebat>emacs is where I want guile
<dsmith>spacebat, Yes indeed!
<nalaginrut>hah~seems we have new cool features
<spacebat>this is taking a while to build :) might need to plug in before its done
<wingo>spacebat: you are building the stable-2.0 branch, yes?
<spacebat>no, master
<spacebat>oups I should switch branches?
<wingo>yep
<spacebat>well its built now, I might play with this one and start a rebuild before I sleep
***dn2k is now known as y0x2a
***y0x2a is now known as dn2k
<ijp>dsmith: I really wish people wouldn't refer to that primer
<mgsk>Gah! I have libpcre3 and libpcre3-dev -- is that not enough for regexp support? Manually compiling.
<waxysubs>mgsk: guile doesn't use pcre
<mark_weaver>mgsk: waxysubs is my logger, which I occasionally type into by mistake while looking over the logs.
<mark_weaver>mgsk: guile wants a posix regexp library, like regex
<ijp>huh, I wondered about name
<mark_weaver>mgsk: I confess I'm fuzzy on the details because I've never had a problem. what system are you running on?
<mark_weaver>I think the reason I've never had a problem is because the GNU C library contains everything that's needed, unless I'm mistaken.