IRC channel logs

2013-04-21.log

back to list of logs

<CaptainLex>Afternoon Guilers!
<dsmith>Hey hey
<CaptainLex>Evening Guilers
<mark_weaver>hi CaptainLex
<CaptainLex>Hello mark_weaver! How's things?
<mark_weaver>things are okay. you?
<CaptainLex>Same ol'
<LAMMJohnson>'evening, all.
<mark_weaver>hi LAMMJohnson
<LAMMJohnson>Can anybody recommend me a good guide to writing FFI extensions for guile?
<CaptainLex>hello LAMMJohnson!
<CaptainLex>I can't, but do want to greet you!
<LAMMJohnson>Friendly greetings almost as good in my books anyway.
<mark_weaver>well, there's the FFI section of the Guile manual. I don't know off hand of a tutorial.
<LAMMJohnson>I assumed manual. That's where I was going to go unless people had better recommendations.
<mark_weaver>also, don't hesitate to ask questions on #guile or the guile-user mailing list.
<mark_weaver>it might also be useful to look at the source code for some existing FFI wrapper, such as guile-sqlite3: https://gitorious.org/guile-sqlite3/guile-sqlite3/blobs/master/sqlite3.scm
<LAMMJohnson>OK, thanks. I'll be sure to say if I struggle with anything. The manual has been very good to me in the past, however.
<mark_weaver>okay, happy hacking!
<CaptainLex>What kind of project were you thinking?
<LAMMJohnson>mark_weaver: Cheers!
<LAMMJohnson>I didn't have anything in particular in mind. I've used guile to extend a few existing projects and I have a Scheme-loving friend constantly telling me I should strive to extend guile's FFI and work in that direction when possible.
<LAMMJohnson>I guess it would just be very nice to know I can wrap any arbitrary thing I like and work in delicious scheme in future.
<CaptainLex>Gotcha
<mark_weaver>The FFI is quite capable at this point. The hardest thing to deal with are complex C preprocessor macros.
<mark_weaver>Perhaps the most complex FFI wrapping effort so far is guile-figl, which can already do quite a lot. https://gitorious.org/guile-figl
<mark_weaver>there's not a single line of C code in guile-figl.
<micro__>
<CaptainLex>Morning Guilers!
<ijp>afternoon
<taylanub>I wonder, what is the relation between Guile's implementation of Elisp, and the current guilemacs implementation which embeds libguile into Emacs ?..
<CaptainLex>taylanub: I wonder this myself
<taylanub>Possibly there's some duplication of effort, although I'm guessing the two approaches will merge somehow ..
<dsmith>bipt, Care to clarify for taylanub ?
<wingo>evening
<ijp>evening
*wingo finally writing symbol tables in wip-rtl
<ijp>wonderful
<dsmith>wingo, Cool.
<wingo>heya civodul
<civodul>hey wingo
***davexuni` is now known as davexunit
<fbs>hmm
<CaptainLex>hmmmmmm
<fbs>ERROR: Throw to key `gnutls-error' with args `(#<gnutls-error-enum The Diffie-Hellman prime sent by the server is not acceptable (not long enough).> handshake)'
<fbs>:<
<civodul>never seen that one
<civodul>maybe there's a tweak to ask GnuTLS to be more lax?
<fbs>it should be set to 65536, could connect to a diff irc server where weechat usually bitches about the dhprime
<fbs>hmm guess i could read the weechat source and find out how they do it
<fbs>hmm
<civodul>dunno
<fbs>this is something
<fbs>*poof*
<fbs>,hello
<bot_122>hello master!
<fbs>civodul: lol In the client side it sets the minimum accepted number of bits. I
<fbs>weechat got me confused
<civodul>another Emacs crash
<civodul>this is annoying
<fbs>use a 'real' client?
<civodul>c'mon
<fbs>:p
<CaptainLex>Haha
<wingo>ok, symbol table now in rtl
<wingo>no way to access it at runtime yet tho :P
<wingo>but it is in the ELF now
<fbs>what does '->bool' do?
<fbs>(define (->bool x) (not (not x)))
<dsmith>wingo, What's the (rough) rtl timeline look like? What more need to happen
<dsmith>Aww
<fbs>:>
<fbs>i assume rtl isnt resistor transistor logic?
<dsmith>register transfer language, iirc
<fbs>ah