IRC channel logs

2025-04-05.log

back to list of logs

<stikonas>ok, the good news is that stage0-posix runs now
<stikonas>so it's just switch statement that needs fixing
<stikonas>deesix: ok, looks like LOAD_W16_AHEAD is indeed missing there
<stikonas>I'll re-add it
<stikonas>probalby there are more issues like you have said
<stikonas>gtker: so far I've pushed a fix for one issue that deesix noticed
<stikonas>but most of the test0031 testcases are still failing (though no longer in an infinite loop)
<matrix_bridge><gtker> Very cool. I've also discovered some issues with armv7l and will have a PR up for those in a minute. Currently armv7l hangs on 0015 for me
<matrix_bridge><gtker> I'll investigate armv7l further, are you looking at the aarch64 issues?
<stikonas>I was looking at aarch64, not right now, but maybe I'll still have more context
<stikonas>gtker: ok, the other place has the same aarch64 bug
<stikonas>and now the tests passes...
<stikonas>so I'll push it...
<matrix_bridge><gtker> Which other place?
<stikonas>it's just another missing LOAD_W16_AHEAD
<stikonas>in :default section
<stikonas>well, I can create a PR if you want to take a look
<matrix_bridge><gtker> Alright, cool. I've found one of the armv7l issues. Now it's segfaulting on test0020
<matrix_bridge><gtker> Sure. I'll keep making PRs even though I've got write access (unless it's a burden on you?)
<stikonas>gtker: it's just https://github.com/oriansj/M2-Planet/pull/124
<stikonas>yeah, sure, I want to keep track of changes at leats to some extent
<matrix_bridge><gtker> Ah, of course. It makes sense when you see them side by side 😄
<stikonas>hmm, can't add you as reviewer
<stikonas>for some reason
<stikonas>I thought it should be posible now since you have write access
<matrix_bridge><gtker> Might not have write access anyway. At least it says "gtker Approved these changes with read-only permissions"
<stikonas>yeah...
<stikonas>did you accept invite then?
<stikonas>or maybe oriansj hasn't sent it yet...
<matrix_bridge><gtker> Not that I recall? I didn't think you had to accept on github?
<stikonas>I think you do...
<stikonas>ok, I should also update stage0-posix. armv7l doesn't matter there anyway
<matrix_bridge><gtker> Opened a PR with the armv7l fix in case you wanted it in anyway
<stikonas>sure, let's get it in
<stikonas>well, stage0-posix doesn't have armv7l support but let's pull it in
<stikonas>so armv7l now works?
<stikonas>or are there other test failures?
<matrix_bridge><gtker> Fails on test0020 with a segfault
<matrix_bridge><gtker> Although to be fair it seems even 0036 segfaults in Release_1.11.0, which was before I had a chance to mess things up 😄
<matrix_bridge><gtker> on the Release_1.11.0 tag*
<stikonas>well, armv7l is far less tested than other arches
<stikonas>well, maybe similar to knight...
<stikonas>stage0-posix supports aarch64, x86, amd64 and riscv32/64
<stikonas>so those are far more tested
<stikonas>personally I no longer have any armv7l hardware either
<matrix_bridge><gtker> I don't believe I have any either. When did the raspberry pis change to armv8?
<stikonas>hmm, maybe 4?
<stikonas>I used to have odroid-u2 sometime ago but later power supply broke off...
<stikonas>anyway, I just ran tests on aarch64 and riscv64 hardware and they all pass
<matrix_bridge><gtker> I'll investigate the armv7l stuff then, but might do some feature stuff if it isn't super critical
<stikonas>yeah. armv7l is not super critical...
<stikonas>given that other arches work well now, I think we have stabilized everything enough
<stikonas>argh, actually my riscv64 final test got wrong checksum...
<stikonas>hmm
<stikonas>maybe I just forgot to update it
<stikonas>oh, that was a conflict between your and my changes
<matrix_bridge><gtker> Ah yeah, I probably forgot to update the checksum, oops
<matrix_bridge><gtker> stikonas: Got all tests passing for armv7l. It was likely some swapped parameters in the huge if blocks of code generation before we did the emit_ functions that caused it to segfault in 1.11.0
<oriansj>gtker: you should have the invite for M2-Planet collaborator
<matrix_bridge><gtker> oriansj: Thanks
<oriansj>I used the jetbrains@gtker.com email address that github provided for you account
<matrix_bridge><gtker> That's fine, I have received the request 😄
<matrix_bridge><cosinusoidally> fwiw every rpi above the rpi1 can run armv7 code (at least in userspace)
<stikonas>oh yes, my rockpro64 can also run armv7 code
<stikonas>but visionfive2 can't run riscv32 code...
<stikonas>gtker: I'll probably look at tokenizing : separately
<stikonas>I've got labels to work now
<stikonas>just need to undo all those hacks in switches
<stikonas>lucklily we have a fairly good test coverage now