IRC channel logs

2025-03-11.log

back to list of logs

<stikonas>yeah, endianess was my worry too
<stikonas>I haven't tested it yet but yes, % is little endian
<stikonas>well, for NULL's it doesn't matter
<stikonas>it's filled with zeroes anyway
<matrix_bridge><gtker> stikonas: (Regarding outputting 'DE AD BE EF' as raw bytes) That makes sense. I'll probably change it to that in the future. I've realized that if I want a single function for parsing initializer lists I can't just output a byte array since some structures can be initialized from e.g. pointers or expressions containing non-constant values. It'll probably be a gradual process where I figure out exactly how to...
<matrix_bridge>... do things
<matrix_bridge><gtker> stikonas: (Regarding endianness) I don't think M2 supports big endian archs right now but I also very much doubt that much software further down the chain supports BE archs
<matrix_bridge><gtker> IMO supporting BE when we don't have an arch that explicitly requires it is a waste of time and complexity. Worst case I don't think retrofitting it if a relevant arch shows up will be that difficult
<fossy>imo, depends on the complexity added
<fossy>if it is significant, then agreed
<fossy>i suspect mes & tcc have no/minimal BE support though
<fossy>but anyways, i think the main relevant archs in 2025 are x86, amd64, riscv64, amd64, and perhaps ppc64 and loongarch
<fossy>none of which are big-endian
<fossy>(technically, ppc64 is typically biendian)
<lanodan>Yeah even as one that has sparc64 (bi-endian but IIRC still big-endian for instructions) and ppc32 (biendian, typically set to LE though) machines, it's pretty reasonable to exclude big-endian from M2 / live-bootstrap.
<fossy>sparc64 machines are not very important for bootstrapping imho, and ppc32 only interesting hardware is the old macs, which are problematic for other reasons
<lanodan>That and probably more interesting to support machines you can still easily buy either first hand or second hand, sparc64 machines are rare and ppc32 is well… probably considered retro and so can get expensive to get.
<fossy> https://github.com/microsoft/typescript-go -- typescript effectively becoming bootstrappable :)
<stikonas>nice
<stikonas>well, typescript is not that dissimilar to javascript anyway
<stikonas>so bootstrapping shouldn't be too hard
<stikonas>given that we have a lot of javascript engines
<fossy>hmm, typescript is a superset of javascript, typescript compiles to javascript....
<fossy>previous typescript compiler was written in typescript
<jackdk>Didn't Fabrice write a tiny JS engine at one point? https://www.bellard.org/quickjs/ ts->js via go
<jackdk>+ js on quickjs is probably quite bootstrappable