IRC channel logs

2025-01-26.log

back to list of logs

<mihi>homo, portable Makefile. Hmm. Yes, today it is quite easy, as there are not too many C compilers that do not follow standards (basically I have not seen anything other than gcc, clang, msvc and tinycc to be used lately). Still I am curious if you can write a portable Makefile that does automatic include tracking and works with gcc, clang and possibly MSVC.
<mihi>e.g. you have main.c, util.c and core.c which include an unknown and changing number of .h files. Compile each individually and then link the result. Rebuild should only rebuild the needed parts.
<mihi>but you have to take into account that those projects are quite old, and at that time standard header files were not as standardized as they are today.
<stikonas>oriansj: good news from gtker: https://github.com/oriansj/M2-Planet/pull/66
<stikonas>though probably will need some fixes before it properly works
<stikonas>(gtker haven't tested on non-x86 arches)
<panorain>hi
<stikonas>rkeene: hi, I've noticed that mescc-tools-extra fails to build untar...
<stikonas>when building with GCC...
<stikonas>untar.c:268:47: error: implicit declaration of function ‘symlink’ [-Wimplicit-function-declaration]
<stikonas>we might need to include something
<stikonas>janneke: hi
<stikonas>just wanted to give you some advance notice that M2-Planet's pointer arithmetic might be fixed soon
<stikonas> https://github.com/oriansj/M2-Planet/pull/66
<stikonas>so likely we'll need to undo some #ifdef __M2__ hacks in mes