IRC channel logs

2024-10-03.log

back to list of logs

<oriansj>I really should add SET to mescc-tools-extra as a default text editor (as right now the end state doesn't include any editors)
<oriansj>(unless someone thinks I should do an ed port ??)
<nikolar>ed is the standard editor after all
<oriansj>nikolar: fair
<nikolar>i imagine more people are familiar with ed
<pabs3>from #reproducible-builds <kpcyrd> there's a new javascript runtime written in Zig called `bun` that unfortunately needs a compiled binary of itself to build https://github.com/oven-sh/bun/issues/6887
<oriansj>pabs3: I'm not saying people suck but this is getting crazy.
<Googulator>oriansj: which one is easier to use for auditing purposes, SET or ed?
<Googulator>pabs3: please tell me it's not built from source code named "dough"
<oriansj>well SET.c 311 lines of C code and ed is about 2,508 lines of C code; they both can print lines of text so reading code ed is a little easier but writing code it would be a bunch better.
<oriansj>ed also requires a regex library and has some pretty ugly macros for disabling interrupts in its code.
<Googulator>ouch
<Googulator>my idea is to optionally break into an interactive(-ish) shell as soon as it's possible, and give the user a chance to review source code before proceeding to compile it - before the compiled code has a chance to subvert attempts to review its source
<Googulator>anything before that point (where the interactive shell can be spawned) will need to be automatically printed to console when the FS is being loaded (I have a prototype for this in builder-hex0), but that means, ideally, we need to minimize the amount of source code needed to compile this first shell
<oriansj>well reviewing code can be done with a more/less clone which would only be about 100 lines of C code
<oriansj>combine with sha256sum (which we already have); you gain the ability to using a large body of humans do an effective source code review and cheaply hash to know the code is good
<lanodan>I guess QED instead of ed(1) wouldn't have the regexes and it doesn't seems like ed from BusyBox supports regexes. (it's sed also doesn't for addresses…)
<ismael>sc/23
<oriansj>ismael: well I hear they have reproducibility talks (assuming you are referring to the conference)
<oriansj>lanodan: well I found a qed which is only 1319 lines of code. (Could possibly trim that down a little)
<oriansj>well, I just got nerd sniped by dercuano's bytecode interpreters for tiny computers into the smallest possible vm I could make which would have all of the functionality required to self-host and bootstrap GCC
<nikolar>link?
<oriansj> https://dercuano.github.io/notes/tiny-interpreters-for-microcontrollers.html
<oriansj>well worth mirroring the whole set: git clone https://gitlab.com/kragen/dercuano.git
<nikolar>interesting