IRC channel logs

2024-09-06.log

back to list of logs

<kerravon>hi guys. i was on here a year ago or something and i asked about switches
<kerravon>there used to be computers like this:
<kerravon> https://en.wikipedia.org/wiki/Altair_8800
<kerravon>and i was wondering if they could still be bought new - and the answer was that there were no new computers like that
<kerravon>but i asked someone else recently and they said that i could do this:
<kerravon> https://www.electronicsforu.com/electronics-projects/manual-eprom-programmer
<kerravon>program an EPROM via switches and then use that to access a CF card in the Book 8088
<kerravon>the thing is, this guy:
<kerravon> https://bootstrapping.miraheze.org/wiki/Stage0
<kerravon>says:
<kerravon>"A sub 500 byte hex monitor [How you create it is up to you; I like toggling it in manually myself]"
<kerravon>as if it is normal to have access to toggle switches
<kerravon>but it isn't - you can't buy such a machine new
<kerravon>even the eprom programmer above can't be bought new, but that's the closest thing we have to something buyable new
<lanodan>Also entering ~500 bytes without any mistakes seems… strange, I think I'd rather have something like hex0 on an 8-bit computer so it's words instead, easier to check and batch.
<oriansj>kerravon: it feels normal to me (but I might just be weird). But if you notice the programming circuit in the URL you linked isn't for buying but for making yourself using a voltage regulator and a 555 clock IC (which you could replace with something else).
<oriansj>You even can make your own 555 https://hackaday.com/2021/12/20/all-hail-your-new-giant-555-timer-overlord/ https://www.instructables.com/Working-MEGA-555/
<oriansj>lanodan: well the idea is anyone should be empowered to make their root of trust anyway that they want using any architecture, method or way that they want.
<oriansj>If you want to toggle words or bytes or bits; fine no problem.
<oriansj>If you want to use a reel of punched paper or metal tape, also cool.
<oriansj>If punch cards hold your fancy, go for it
<oriansj>If you trust a floppy disk, go forth and use what you trust.
<lanodan>Yup just can't really see doing ~500 toggles without any mistakes, while yeah something some sort of automation of that with punched cards makes sense, and in fact makes me wonder if it somehow could be used today specially on x86. (I think on sparc/macppc/some-riscv/… you could use raw serial or ZMODEM to send bytes)
<lanodan>At least problem I see on x86 is ending up with extra software in your custom boot device (which would also need an EPROM) that is several times bigger than 500 bytes and could very well swap some bytes.
<oriansj>lanodan: well if you are programming an eeprom with toggles, you can make mistakes and just change the bytes that are wrong.
<lanodan>Ah yeah right
<oriansj>but yes, putting the source code onto the media is a much bigger problem
<oriansj>but that is why we have sha256sum in mescc-tools-extra
<oriansj>and tools like SET, SIN and MORE can be used to audit the source code; while also being something you could implement in hex0 if you wanted.
<oriansj>and if doing an EEPROM, there is no firmware in the system except what you put in the EEPROM (aka, you'll have to include your own BIOS routines which will be far larger than your hex0 monitor)