IRC channel logs

2024-08-05.log

back to list of logs

<aggi>good morning
<aggi>for mentioned reasons i am forced to move the c-only/no-c++ profile to static linking, which i keep tracking with gentoo-portage tooling currently
<aggi>a principle issue with static-linking seems, there is no reliable option to _force_ static linking, with various tooling involved: autoconf/automake/(s)libtool and various other plain Makefiles
<aggi>export (AM_)LDFLAGS=-static and similar do cover several hundred ebuilds emitting static libs/binaries, some ebuilds ignore -static, and ~100 ebuilds break when passing -static flag
<aggi>and some ebuilds are problematic to cope with, such as util-linux
<aggi>anyway, was there any and if, what's the best approach to enforce static linking with autootools/automake/slibtool?
<aggi>there is rather many configure.ac/makefile.am/libtool stuff which are driving me mad
<aggi>although i am willing to repair the entire portage tree overlay (~400ebuilds already), to verify static-linking works
<mid-kid>So I recently upgraded from a linux-msft-wsl-6.1.y kernel to linux-msft-wsl-6.6.y
<mid-kid>With the previous kernel the chroot bootstrap broke on some "mv something/*/*/*.thing"
<mid-kid>I assume because of the asterisks
<mid-kid>said file not found
<mid-kid>Now it seems to be proceeding without issue
<mid-kid>I wonder: This issue has persisted since last winter
<mid-kid>Has anyone else encountered issues doing the early chroot bootstrap on older kernels, or would this more likely be a WSL bug?
<lanodan>This works fine on a 6.1.53 musl+linux machine I have around (yeah I should update it): mkdir -p foo/bar/baz/ ; touch foo/bar/baz/hello.thing ; mv foo/*/*/*.thing thingy
<Googulator>Known issue: https://github.com/fosslinux/live-bootstrap/issues/379
<Googulator>It's a bug in the early Bash build, and it has to do with the handwritten makefile
<mid-kid>I see
<mid-kid>Yeah I was wondering if this issue was visible in mainline linux kernels as well
<mid-kid>or if it was just wsl
<mid-kid>lanodan: this issue only happens with some of the tools in live-bootstrap, not in general.
<mid-kid>wildcards in bash were solved aeons ago lol
<mid-kid>I might go and debug this soonish
<mid-kid>though it's less of an issue now you can simply use a newer kernel
<Googulator>mid-kid: it's a bit weird - the wrong behavior can be elicited from the buggy Bash on any linux kernel if you run it outside a chroot
<Googulator>but somehow inside a chroot, it behaves well - except in WSL, and apparently in a few obscure distros
<Googulator>My theory is that it depends on some Kconfig option
<mid-kid>oh!
<mid-kid>that's interesting info actually
<mid-kid>I'd compare the config.h between a makefile build and an autoconf build
<mid-kid>or idk how the makefile build sets the compiler defines
<mid-kid>It could also very well be about a difference in /dev layout
<mid-kid>ah yeah it's the COMMON_CFLAGS