IRC channel logs

2024-01-18.log

back to list of logs

<stikonas>lrvick: what are you configure options?
<stikonas>lrvick: at least from the long it seems it thinks it's running on x86_64-pc-linux-musl host
<stikonas>but you need both build and host to be 32-bits
<stikonas>and target to be 64-bits
<stikonas>x86_64-pc-linux-muslx32 is not good tripple I think
<stikonas>it will think that it's 64-bit
<lrvick>Ah, it actually failed in libgcc. Was looking at the wrong config.log. https://dpaste.org/btsCX
<lrvick>but yeah let me hardcode --build and --host and see what happens
<lrvick>it has at least lasted longer so far!
<lrvick>nope, was too optimistic on time. Still only made it back to libgcc. It is seemingly ignoring --host and --build even after a distclean and reconfigure. https://dpaste.org/2wprA
<lrvick>made it a bit further. Now failing at missing pthread
<lrvick> https://dpaste.org/3ouyr
<matrix_bridge><Andrius Štikonas> Just disable threads
<matrix_bridge><Andrius Štikonas> And other optional thongs during configure
<lrvick>it is not fully clear what is and is not optinoal, but trying to disable threads now...
<matrix_bridge><Andrius Štikonas> Probably --disable-threads
<matrix_bridge><Andrius Štikonas> See https://www.linuxfromscratch.org/lfs/view/development/chapter05/gcc-pass1.html too for what should be disabled
<Googulator>pder: so simply enabling CONFIG_QEMU_DEBUGCON somehow makes it work?
<Googulator>also, do you see the line "QEMU Bochs-style debug console emulation enabled" printed?
<pder>Googulator: no I don't see that line. I searched my tmux scrollback buffer
<lrvick>Okay disabled everything I think I can and got further
<lrvick>new problem: #8 653.3 /bin/sh: line 8: x86_64-linux-musl-ar: command not found
<lrvick>I had the same problem with "as" and got around it with "--with-as=/usr/sbin/as" but there does not appear to be a "--with-ar"
<Mikaku>pder: if you enabled CONFIG_QEMU_DEBUGCON you definitely must see the line "QEMU Bochs-style debug console emulation enabled" during the kernel boot up
<lrvick>lets see if I can symlink around this...
<pder> if(kstat.flags & KF_HAS_DEBUGCON) {
<pder> printk("\t\t\t\tQEMU Bochs-style debug console emulation enabled\n");
<pder> }
<pder>Mikaku: the only change I made was to change line in include/fiwix/config.h to #define CONFIG_QEMU_DEBUGCON
<pder>I did not change any qemu parameters for this test
<pder>Perhaps that if condition is not true for some other reason?
<Mikaku>pder: ah, you're right, you need to include the specific parameter to QEMU