IRC channel logs

2024-01-11.log

back to list of logs

<rickmasters>OK reproduced checksum fail for python 3.1.5 using latest live-bootstrap. The python versions before that were OK.
<Googulator>One way you can speed up testing Python issues is by commenting out guile and everything else until Python
<Googulator>Guile & Autogen are AFAIK only needed for GCC 10+
<rickmasters>Thanks. Just passed python 3.1.5 with Fiwix update with success.
<rickmasters>I'll continue testing to find the revision that python 3.1.5 first fails on.
<Googulator>I've done a test myself to revert the Fiwix upgrade - Python checksums are still wrong, matching the ones with the new Fiwix.
<jenntech23>hoping someone can help me figure out why my product image on the image after clicking a product is so small? Im trying to stretch it to the container... https://demandrights.pythonanywhere.com/product/security-agreement/
<muurkha>can you provide context?
<fossy>jenntech23: i think you are very much in the wrong channel.
<muurkha>well, perhaps they are in the right channel but sent that message to the wrong one, or perhaps there's some meaning I haven't deciphered
<fossy>perhaps
<Googulator>rekado: yale-haskell is failing in exactly the same way in clisp 2.49, the last proper release from 2010
<Googulator>by any chance, do you remember what version you used in 2016?
<matrix_bridge><cosinusoidally> Raised a PR to optionally allow the use of my alternative tcc bootstrap path https://github.com/fosslinux/live-bootstrap/pull/407 . It's not in a fully mergable state yet, but it should be useful for review. It takes around 10 mins of pass1.
<matrix_bridge><cosinusoidally> * mergeable
<fossy>ooh, thank you!
<stikonas>hopefully no pregenerated files there :)
<fossy>cosiunsoidally: wow, this is surprisingly a fairly simple PR. I was expecting a lot more hacks to be required with mes libc!
<stikonas>well, I guess a lot is hidden inside tcc-bootstrap-alt repo
<fossy>yeah
<fossy>what libc is tcc itself compiled against?
<stikonas>and checksums are still disabled...
<stikonas>probably libc from tcc-bootstrap-alt?
<stikonas> https://github.com/cosinusoidally/tcc_bootstrap_alt/tree/master/woody/usr/include
<stikonas>libc from debian woody I guess
<fossy>that's only headers though... not any actual code
<stikonas>hmm, yes
<matrix_bridge><cosinusoidally> yep woody headers (which are fairly big). It can use the in tree polyfill libc or glibc, it's just a case of linking the object code to the desired one.
<matrix_bridge><cosinusoidally> There are lots of headers I should probably strip out.
<matrix_bridge><cosinusoidally> Checksums are disabled for mes (since it's not built) and tcc-0.9.26 (since for some reason they don't match). By the time it gets to the live-bootstrap tcc-0.9.27 the checksums are the same again.
<matrix_bridge><cosinusoidally> During the bootstrap I use the polyfill libc obviously.
<fossy>ahhhh
<fossy>is the polyfill libc in M2libc directory?
<fossy>(in tcc_bootstrap_alt repo)
<matrix_bridge><cosinusoidally> There are several polyfill libcs and they are a bit spread out/overlapping. I think my next step is probably a bit of writing documentation for the process.
<matrix_bridge><cosinusoidally> eg https://github.com/cosinusoidally/tcc_bootstrap_alt/blob/master/tcc_27/libc_boot4.c is one of the libc polyfills
<matrix_bridge><cosinusoidally> and https://github.com/cosinusoidally/tcc_bootstrap_alt/blob/master/tcc_js/elf_loader_support_cc_x86.c
<matrix_bridge><cosinusoidally> and https://github.com/cosinusoidally/tcc_bootstrap_alt/blob/master/tcc_10/libc_boot.c
<matrix_bridge><cosinusoidally> etc etc etc
<fossy>okayyyy
<matrix_bridge><cosinusoidally> I also need to cut them down and deduplicate.
<matrix_bridge><cosinusoidally> libc_boot.c is the first elf version of libc used by the first elf version of tcc.
<matrix_bridge><cosinusoidally> The elf version of tcc will also call across to elf_loader_support_cc_x86.c (and then to some of the stuff in M2libc for certain low level stuff/syscalls)
<fossy>regarding the PR itself, looks fairly sensible to me. there will need to be checksums done though
<fossy>it would also be nice if the tcc_bootstrap & mes paths produced the same tcc binary at the end. i feel like that should be possible - and could already be the case - but then again, maybe not
<matrix_bridge><cosinusoidally> I'm guessing it's probably some missing define somewhere. the 0.9.27 binary is identical, just not the 0.9.26 one. live-bootstrap ci checks all the checksums by default? If so, all the hashes after 0.9.26 are correct.
<rickmasters>cosinusoidally: regarding: cp artifacts/tcc_27_boot_static.exe /usr/bin/tcc-boot0
<rickmasters>where does artifacts/tcc_27_boot_static.exe come from?
<fossy>tcc_bootstrap_alt-0.1 should have checksums. also, past here, https://github.com/fosslinux/live-bootstrap/pull/407/files#diff-cc6e390ef115302dcd339b5d634107e16ad985d974300ad2b51732aa948a7484R385, there is no checksum generation/validation for TCC_BOOTSTRAP_ALT=True, as both branches match it to False
<fossy>so currently tcc_bootstrap_alt mode is not protected by checksums
<rickmasters>oh nevermind, I haven't looked at the new alt sources
<rickmasters>the builds steps for tcc_27_boot_static.exe must be in there (?)
<fossy>yeah
<stikonas>it might be that we need to do more rebuilds for them to produce same binary...
<stikonas>right now mes path has the minimum number of rebuilds until checksum stabilizes
<stikonas>which is just tcc-mes, tcc-boot0 tcc-boot1 and final tcc
<matrix_bridge><cosinusoidally> rickmasters: https://github.com/cosinusoidally/tcc_bootstrap_alt/blob/master/tcc_27/run_27_static.kaem#L22
<stikonas>and also version of tcc 0.9.26 is a bit confusing, it's much closer to 0.9.27...
<rickmasters>cosinusoidally: thanks. there is ... a lot more phases there than I was expecting. wow
<matrix_bridge><cosinusoidally> fossy: ah I see, I didn't check the sha sums for tcc_bootstrap_alt in its pass1.kaem. I can add that in. Would that just be the sha256sum for tcc_27_boot_static.exe / /usr/bin/tcc-boot0 .
<matrix_bridge>Just going to check if the sha256sums for the live-bootstrap version of "tcc-0.9.26" differ.
<rickmasters>fossy: next problem with --kernel is that mkdir and mount of /proc before kexec were left out of the simplify overhaul.
<rickmasters>fossy: kexec needs to read /proc/iomem
<rickmasters>fossy: can you remember if there was any reason to remove the /proc stuff?
<rickmasters>fossy: I can provide a PR for that. Unfortunately, there are checksum issues with tar-1.34 later on. So --kernel still won't be working yet.
<fossy>yes cosinusoidally, that is correct
<fossy>rickmasters: oh, mount of /proc is done in populate_device_nodes. (probably hsould change the name of that script). anyways a improve: populate_device_nodes should be added between build: util-linux-2.19.1 and jump: linux
<fossy>to fix that
<rickmasters>fossy: ok, is right before linux ok? I'll test it first...
<rickmasters>*right before jump: linux ?
<fossy>anywhere between
<fossy>right before linux should be ok
<matrix_bridge><cosinusoidally> https://github.com/cosinusoidally/live-bootstrap/actions/runs/7494979437/job/20404096073#step:7:66572 interesting, /usr/bin/tcc* have the wrong hash in my branch for LB tcc "0.9.26" but the mes libc and libtcc1.a are right. I suspect a rebuilt of 0.9.26 with itself may make it converge.
<fossy>yes, i suspect similarly