IRC channel logs

2024-01-06.log

back to list of logs

<stikonas>well, it works if I do if (1) there
<stikonas>(as expected at this stage)
<stikonas>oh, maybe unlink doesn't work if file is open in read only mode
<stikonas>that would make sense
<stikonas>oriansj: that's it!
<stikonas>works ow
<stikonas>works ow
<stikonas>now
<stikonas>it was two bugs cancelling each other out
<stikonas>so the other bug was here https://github.com/oriansj/M2libc/blob/80d32745dcab5b21683ed3e79e943b158397c224/uefi/unistd.c#L281
<stikonas>which was doing "w" before due to flag == O_WRONLY|O_CREAT|O_TRUNC being true
<stikonas>oriansj: https://github.com/oriansj/M2libc/pull/53
<stikonas>if you don't mind, I would prefer 2 separate commits / PRs
<stikonas>first is just fixing that bug
<stikonas>but I haven't added any acess implementation
<stikonas>will look at that later
<stikonas>we shouldn't mix it up with bugfix anyway
<stikonas>ok, got access() working too
<stikonas>and now I can run mes --help and mes --version
<stikonas>mes without arguments seems to start but as expected does not accept any input (stdin is not implemented in M2libc/uefi)
<oriansj>stikonas: good work
<stikonas>well, you helped today
<stikonas>oh I also kind of accidentally pushed M1 defines that posix-runner needs
<stikonas>but I guess it's ok
<stikonas>even if it's not a final list, we can update it
<muurkha>I just realized that SeRV is the same size as a MuP21 or a Z80: https://github.com/olofk/serv
<muurkha>2.1 CMOS gate equivalents is roughly 8400 transistors
<muurkha>the Z80 is 8500, the MuP21 is 7500. Calculus Vaporis would be about 4000 and is probably faster than SERV but more of a pain to program
<oriansj>muurkha: yeah, the minimal bedrock hardware is approaching something one might be able to make at home
<muurkha>Konrad Zuse did 80 years ago
<muurkha>gotta get the RAM requirements down tho
<fossy>Piraty: heh, nope, i did not use abi-dumper at all in live-bootstrap :)
<oriansj>muurkha: or improve the at home transistor yield. As one can get quite far with 1MB of RAM.
<stikonas>yeah, abi-dumper is not useful for live-bootstrap
<stikonas>I've used it before for other things
<stikonas>but live-bootstrap mostly builds things statically anyway
<stikonas>so you can't break existing binaries by upgrading some library
<stikonas>and I guess in general abi-dumper is more useful for application developers than distro maintainers
<pabs3>we have talked about using it in Debian to block testing migration on ABI breakage
<rickmasters>Mikaku has merged the final outstanding live-bootstrap related PR into upstream Fiwix!
<Mikaku>yeah!, we did it! :-)
<rickmasters>It took 27 PRs that I dragged out over a year but we finally did it!
<rickmasters>Mikaku has released a source tarball that can now be directly pulled into live-bootstrap: https://github.com/mikaku/Fiwix/releases/tag/v1.5.0-lb1
<rickmasters>I am working on a PR for live-bootstrap to pull from there, as well as adopt necessary changes to the build process.
<muurkha>fantastic!
<muurkha>oriansj: you don't need anywhere close to 1MB of RAM if you have tape or disk
<muurkha>but Zuse's Z3 had 64 words of RAM, which is likely not enough
<euleritian>Mikaku: rickmasters: Congratulations! That sounds wonderful!
<rickmasters>euleritian: thanks!
<stikonas>rickmasters: congratulations too!
<rickmasters>stikonas: Thanks! Also, Issue and PR was just submitted to live-bootstrap to pull from upstream.
<rickmasters>Looks like I need to add some license declarations...