IRC channel logs

2023-11-19.log

back to list of logs

<stikonas>fossy: https://github.com/fosslinux/live-bootstrap/pull/333
<stikonas>(cc ekaitz)
<ekaitz>lol go to sleep
<ekaitz>stikonas: (y)
<stikonas>yes, going now
<stikonas>though it's later for you...
<ekaitz>i'm reading a very interesting book
<ekaitz>(crafting interpreters)
<stikonas>kicked off riscv64 native run too on this commit
<stikonas>but it will take another week...
<ekaitz>alright
<ekaitz>we'll see
<ekaitz>we need to plan what to do next
<Googulator>Mikaku: looks like Fiwix has a small bug related to handling disk full errors
<Googulator>...
<Googulator>interation 203
<Googulator>iteration done
<Googulator>interation 204
<Googulator>iteration done
<Googulator>interation 205
<Googulator>ramdisk_read(): block 2621312 is beyond the size of the ramdisk.
<Googulator>WARNING: bread(): returning NULL!
<Googulator>WARNING: ext2_bfree(): invalid block 2621312!
<Googulator>cat: write error: I/O error
<Googulator>afterwards, it recovers and actually reports "No space left on device"
<Googulator>But the first write that would overrun the disk yields I/O error instead
<Googulator>oriansj: yes, xz would provide even more compression... but good luck implementing LZMA decompression in any kind of trivial/bootstrap-friendly language
<Googulator>LZMA is notoriously difficult to bootstrap
<matrix_bridge><Andrius Štikonas> Googulator: Simple C is bootstrap friendly, just need to simplify it for M2-Planet
<sam_>yeah the notoriously difficult thing sounds very wrong to me
<oriansj>Googulator: notoriously difficult to bootstrap, sounds like a fun to solve problem.
<oriansj>and we certainly already solved a good few of those together.
<sam_>:D
<stikonas>yeah, I don't think xz is that hard to bootstrap. I've heard that too, but e.g. in live-bootstrap (though much later) we had no issue bootstrapping xz
<stikonas>oriansj: O
<stikonas>oriansj: I've now removed VPATH from M2-Planet makefiles
<stikonas>might be good if you can review them
<stikonas>but I think now they work better
<stikonas>e.g. make clean all test DESTDIR=xyz install now works
<oriansj>thank you stikonas
<oriansj>found two missing details but fixed those but great work
<stikonas>oh yes, those are good to have too
<oriansj>and I am guessing probably something similiar needs to be done to mescc-tools
<stikonas>yes, that also fails...
<stikonas>not sure why vagrantc didn't complain about it
<stikonas>probably he had already separated make and make install targets there
<stikonas>hmm, I'm getting some linker error if I make the same change
<stikonas>gcc -D_GNU_SOURCE -std=c99 -ggdb -fno-common hex2.c bin/hex2 -o hex2
<stikonas>/usr/lib/gcc/x86_64-pc-linux-gnu/13/../../../../x86_64-pc-linux-gnu/bin/ld: bin/hex2: stdout: invalid version 3 (max 0)
<oriansj>well you made a typo
<oriansj>the bin/hex2 comes after the -o
<oriansj>gcc was trying to link the binary with itself
<stikonas>hmm, I still can't see the typo :(
<stikonas>this is my word-diff: https://paste.debian.net/1298578/
<stikonas>oh, it actually compiled it and then tried to rebuild it again...
<stikonas>something is wrong elsewhere
<stikonas>oriansj: we have another bug
<stikonas>including in M2-Planet makefile
<stikonas>in your last commit, where you added M2-Planet: target, we still need to add it to .PHONY
<stikonas>I've now pushed mescc-tools commit
<stikonas>ok, pushed fix to M2-Planet too
<oriansj>thank you for catching that
<stikonas>hmm, I should also fix kaem makefile...
<stikonas>ok, pushed
<stikonas>and mescc-tools-extra has the same issue...
<Mikaku>Googulator: I've been testing 'cat /dev/zero > /dev/ram0' and I get 'cat: write error: No space left on device' all the time
<Mikaku>Googulator: can you tell me the exact command I need to reproduce your scenario?
<efraim>mescc-tools-1.5 and m2-planet-1.11 both build on powerpc-linux
<Googulator>Mikaku: it's reproducible with this patch: https://gist.github.com/Googulator/ae3fa19bcbe281b482f7fd2949054947 on top of https://github.com/Googulator/live-bootstrap/tree/playground
<Googulator>    ls -l /boot/fiwix
<Googulator>    for i in $(seq 1 1000)
<Googulator>    do
<Googulator>        echo "interation $i"
<Googulator>        cat /boot/fiwix >> /boot/wifix || break
<Googulator>        echo "iteration done"
<Googulator>    done
<Googulator>    ls -l /boot/wifix
<Googulator>this is the relevant code that triggers it
<Googulator> https://gist.github.com/Googulator/ae3fa19bcbe281b482f7fd2949054947/ed20e70f95b91b4653e911beeb33b71e950252c2 this patch actually
<Googulator>the one I first linked already had this code removed, since it was only something I was testing
<Googulator>(to see how much space is left over in the initrd after the Linux build)
<Googulator>of course, it could be related to some of the live-bootstrap-specific patches
<Mikaku>Googulator: I've just tested: ' mkfs.ext2 -m 0 -r 0 /dev/ram0 ; mount -t ext2 /dev/ram0 /mnt/disk ; while true ; do cat /boot/fiwix >> /mnt/disk/fiwix || break ; done' and I get the same 'cat: write error: No space left on device' all the time
<Mikaku>Googulator: you might want to test it in the latest FiwixOS 3.3 disk image <https://www.fiwix.org/FiwixOS-3.3-i386.raw.gz>