IRC channel logs

2023-11-08.log

back to list of logs

<oriansj>I have an idea for getting switch statements into M2-Planet
<oriansj>it will be a little ugly and not the most efficient.
<stikonas>oriansj: ?
<oriansj>jump over the case statements, basically dump the case statements in order and then recursively populate the cmp/je bits for all of the cases and a label for after the switch closes };
<oriansj>so case 11: case 12: case 13: return foo; just becomes :label_case_12 :label_case_13 :label_case_11 (regular return foo logic)
<stikonas>and break will jump to that last label?
<stikonas>or not allowed?
<stikonas>I guess we only need to reinstate enough switch in mes.c
<stikonas>so doesn't have to support everything in the world anyway
<oriansj>indeed
<oriansj>and we don't need nested switch statement suport either