IRC channel logs

2023-10-27.log

back to list of logs

<muurkha>oriansj: 01997? I think this was 01977
<muurkha>or a bit earlier
<oriansj>muurkha: that was the year the source code (nih.a) was given to Warren Toomey (curator of the TUHS archive)
<oriansj>via Dennis Ritchie's collection of old tape images
<muurkha>haha
<matrix_bridge><emilytrau> https://www.chainguard.dev/unchained/fully-bootstrapping-java-from-source-in-wolfi
<matrix_bridge><Andrius Štikonas> emilytrau: they are missing some prebuilt jar files there
<matrix_bridge><Andrius Štikonas> Gcj comes with them I think
<matrix_bridge><emilytrau> has there been other published work on java?
<matrix_bridge><Andrius Štikonas> Well, guix does it correctly
<matrix_bridge><Andrius Štikonas> Which I also copied to my gentoo overlay: https://github.com/gentoo-mirror/gentoo-bootstrap#bootstrapping-story
<matrix_bridge><Andrius Štikonas> This starts with fastjar, jikes, gnu classpath 0.93 and jamvm 1.5
<matrix_bridge><emilytrau> very cool. i'm putting it on the list to bring to nix :)
<matrix_bridge><Andrius Štikonas> Yeah, I think gcj depends on ecj https://gcc.gnu.org/bugzilla/show_bug.cgi?id=37676
<civodul>gcj’s no more though
<stikonas>civodul: yeah, but that blog post describes building older gcc with gcj to bootstrap openjdk
<stikonas>which does not solve those ecj precompiled jar problem
<stikonas>you need to work quite a bit harder to bootstrap ecj
<civodul>indeed
<artemist>I've been working on a prototype of building mes on aarch64. I'm having some trouble with pointer sizes, is there a reason we're using m2-planet in bootstrap mode?
<artemist>It would be nice to be able to ifdef
<stikonas>artemist: are you using up to date code?
<stikonas>we have switched to bootstrap mode a year or so ago
<artemist>I was using the master branch, which does look pretty old
<stikonas>artemist: oh yes I think janneke usually works on other branches...
<stikonas>take a look at wip-riscv
<artemist>I'll try to rebase off there when I have more time, it sounds like that would probably fix a lot of my issues around syscalls and pointer sizes
<stikonas>tough those other branches can be rebased...
<stikonas>so you might have to keep rebasing your changes until the release
<stikonas>but yes, use something newer
<stikonas>artemist: also which M2-Planet are you using?
<artemist>Almost all of my changes are either "bad and not mergable" because I changed some constants or in a separate aarch64 directory, so it hopefully won't be too bad
<stikonas>M2-Planet needs to be from master
<stikonas>I've made some 64-bit fixes there too
<stikonas>basically master of that + wip-riscv of mes should fix most of 64 bit issues as we have managed to bootstrap tinycc on riscv recently
<artemist>Oh, I was using the nixpkgs one which isn't master, I can switch that. I've mostly been duplicating some work on getting 64 bit pointers and writing the necessary libc bits
<stikonas>let me find your the relevant commit...
<stikonas>if it's snapshot, you might already have it
<artemist>thanks!
<stikonas> https://github.com/oriansj/M2-Planet/commit/85dd953b70c5f607769016bbf2a0aa3de7e41b6c from April
<stikonas>(this particular commit fixes 64-bit globals, though only for little-endian arches)
<stikonas>but that's all we have right now anyway
<artemist>Probably won't matter for me, AIUI aarch64_be technically exists but nobody uses it
<stikonas>exactly...
<stikonas>oh, this commit might also be important for mes https://github.com/oriansj/M2-Planet/commits/master
<stikonas>anyway, just use latest M2-Planet from git too
<stikonas>argh, I meant https://github.com/oriansj/M2-Planet/commit/b908dac7c56e131595c04ba7ad550b6d55122e1e
<stikonas>artemist: this might also be relevant for you https://github.com/oriansj/M2libc/pull/17
<stikonas>(and PR is unfinished, so not merged)
<stikonas>might be good to merge at least the working bits before the next release
<artemist>Somehow I haven't had problems with m2libc, I guess I'm not at the point where it's being used
<stikonas>oh if you just build mes, you won't see them
<artemist>Thanks for all the links, I'll probably get back to this when I'm not on terrible train wifi
<stikonas>mes uses its own meslibc
<stikonas>but some helper tools from stage0-posix might be broken
<stikonas>e.g. "rm"