IRC channel logs

2023-08-20.log

back to list of logs

<fossy>is there a way to do alignment in hex2? (some kind of .align equivalent)?
<oriansj>fossy: yes <
<oriansj>< will align hex0 to the alignment requirement of the architecture
<fossy>i see
<fossy>our of interest, is arbitary alignment (eg to say 16 bytes) possible?
<oriansj>fossy: well the alignment is to the architecture for word access but we have <123 to pad an arbitrary number of null bytes
<oriansj>(in M1 of course)
<fossy>right, i see
<oriansj>and RISC-V and arm are 4byte align required
<oriansj>I don't think any architecture has a 16byte alignment requirement for word access and why we didn't have that specified ( most reasonable architectures just have byte alignment and nothing further than that needed)
<fossy>yea there's not really any reason why we'd need that, i was just interested
<oriansj>so effectively yes, we have < to do alignment but it only aligns to the address%4 as no architecture has a requirement beyond that (that I know of)
<stikonas>I don't think we really use alignment in hex2
<stikonas>or at least I don't remember seeing it in x86/amd64/riscv
<oriansj>stikonas: well x86 and AMD64 don't need it and we worked around it in RISC-V so that you wouldn't need to support alignment in the hex2.hex1 as you already had to implement a bunch due to risc-v needing the word support bits