IRC channel logs

2023-07-11.log

back to list of logs

<fossy>ummmm
<stikonas>yeah, I've now idea what is happening...
<stikonas>but I haven't tested it
<fossy>doras: can you confirm that this is the GCC 13 built _by_ live-bootstrap
<fossy>as far as i can see it is, but just want to double check
<stikonas>mescc fix for x86_64 32-bit integers turning to be negative is quite simple...
<stikonas>though I should still write the test
<stikonas>(which will also help us to test riscv64... But I now expect riscv64 to just work)
<stikonas>that was all it took to fix it https://paste.debian.net/1285552/
<janneke>stikonas: ooh...
<janneke>seems there are more instances of that meme in x86_64/as.scm
<doras>fossy: it is with gcc 13.1 built by live-bootstrap, yes. At that point of the bootstrap the only component we built ourselves is gnu-config. So the only inputs to the build are live-bootstrap + our own gnu-config + package sources.
<doras>fossy: this one line is the entire diff that results in binaries that crash: https://gitlab.com/freedesktop-sdk/freedesktop-sdk-binary-seed/-/merge_requests/57/diffs
<fossy>doras: thanks :)
<doras>It's our own after.sh that gets run at the end of sysc's bootstrap. It installs a selection of packages from live-bootstrap to create a subset of sysc. We currently install the latest version of every package built by live-bootstrap.
<vagrantc>i'd like to compile a list of the various active bootstrapping project and their rough status ... any suggestions?
<vagrantc>i'm familiar with mes and hex0 and all that ... there's an EFI bootstrap path ... and live-bootstrap ...
<vagrantc>was there something using fiwix as a kernel?
<vagrantc>stage0 on bare metal ...
<stikonas[m]>vagrantc: fiwix is integrated in live-bootsteap
<stikonas[m]>EFI is only stage0 stuff, no mes support
<stikonas[m]>So live-bootstrap can start with builder-hex0 then build fiwix and Linux
<vagrantc>stikonas[m]: thanks!
<vagrantc>is the final product of live-bootstrap generally bit-for-bit reproducible?
<vagrantc>have a talk on while i will be highlighting reproducible builds and bootstrappable ... though i'm a little weaker on the status of various bootstrapping efforts
<stikonas[m]>vagrantc: yes, it is bit by but reproducible
<stikonas[m]>Build script checks checksum after the build
<stikonas[m]>Which is committed into the repo
<stikonas[m]> https://github.com/fosslinux/live-bootstrap/blob/master/sysa/SHA256SUMS.pkgs
<stikonas[m]>In general you get reproducible builds in live-bootstrap almost for free
<stikonas[m]>Because 1.we have no initial toolchain that might introduce non reproducibility
<stikonas[m]>2. Install paths in live-bootstrap are fixed (we use /usr)
<stikonas[m]>so non reproducibility mostly comes when software explicitly tries to use current date or time
<stikonas[m]>which doesn't happen too frequently and we patch it out
<stikonas[m]>or we just remove stuff we don't care about, i.e. sometimes we just remove docs/manpages)
<stikonas>vagrantc: live-bootstrap though is x86 only for now (especially with kernel bootstrapping)
<stikonas>well, all full system bootstrapping is x86 only
<stikonas>though we are not too far from bootstrapping tcc on x86_64
<vagrantc>ah, keep forgetting about x86 only
<vagrantc>i think the guix bootstrap bootstraps an x86 toolchain and then presumably cross-compiles an x86_64 toolchain from that ...
<stikonas[m]>Indeed
<stikonas>janneke: is there an easy way to force make check in mes to use mescc?
<stikonas>it seems to use gcc for me
<janneke>stikonas; if gcc is available, it will use gcc
<janneke>...but it's pretty easy to edit ./check.sh and comment-out/disable the
<janneke>if test $compiler = gcc; then [...]
<janneke>bit
<stikonas[m]>OK. It's just that M1 overflow test is useless with gcc