IRC channel logs

2023-07-10.log

back to list of logs

<stikonas>oriansj, janneke, ekaitz: so limitation of 32-bit numbers that I encountered while trying to build tinycc comes from M1...
<stikonas>mescc just spits out %0xedab1234
<stikonas>hmm, actually that might be only limitting factor for x86_64 and not riscv
<stikonas>I think on riscv64 we do have a code to deal with that
<stikonas>perhaps shoudl also teach x86_64 codegen to not emit %number for 32-bit numbers
<stikonas>I guess we need to use #:immediate8 more carefully
<stikonas>i.e. instead of (if (and (>= v 0) (< v #xffffffff)) we might have to use #x7fffffff
<doras>Hi. I recently updated freedesktop-sdk-binary-seed to the latest commit in live-bootstrap, and switched to GCC 13.1 while at it. While the update worked, the switch to GCC 13.1 didn't. It seems that we're getting segmentation failures in binaries built with it.
<doras>I didn't have time to investigate this, and likely won't have time in the near future, so just letting everyone know.
<doras>You can see the failing CI job here: https://gitlab.com/freedesktop-sdk/freedesktop-sdk-binary-seed/-/jobs/4621568706
<doras>It seems like every project we try to build with ends up with binaries that crash at runtime. For example, here's a segmentation fault from attempting to build `file`:... (full message at <https://libera.ems.host/_matrix/media/v3/download/libera.chat/92922d61100105051931290ecfb8e1a64a16f70c>)
<stikonas[m]>fossy: ^
<muurkha>well, debugging compilers does often result in spending significant time trying to figure out why the code they generated dumps core